AmiKit - Your Modern Retro Amiga Experience
 Begin Register Reply Search Statistics Quick Guide  
Online now: Guests - 2
Members - 0
Most users ever online: 717 [7 Feb 2021 09:33]
Guests - 717 / Members - 0
Miscellaneous topics AmiKit Support Forum / Miscellaneous topics /  
 

New versions of P96 on AmiKit XE

 
Author AmiKit
Admin
#1 Posted: 5 May 2021 22:05 Edited by: AmiKit 
Hey, due to spam messages which appeared in the original thread I accidentally deleted the whole thread (instead of those spam messages only). I am very sorry about that. And I am afraid that was not the only thread I deleted (panic, panic!)

If you were the author of the thread, can you post the question again, please?

Author fehmi
Partaker
#2 Posted: 6 May 2021 00:39 
No worries, Jan. I hope you were able to resolve the spam issue for good.

I had also posted my question in the P96 thread on EAB @ http://eab.abime.net/showpost.php?p=1480807&postcount=126

I installed P96 3.0.2 on AmiKit XE. When I try screen dragging with ChaosPro, I am able to drag the screen and see Workbench behind it. However, navigation with the mouse is pretty much broken. For instance, when I move the mouse up to Workbench, even though the cursor is still visible on the ChaosPro screen, mouse buttons are registered on Workbench. I can only navigate on Workbench by blindly clicking on random spots. That said, once I reach to ChaosPro window by trial-and-error, I can either drag the screen up or close the program without any issue.

I tried the same with Workbench 3.X that came with Amiga Forever 9 - I replaced the stable WinUAE with Beta 19 and ensured 32-bit version is launched by choosing "Play with WinUAE (32-Bit)".

I was able to drag the ChaosPro screen and the cursor was visible on Workbench when I moved the mouse up. However, I encountered another issue this time - the cursor was invisible on the lower screen. I had to click blindly to find the right spots. Also, random horizontal bars started to appear in the screen below and there was even a second mouse cursor left-over - see the screenshot -
http://eab.abime.net/attachment.php?attachmentid=71796&d=1620079043

In short, screen dragging didn't work properly in either AmiKit or Workbench 3.X; that is why I believe there is an issue with the new P96 UAE driver (also pointed out by Thomas). However, as screen dragging exhibits different behaviors under AmiKit and Workbench 3.X, can you please give this a try when you get the chance? I will be happy to report any of your findings on EAB.

Below is a breakdown of my setup:

WinUAE 4.9 Beta 19 (also tried beta 3, 16, 17, and 18)
Picasso96 3.0.2
Workbench 3.X and Kickstart v3.1 (amiga-os-310-a1200.rom) from Amiga Forever 9
AmiKit XE 11.4.2 (default configuration - attached)
Windows 10 20H2
GeForce RTX 2070 Super (tried drivers 466.11 and 466.27)

Author AmiKit
Admin
#3 Posted: 6 May 2021 19:40 
Hi Fehmi, thank you for posting that again. And sorry again for the mess - it's been busy here lately. I will test the scenario you described ASAP and let you know!

Author AmiKit
Admin
#4 Posted: 14 May 2021 01:00 
Hey Fehmi, I can confirm the mouse cursor behavior is quite strange when using screen dragging. I tested AmiKit XE installed with Amiga Forever, WinUAE beta 19, and P96 3.0.2.

I drag the screen 1 half way down, and I can see the screen 2 behind it. As it should be.
But then I move my mouse cursor a bit up, it should appear on screen 2, right? But it appears on the bottom of the screen 1.

And here's something even more weird - while the cursor is displayed on the bottom of the screen 1, physically it is up on the screen 2. I know that because if I press and hold left mouse button, and move the cursor (which is still displayed on the bottom of the screen 1), the square area is actually marked on the upper screen 2.

See the screenshot:

Here's something interesting. If I enable Virtual Mouse Driver "Show Both Cursors" in WinUAE/GamePorts, I can actually see the Windows pointer on the upper screen 2 while the Amiga pointer stayed on the bottom screen 1. Then there are 2 mouse pointers visible at once.

Hope it helps?

Author fehmi
Partaker
#5 Posted: 14 May 2021 01:25 
Thank you, Jan. Your findings basically mirror mine - the mouse navigation is pretty much borked once I drag the screen down and move the mouse up to the WB screen.

I also tried screen dragging on WB 3.X from AF9. This time the cursor was visible on the top screen (i.e. WB) after I dragged the screen; however the cursor was invisible on the ChaosPro screen at the bottom - see the screenshot in my previous post.

My understanding is that the P96 UAE driver that comes with WinUAE is somewhat broken. My post in P96 thread did not seem to draw Toni's attention so I will post in support.WinUAE instead.

Author fehmi
Partaker
#6 Posted: 17 May 2021 02:14 
I made a new post in the P96 thread -
http://eab.abime.net/showpost.php?p=1484020&postcount=136

As I have noted there, setting SoftSprite=Yes vs SoftSprite=No in the monitor icon did not make a difference for me.

I believe I made the change properly; however, could you please give it a try once you get the chance?

Author fehmi
Partaker
#7 Posted: 15 Jun 2021 02:03 Edited by: fehmi 
fyi - Toni fixed the issue with screen dragging on beta 22 -
https://eab.abime.net/showpost.php?p=1490376&postcount=684

Author AmiKit
Admin
#8 Posted: 15 Jun 2021 07:21 Edited by: AmiKit 
Nice! Thanks for letting me know and thank you so much for taking care of this issue, Fehmi!

And please excuse my passivity - I reverted to using the free Aminet version of Picasso96 v2.0 in emulation as I personally don't actually see much (or any) difference to the new v3.x version (which, on top, requires a payment once a year, you know). Perhaps on real Amigas it's more useful.

Author fehmi
Partaker
#9 Posted: 16 Jun 2021 00:16 
No worries, Jan. There is definitely no need to apologize! I can definitely see where you are coming from regarding screen dragging - it is cool to have but the novelty wears off quite fast. I am also not a fan of annual payments for P96.

Also, I believe I was the only person who ever tried screen dragging on WinUAE because no one (including Toni) actually noticed that it had been broken for 21 beta releases

Author AmiKit
Admin
#10 Posted: 16 Jun 2021 00:25 
That makes us the only two persons who ever tried it

Author fehmi
Partaker
#11 Posted: 16 Jun 2021 00:31 
Shoot! I totally forgot about you!!

Author AmiKit
Admin
#12 Posted: 16 Jun 2021 00:36 

Miscellaneous topics AmiKit Support Forum / Miscellaneous topics /
 New versions of P96 on AmiKit XE

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑