AmiKit Support ForumAmiKit Discord Chat
 Start Register Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 717 [7 Feb 2021 09:33]
Guests - 717 / Members - 0
Miscellaneous topics AmiKit Support Forum / Miscellaneous topics /  


Author AmiKit
#1 Posted: 22 Nov 2018 22:06 
Some of you asked for instructions on how to run AmiKit on FS-UAE... Here you are:

Author Craziazkowboi
#2 Posted: 24 Nov 2018 03:33 
Thanks for the instructions, is there no way to do it from the Mac install? I don't mind paying again, but paying for a Windows install that I'm never going use after the interim copy seems a waste.


Author AmiKit
#3 Posted: 24 Nov 2018 08:56 
Yes, it should work from the Mac install as well.

Btw. the reason of transferring the data from AmiKit's hardfile to another one is that the AmiKit hardfile is of dynamic type and FS-UAE doesn't support it.

Author Craziazkowboi
#4 Posted: 27 Nov 2018 13:19 
OK, I have followed the instructions above, and I have an AmiKit directory with the files all there. I select the same kickstart as the AmiKit Installer, and tell FS-UAE to mount my Amiga OS3.9 CD ISO. It boots fine, and asks for the Amiga Files, I click the button to use my Amiga OS39 CD, it finds the CD fine and is about to copy the files across, but stop with an "CopyReplace failed return code 20". I tried a number of other kickstarts, and checked my permissions on the Mac side - set to read/write. Interestingly, if I use the new Amiga OS 3.1.4 kickstart, the same error appears int he shell window, but it continues to copy files anyway - but then fails to load properly, and if it does load, crashes really fast. I've also tried using both the stable and the Dev version of FS-UAE with the same result.

Can I copy the files manually to get around this? Any ideas or thoughts on what's going on to cause a return code 20 (pretty serious software crash)?

Thanks Again.

P.S. I'll get some new instructions written once I have this going - the current instructions got me to this point, but they could use some help.

Author AmiKit
#5 Posted: 27 Nov 2018 13:23 
That error message usually pops up if there are multiple drives named AmiKit. In that case the installer is confused where to install the system files...

Author Craziazkowboi
#6 Posted: 1 Dec 2018 16:38 
Let's try and improve those instructions (seriously, the instructions in the link, kinda blow-dog).

So you have an Apple Mac and you want to install AmiKit (which uses WinUAE via Wine) on FS-UAE, who knows why you want to, you just do...because you can.

The speed of AmiKit on a modern Mac is fine, it plays everything great! Previous experiments had shown no noticeable gain upgrading the version of Wine and WinUAE in the AmiKit install. So, I wanted to see if there was a performance improvement by not using Wine.

I am using Amiga OS 3.1.4 (A1200 version) on my Mac Pro, with a Geekbench single-core score of 3854 (to compare these results with what you might expect from your own rig).

Spoiler Alert:
FS-UAE might be faster than Wine, but I'm not convinced you'll notice:

SysSpeed says yes:

MIPS. 1813.34
MFLOPS 1484.68

MIPS. 2475.15
MFLOPS 2079.07

SysInfo shows a slightly different result:

MIPS 580.21
MFLOPS. 44.39

MIPS 451.99
MFLOPS. 63.80

FS-UAE + Blizzard 060
MIPS 32.11
MFLOPS. 10.33

Both results are waaaay faster than a stock A4000, and capable of modern computing.

The 060 experiment shows emulating an Amiga 1200 with a Blizzard 060 accelerator card is 1.68 times faster than a stock A4000 040 25Mhz. Not really up to modern computing demands, and much slower than emulating the 020 with very little practical advantage, but still plenty fast enough to run your games.

A note on running WHDLoad games from FS_UAE and AmigaOS- using an Amiga faster than stock causes a bad flickering problem in at least a couple games, Nitro and IK+ (and its not an old .slave file issue). They work fine using FS-UAE with the original speed & config Amiga, or outside FS-UAE using the Wine AmiKit install, but they hiccup with FS-UAE running any AmigaOS and blazing fast (with or without an accelerator). It's not JIT either, as even with JIT off and using an 040 or 060 the same graphic error occurs. Most games work perfectly with no glitches, but my favs Nitro/IK+ suffer. So I play them using the Quickstart (File & Game database) options in FS-UAE, not from inside the AmigaOS.

Enough, lets move on. Getting an AmiKit drive into FS-UAE then...

You will need a Workbench boot floppy. I used a Workbench 3.0 .ADF file.

1. Install AmiKit on your Mac (no need to start a virtual machine and do the windows version and all that blah blah from the previous instructions)

2. I completed the AmiKit instructions through to the point where I had a bootable AmiKit install, and I let it install all the latest patches etc. I also did the upgrade to Amiga OS 3.1.4 (A1200 version - make a purchase on the Hyperion website http://hyperion-entertai<wbr><wbr><wbr> and support your girlfriend (the Amiga)).

3. I could not use the AmiKit install in FS-UAE. I get an error with the initial AmiKit install if I try to run it in FS-UAE, an error 'CopyReplace failed return code 20' - which is a fatal software error (at the point where it copies the files from your choice of Amiga OS 3.9 CD, Amiga Forever etc...); and an FS-UAE error about an unimplemented feature 52... anyway, it doesn't work, so do the initial install all the way using the AmiKit install and follow the AmiKit instructions.

4. Exit AmiKit. If you are using the default install of FS-UAE, then go to "Documents" on your Mac, and navigate to (or create the folders if you have not installed FS-UAE yet)

/Documents/FS-UAE/Hard Drives

create new folder and call it AmiKit_FSUAE (call it anything you want, but don't call it AmiKit as this is already used by AmiKit..duh)! Don't close the finder window yet.

5. Right click on AmiKit and choose "Show package contents". Then navigate to:


and copy a Workbench boot disk in ADF or DMS format here. I used a Workbench 3.0 .adf image, I don't think it will matter which WB you use for this next step. Keep it simple.

6. Navigate to:

Copy the RabbitHole folder to /Documents/FS-UAE/Hard Drives
Copy the Dropbox folder too, if you use that. I don't, so I left it out and it has not caused me any grief.

7. Relaunch AmiKit and choose 'Configure' - do not hit 'Launch'. Click on Floppy Drives, and put a Workbench disk into DF0: I put a Workbench 3.0 .adf disk image in DF0: to boot from. Do not start WinUAE yet.

8. Click on 'CD & Hard drives' and then on "Add Directory or Archive". Click on "Select Directory". Click on 'My Documents', 'FS-AUE', 'Hard Drives' and 'AmiKit_FSUAE' (or whatever you named the folder from step 4 above - from here on, I just assume you have used AmiKit_FSUAE) and click the 'open' button. Click OK.

9. (Give thanks to your favourite Deity), and click the start button in WinUAE.

10. If your Mac shows a message asking for Wine to control your computer, hit 'Deny'. it doesn't need sh.t.

11. Hopefully your workbench boot disk has started your amiga, and the familiar desktop shows up (looks fugly these days, heh?). Hopefully you see an 'AmiKit' and an 'AmiKit_FSUAE' icon.

12. Open WorkBench disk, open the System drawer, and open the Shell application in the Amiga you just booted up. In the Shell window type:

copy AmiKit: AmiKit_FSUAE: all quiet clone

Give your machine time to copy the almost 1Gb across. The Shell won't show you much love, if you want to see some action, just ask your Deity to grant you patience, but could they hurry-up.

....still waiting... My Mac has an SSD drive (not the bottleneck here) and took about 8 minutes before the command prompt reappeared in the Shell window. You can see it's doing something by the flashing "HD" icon at the bottom of the emulator window, or right clicking the AmiKit_FSUAE folder and choosing 'Get Info' (or select the folder and press CMD+i)- and watch the folder size grow before your very eyes.

13. With that done, close WinUAE, don't save anything - then you can go back to using AmiKit has designed should you wish.

14. Install/Open FS-UAE. I use the latest stable version, which at time of writing is v2.8.3.

15. If you have not already done so, copy your Kickstart rom to

If you purchased a digital copy of Amiga OS 3.1.4, the correct ROM is under<wbr><wbr><wbr>ROMs/unsplit_un<wbr>swapp<wbr>ed/ki<wbr>ck.a1<wbr>200.46.143<wbr>

16. I assume you know your way around FS-UAE to a basic level here. The FS-UAE website has good help if you need it. Create and save a config as follows:

a. Amiga Model A1200, using a 3.1 ROM and 68020 CPU, High Accuracy (as above, any other CPU will actually be slower, or not provide the right features to make this work). Nothing in the Floppy Drives.

b. Set Amiga Joystick to your gamepad or Joystick of choice (you need a gamepad/joystick connected to your Mac before it will be available in the drop down list here)

c. Set your first hard to the folder /Documents/FS-UAE/Hard Drives/AmiKit_FSUAE
d. Set your next Hard Drive to /Documents/FS-UAE/Hard Drives/RabbitHole
e. If you have a folder with unzipped WHDLoad files ready to use, then add that hard drive in as well.

f. Set your Kickstart ROM: to a 3.1 ROM, or if you have upgraded to Amiga OS 3.1.4, set this to the kick.a1200.46.143

g. Set Chip RAM to 8Mb (woohoo!), 0Mb Slow RAM, 0Mb Fast RAM, 0Mb Motherboard RAM, 0Mb Accelerator RAM

h. Tick the checkmark boxes for Zorro III Fast Memory and Graphics Card RAM and set both to 256Mb (go higher if you want - but what the heck are you doing that needs that much, and really - should be using an emulator for that work??)

i. Under Expansions, do not have tick in the Accelerator or Blizzard SCSI Kit checkmark boxes
j. Put a tick in the checkmark box for Graphics Card and set this to UAEGFX Zorro III
k. Put a tick in the checkmark box for UAE bsdsocket.library, and set this to Enabled

l. Put a tick in the checkmark box for CPU and set to 68020 (not the EC model)
m. Put a tick in the checkmark box for JIT Compiler and set this to Enabled
n. <optional> I also put a Put a tick in the checkmark box for Floppy Drive Speed and set this to 800% - potentially a problem for loading disks, but I have not had an issue yet.

o. Click the Custom Configuration button and add the following lines:
uae_cpu_speed = max
uae_fpu_model = 68882
uaem_write_flags = nhsparwed

This tells FS-UAE to use a math co-processor (the 68882), and to run the 68020 at the fastest speed possible by your rig. The uaem_write_flags is from the previous instructions, and here for safety, but likely unneeded as the default for FS-UAE is to have all these turned on anyway.

17. Give your new config a name and hit the save button!

18. You can tweak other settings in FS-UAE by clicking he Amiga logo icon in the top left of the FS-UAE config window, and from the drop-down, select Settings. You can set the location to search for games (folder on your Mac, zip files OK to use) using the File Database options, and download the latest Game Database from her

Author Craziazkowboi
#7 Posted: 1 Dec 2018 16:56 
19. Hit start, or copy your WHDLoad.key to \Documents\FS-UAE and \Hard Drives\AmiKit_FSUAE\Devs

Author Craziazkowboi
#8 Posted: 2 Dec 2018 01:17 
On my Mac:

Upgrading AmiKit to v10.5.2, Upgrading Wine to v3.01 (from the standard install of v2.00), and upgrading WinUAE to v4.01 sees a small performance gain:

SysInfo says:
MIPS 979.23 way up from 580.21!!
MFLOPS 47.15 small increment from 44.39

SysSpeed says:
MIPS 2106.86 up from 1813.34
MFLOPS 18.6 - mm...something not right...

While I was at it, I thought I would see how the Dev version of FSUAE performs - it's slightly slower than the stable version on the Mac at present (using FS-UAE 2.9.7 dev 2):

SysInfo says:
MIPS 499.25 up from 451.99
MFLOPS 63 down from 63.80

SysSpeed says:
MIPS 2366.17down from 2475.15
MFLOPS 1772.56 down from 2079.07

Author Craziazkowboi
#9 Posted: 21 May 2019 15:38 
Yo fellow AmiKit enthusiast,

I upgraded my AmiKit to the new v11 AmiKit XE, and then upgraded Wine manually to V4.01 and WinUAE to V4.2.1 on my Mac, and wow there is yet another speed improvement - Jan you are amazing!! It did feel snappier, so what would SysSpeed and SysInfo say?

SysInfo Says:
MIPS: 892.7 waaay up from 580.21 using older Wine/AmiKit v10
MFLOPS: 47.95 up from 44.39 using older Wine/AmiKit v10

SysSpeed Says:
MIPS: 2080.29 up from 1813.24 using the old Wine/AmiKit v10
MFLOPS: 1460.53 slightly down from 1484.68 using the older Wine/AmiKit v10

And of Course AmiKit under Wine plays everything perfectly - I.e. the flickering graphics issues seen playing Nitro within AmiKit on FS-UAE do not occur when using Wine/WinUAE.

I also tried running these tools under FS-UAE using the new and shiny AmiKit XE:

SysInfo Says:
MIPS: 523.42 up from 451.99 on AmiKit v10 and FS-UAE 2.8.3
MFLOPS: 63.25 slightly down from 63.8 on AmiKit v10 and FS-UAE 2.8.3

SysSpeed Says:
MIPS: 2594.6 up from 2475.1
MFLOPS: 15.66

I'm sooo in love with AmiKit!!


Author Craziazkowboi
#10 Posted: 12 Jul 2019 15:45 
Hello Again,

So I only just noticed FS-UAE v3.0 has been released, YAY!! I've updated my AmiKit FS-UAE install, and re-run Sysinfo and Syspeed again to see if there is any difference according to these programs:

MIPS: 598.79
MFLOPS: 63.59

MIPS: 2364.6
MFLOPS: 15.66

Unfortunately the flickering graphics issue in IK+ and Nitro remain an issue when using WHDLoad from AmiKit, but run without glitch if run from FS-UAE Launcher. Maybe there is something about WHDLoad running from AmiKit they don't like?

Author AmiKit
#11 Posted: 12 Jul 2019 15:53 
Thank you for your report. I don't use FS-UAE so I am afraid I cannot be of much help here. Maybe ask Espen?

Best regards,

Author Rohit118
#12 Posted: 4 Sep 2019 17:46 
nice info

Author danica_talos
#13 Posted: 9 Nov 2019 17:07 
Works my Flowerpot AmigaOS 4.1 in FSUAE?

Author AmiKit
#14 Posted: 10 Nov 2019 11:32 
Hello Danica,

FlowerPot is based on WinUAE, just like AmiKit is. If you want to use FS-UAE instead, you can follow the instructions here: The guide describes how to transfer AmiKit to FS-UAE, but the procedure should be quite similar with FlowerPot too.

Hope it helps!

Miscellaneous topics AmiKit Support Forum / Miscellaneous topics /

Your Reply Click this icon to move up to the quoted message

Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


AmiKit Support Forum Powered by Forum Script miniBB ®