AmiKit - Your Modern Retro Amiga Experience
 Start Register Search Statistics Quick Guide  
Online now: Guests - 2
Members - 0
Most users ever online: 717 [7 Feb 2021 09:33]
Guests - 717 / Members - 0
Miscellaneous topics AmiKit Support Forum / Miscellaneous topics /  

Android mouse issues

Author amyren
#1 Posted: 6 Apr 2017 08:04 
I did install AmiKit on my Galaxy Tab4 10.1". (purchased from google play together with cloanto essensials).

As I already own both the OS3.5 and 3.9 Cd's I wanted to make use of these to install amikit. This was not so easy as I thought. The instructions does mention copying the os files, but not to specific which folders from the CD that is needed. I also tried using an ISO file as source, but this didnt work. At last I got it right somehow, but I had many tries before the AmiKit installation program did finally accept that I had the OS files present.

But once installed, I found that the mouse emulation within AmiKit was very ackward to use on a touchscreen. I found that moving the mouse pointer also activate the LMB so it was impossible to use.
I then connected a real mouse (tried both a bluetooth mouse and a USB mouse), but this seem very unstable in AmiKit. Most of the time it does require me to press and hold LMB in order to move the cursor abound. I think its not AmiKit specific, since I found the same issue when using UAE4arm in general.
I have been in the device setting menu and checking that the laptop mode is enabled, and sometimes it does work ok. But next time I start AmiKit it may work or not, so it seem very unstable.

I also have other issues using uae4arm and the joystick emulation. I cant find a way to get the joystick working with a phsyical keyboard. The keyboard works well inside the emulation as a normal keyboard, but I cant get any response when setting custom keys to the joystick settings.

Am I the only one with theese issues or are this known bugs with uae4arm? If they are know, they are hopefully being worked on?

Author AmiKit
#2 Posted: 7 Apr 2017 14:12 
Anbjörn, is that you?? Long time no speak. Hope you are well.

Regarding the Android port, this is little bit an experimental side project as UAE4ARM is not as developed yet as I would like to.

I've already notified Lyubomyr, the guy who ported UAE4ARM to Android, to check the issues. Let's see what he can do about it.

Regarding the installation, do you remember where was the bottleneck exactly? I will update the installation instructions as it seems you're not the only one struggling here.

Author amyren
#3 Posted: 7 Apr 2017 22:22 
Hi Jan. I'm fine, thanks for asking

I did re-read the instructions on google play just now, and I theink either I must have missed something important when reading it the first time, or they have been updated since then. As they apear now, its quite clear how the files should be copied from the OS3.9 cd and where they should be put.

Not being sure what and where to copy these files I think was my main bottleneck when installing this, trying various folder combinations from my CD and putting them on different locations in android. I had to move the Amikit installation files to extSD due to space limitation, so this made me even more uncertain about where the files should be put. I also started to suspect that windows didnt copy the os files correctly from the OS3.9 CD (windows tend to convert the filenames to uppercase) I then tried mounting an os3.9 iso imagefile in uae4arm, but this didint work either. After trying x-number of times I start to forget what I had tried and not tried, so it was a relief at last when it suddenly accepted my installation.

BTW the link on google play to the pdf instructions does not work for me. points to and gives me a 404 error page.

Author FatAgnus
#4 Posted: 19 Apr 2017 23:05 

could you please let me know how to start that AmiKit installation program manually?
I, too, had problems finding the right files to copy and knowing where to copy them to on the Android port.
Unfortunately I could never figure it out and so I ended up using the setup dirs from the Amiga Windows kit to start up the AmiKit engine in the Android port. Yet now I got an bare bones Amiga engine, that starts up from two directory "drives" and I can not figure out a way how to finish the installation process.

Author amyren
#5 Posted: 22 May 2017 12:36 
FatAgnus: Sorry for late reply

Please read the instructions on google play carefully. I think they have been updated so they explain it better.
As for starting the installation manually, I have not tried that. But the Amikit app will download a hdd file for AmiKit that basically contains a hdd that boots into the installation script.
So if you need to do that manually, I suggest you copy that hdd file to a pc and mount it so you can get that script.
But I dont think that is needed if you can do this by getting the files into the correct place it will install automaticly with much less work.

Here is a copy of the current instructions:


1) First, the application will download the latest AmiKit hardfile (a virtual harddisk) to android/data/sk.amiga.amikit.arm/files folder of your device automatically.

2) You will need Amiga Kickstart ROM 3.1 file to run the emulator. Either install the Amiga Forever Essentials from Google Play OR copy the ROM to android/data/sk.amiga.amikit.arm/files/ROMs folder manually (see PDF for details).

3) You will need Amiga OS files. If you have OS3.9 CD, copy its entire content (including file) to the AmigaOS3.9 subfolder of android/data/sk.amiga.amikit.arm/files folder. If you have different CD, copy its entire content to the corresponding subfolder („Amiga Forever“ or “AmigaOS XL“ or “AmigaOS3.5“).

Regarding Amiga Forever, installed it on your computer first, then locate the folder containing C, Classes, Devs... etc. including file, and copy its entire content to your phone to the following folder: android/data/sk.amiga.amikit.arm/files/AmigaForever


You can pack the content of the folder (or CD) to a ZIP file (audio and video folders of AmigaOS3.9 CD are not necessary), upload the archive to your GoogleDrive or Dropbox and then use Total Commander with GoogleDrivePlugin or DropboxPlugin to download and unpack the archive to the corresponding folder of your phone.

AmiKit should be ready to use now!

Miscellaneous topics AmiKit Support Forum / Miscellaneous topics /
 Android mouse issues

Your Reply Click this icon to move up to the quoted message

Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


AmiKit Support Forum Powered by Forum Script miniBB ®