AmiKit - Your Modern Retro Amiga Experience
 Begin Register Reply Search Statistics Quick Guide  
Online now: Guests - 2
Members - 0
Most users ever online: 324 [28 Nov 2019 07:12]
Guests - 324 / Members - 0
Specific questions AmiKit Support Forum / Specific questions /  

Amikit very slow

Author Andrew
#1 Posted: 6 Dec 2009 04:35 Edited by: Andrew 

I'm new to Amikit but not quite so to Amigas /emulation. I have installed Amikit 1.5 with Amiga OS 3.9 CD and have opted for the Magellan install. I have used WinUAE on my current PC with Zero slowdown problems whatsoever. However I seem to get VERY slow graphics and a mouse trail when trying to use Amikit

Trying to run in 1280x1024. it boots fine, but trying to "do anything" is horribly slow. Surely it can't be my PC ?


Intel QX6850 Quad core Extreme @ 3.0
4.0 GB Ram
2xWD raptor 150 GB in Raid 0
Ati Radeon 3870 x2 Graphics
Windows 7 Ultimate x64

So it must be some setting in winuae or Amikit (I've replaced the winuae.exe included with the Amikit package with latest and get same symptoms with both) and set up a "reasonable config", I cant even install the boingbags for 3.9 as the slowness/graphics corruption means I can barely see dialogue boxes when they appear.

.... what am I missing ?



Author AmiKit
#2 Posted: 6 Dec 2009 09:42 Edited by: AmiKit 
Hi Andrew and welcome to AmiKit.

There are 5 usual possible slowdown causes:

* bad powersaving driver, it causes timer that WinUAE uses to return bogus values. Basically AMD-only issue, make sure bios is latest and Cool'n'Quiet driver is up to date, or disabled.

* CPU Idle setting in CPU-panel set too high. 1 or 2 step from left is good test setting.

* Priority in priority-panel set to High. In some cases Normal can cause similar problems, usually only when CPU Idle is disabled. Try "Low". (low does not mean low emulation speed)

* some realtime virusscanners can slowdown harddrive emulation (can also be related to priority setting)

* vsync, make sure vsync in display panel is disabled.

First 3 settings are very PC/Windows/driver version specific.

Recently it was reported that some antivirus software (like Norton or Webroot) might be the reason for huge slowdowns. Disable your antivirus before you start AmiKit to find out. If it helps, try to add some exception for WinUAE.exe process or whole AmiKit folder when you enable it again. Or use better antivirus software.

Author Andrew
#3 Posted: 6 Dec 2009 13:24 
Thank you for the welcome

Here is what I have tried so far, with the same results:

Antivirus disabled
CPU IDLE 2 from left.... all the way up to max (right)
Priority set to low
Vsync was the first thing I checked... it is permanently off.

Powersaving driver... you say it is an AMD only issue... I am on an intel machine so *shrugs*

I will go look in BIOS next.



Author AmiKit
#4 Posted: 6 Dec 2009 13:52 Edited by: AmiKit 
What antivirus do you use? Similar problems were reported with Norton 360.

When you referred to your own WinUAE setup which doesn't suffer from slowdowns, do you use hardfile or PC folder to store your Amiga files? AmiKit uses the folder and this is something that Norton 360 didn't like.

Author Andrew
#5 Posted: 6 Dec 2009 14:14 

I use Kaspersky Antivirus 2010. My Winuae actually runs the CF Hard drive that I use in my A1200 using the "add hard drive" option. However I have also used hardfiles without problems.


Author AmiKit
#6 Posted: 7 Dec 2009 00:03 
While hardfiles and real HDs are OK, storing Amiga files in PC folder may be problematic for some antiviruses. Are you sure the Kaspersky got completely disabled? Or isn't it possible to add some exception for WinUAE task?

Alternatively it is possible to convert AmiKit folder to hardfile. More info here:

Specific questions AmiKit Support Forum / Specific questions /
 Amikit very slow

Your Reply Click this icon to move up to the quoted message

Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


AmiKit Support Forum Powered by Forum Script miniBB ®