AmiKit - Your Modern Retro Amiga Experience
 Begin Register Reply Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 324 [28 Nov 2019 07:12]
Guests - 324 / Members - 0
Specific questions AmiKit Support Forum / Specific questions /  

Is GlobalTrash broken?

Author DamnRight
#1 Posted: 8 Apr 2019 15:22 Edited by: DamnRight 
- your AmiKit version number: 10.5.2
- is it Windows, Mac or Linux installation? Windows 10 - 64 bit
- which AmigaOS version have you used to install AmiKit? Amiga Forever KS ROM v3.1 (A1200) rev 40.68 (512k) - default
- which Amiga desktop manager do you use - Directory Opus (default), Workbench or Scalos? - Directory Opus (default)

All attempts to send anything to the Global Trashcan fail; the list becomes Busy and never finishes the process - only solution is to reboot AmiKIT.
Steps to reproduce:
Open Text/REdit
enter some text
Project/Save As - name it
Close Redit
Open AmiKIT Drive
display as text
Locate and highlight the new item
Click Trash ICON

cursor changes and lister window status goes to Busy
effectvely locking the lister from any other action
item never goes to Trash, process never ends

Have to reboot AmiKIT to regain control .

Also - OPEN GlobalTrash does nothing.

DELETE ("X") works as a workaround.

Never checked this before updates, so I can't say if it worked before 10.5.2 (or if it worked on version 8).
Does it work with AmigaOS 3.1.4?

Author AmiKit
#2 Posted: 8 Apr 2019 20:57 Edited by: AmiKit 
You're damn right Thank you for your report.

I assume double-clicking the Trashcan icon on desktop doesn't do anything either.

Could you please confirm the following actions fix the problem?
1. reboot
2. right-click the Trashcan icon located on desktop and select Un-Snapshot
3. reboot

Author DamnRight
#3 Posted: 8 Apr 2019 21:32 
Your assumption was correct... and better yet, your FIX worked!

Was this something I did, or does everyone have to do this to restore functionality?

Author AmiKit
#4 Posted: 8 Apr 2019 21:41 
Thanks for your confirmation. It's happening here as well, so I am afraid it's a GlobalBug ;) I am still investigating the conditions, though. There are more variables, eg. AmigaOS version is one of them.

Specific questions AmiKit Support Forum / Specific questions /
 Is GlobalTrash broken?

Your Reply Click this icon to move up to the quoted message

Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


AmiKit Support Forum Powered by Forum Script miniBB ®