AmiKit - Your Modern Retro Amiga Experience
 Begin Register Reply Search Statistics Quick Guide  
Online now: Guests - 2
Members - 0
Most users ever online: 324 [28 Nov 2019 07:12]
Guests - 324 / Members - 0
Specific questions AmiKit Support Forum / Specific questions /  

Launching Google Drive Error

Page  Page 2 of 2:  « Previous  1  2

Author DamnRight
#16 Posted: 10 May 2019 21:43 
and... after deleting files, copying the new code and rebooting.... Google Drive fails to run.....

Author AmiKit
#17 Posted: 10 May 2019 23:06 
Hi, I've just tried AmiKit X 10.5.3, set up GoogleDrive, launched AmiKit:Devs/Google/GoogleDrive and it worked. Upgraded to 11.0.0, launched AmiKit:Devs/Cloud/GoogleDrive and it worked with the very same client code.

Please make sure the client code is located in AmiKit:Devs/Cloud folder.

Author DamnRight
#18 Posted: 11 May 2019 03:59 Edited by: DamnRight 
SOLVED part of the problem (I think):
your Taskbar Menu called TOOLS has a "Google Drive" item
BOTH the IMAGE and the APPLICATION are set to use
when I updated them both to use
the item on the menu now has an icon and it launches Google Drive

BUT it then fails first login with an Invalid Grant & Bad Request Error.... so close...

this locks AMIKIT and I have to reboot.... and I don't get the token files back that I deleted....

It worked for you, I bet, because you, as a developer, launched from the file system rather than, as an end-user, from the menu system.

So.... I copied in a "fresh" token... good news - no errors, bad news- nothing executed... Do I need those deleted token files back??

Author AmiKit
#19 Posted: 11 May 2019 11:24 Edited by: AmiKit 
Oh, in AmiStart! So you found a bug ...and ruined my new release celebration Next time you join our beta tester team!

What do you mean by "nothing executed"? The Google Drive is now located in AmiKit:Devs/Cloud folder. Can you follow the program instructions (located in that folder) and activate the drive according to them? Let me know what did not exactly, please.


Author DamnRight
#20 Posted: 11 May 2019 14:54 Edited by: DamnRight 
When I Open the Google Drive located in the AmiKit:Devs/Cloud folder, I get a window with this text inside:
RUN > NIL: wait -gui 2 wt="Mounting Google Drive (configure it in AmiKit:Devs/Cloud)" BIG

and nothing else......

When I use the fixed AmiStart link to run Google Drive - I see nothing happening at all (this could be because of my "fix" not being enough)

From the .readme: Please explain....

where's "the archive" to copy from
where's my "user-startup" to edit
how do I know if I have an "SSLROOT: assign"?

UPDATE: opened a new CLI window and typed: list GOOGLE:
original first run errors, as described above, returned and process never finishes (clock cursor) - have to reboot
cGoogleDriveHandler:auth() failed (first time login)
{"error": "invalid_grant".
"error-desrcription". Bad Request}

click OK and Error popup closes

and an untitled, empty, unclosable window remains and the Google Drive icon never gets to the desktop

after reboot, same steps produce same result (THIS was my original issue, so the first Bug I found didn't fix this.)

AHA - found User-Startup (finally) and the BEGIN GOOGLE (!) section points to the old DEVS:Google folder... will change to Devs:Cloud (another Bug?)
AND - "fixing" that (2nd Bug?) made no change to the Google Drive (original error remains).

Unless you have a fix for this, assuming you can reproduce it, is my only solution a brute-force total uninstall-reinstall of X/XE? Would prefer to replace all my funky Google Drive bits before going that far.

Author DamnRight
#21 Posted: 13 May 2019 16:24 

... help me Obi-Jan, you're my only hope ....

Author AmiKit
#22 Posted: 13 May 2019 17:01 
Sorry for the delay. Please drop me an email to and I will do my best to solve it.

Author DamnRight
#23 Posted: 13 May 2019 17:51 
will do

Author DamnRight
#24 Posted: 13 May 2019 18:40 

Author DamnRight
#25 Posted: 16 May 2019 04:32 
Thanks for the help! Hopefully my upgrade issue was a one-off. Looking forward to the AmiStart menu fix patch.....

Page  Page 2 of 2:  « Previous  1  2 
Specific questions AmiKit Support Forum / Specific questions /
 Launching Google Drive Error

Your Reply Click this icon to move up to the quoted message

Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


AmiKit Support Forum Powered by Forum Script miniBB ®