AmiKit - Your Modern Retro Amiga Experience
 Begin Register Reply Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 324 [28 Nov 2019 07:12]
Guests - 324 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  

Amiga Forever 2006 online - This is NOT a valid source of AmigaOS

Author gigio
#1 Posted: 25 Aug 2007 16:03 Edited by: gigio 
I tried selecting "AF Installed" as a source of my system files, as suggested in another post, but I have got the error saying there are invalid commands and emulator ask me another time file system source (OS3.9 - OSXL - AF...).

Too much difficult for my opinion, I spent an hour to understand something trying various methods, reading all posts, after I uninstalled everything.

A friend of mine has had the same problem, using OS3.9 disk.

Does this program work really or is everything a great joke?

Author AmiKit
#2 Posted: 25 Aug 2007 16:21 Edited by: AmiKit 
It's all joke, what did you expect? The high-end classic Amiga on your PC?

Seriously, beside the "This is NOT a valid source of AmigaOS" sentence, what commands have failed, do you remember?

Also tell me what OS do you use (XP, Vista?) and what CPU you have.

Have you installed AmigaForever2006 into its default installation path or somewhere else?


Author gigio
#3 Posted: 25 Aug 2007 17:43 
Well... thank for your help in advance!

My sistem is an Athlon 64 5000+ dual core, 2GB RAM memory, ATI X850 video card 500GB hard disk with Windows XP SP2 (english version)

I have installed AmigaForever2006 and Amikit with update 1.3 with all default path using the Kickstart v3.1 (A500,A600,A2000).
At first, I have had only the classic "insert disk" image from WinUAE emulator.
After, using "AmigaSYS 3 Plus for WinUAE 1.4.3 or later, 3.0,3.1,3.9" of WinUae load settings, I have had only a request of inserting a diskette in df0:

So, I tried to use the Kickstart v3.1 (A4000)(Cloanto) from Cloanto installation directory. No result at all.

I tried so, after reading the forum, the file and followed your instruction (copied Startup-Sequence and Startup-Sequence2 into AmiKit\AmiKit\S drawer and overwrite existing files there). No results, only the "insert disk" image.

Again, I tried as you suggested AmiKit:Prefs/Presets/AmiKit/Install/S/Startup-Sequence
to AmiKit:S/ Again, no results!

Really difficult and boring as you can see for a normal user.

Author AmiKit
#4 Posted: 25 Aug 2007 20:24 Edited by: AmiKit 
Okay, thanks for the additional information.

- First of all, please un-install AmiKit and un-install WinUAE using the "Add or Remove Programs" tool.

- Install AmiKit again, do not run it, though. (Btw. the RomFind will find and use the Cloanto ROM during this installation.)

- Download the latest WinUAE ZIP archive, extract and copy the WinUAE.exe to your installed AmiKit\WinUAE\ folder. Overwrite the old WinUAE.exe there.

- Start the AmiKit Launcher, but before you press the "Run AmiKit button", please check the existence and content of the following file located in your AmiKit installation folder:


If your system partition is named just "C:" then this file should contain something like this:

WinDH_C:Documents and Settings/All Users/Documents/Amiga Files/System

If your system partition is labeled eg. "MySystem", the file should contain:

MySystem:Documents and Settings/All Users/Documents/Amiga Files/System

This is the path where the AmiKit looks for the AmigaForever system files. Check the existence of this folder. It should contain additional folders like "dir", "hdf", "rom", etc.

If the AFOnlinePath conatins different or wrong path, please correct it according to reality. Use NotePad for editing. Save the changes.

- Now press the "Run AmiKit" button. The emulation should start, select "AF Online" as the source of the system files. If the path is correct, the system files will be found and copied to AmiKit automatically.

Please let me know the result.

Author gigio
#5 Posted: 26 Aug 2007 12:04 Edited by: gigio 
Hi! Many thanks!

In my system the folder


doesn't exist.

I have also tried to uninstall and reinstalled everything in my notebook (an Acer Aspire 5100 with 2GB of RAM Turion64 3000+).

Don't worry, I surrended, I think it's destiny!

Thanks again for your help and good luck for this program.

Author AmiKit
#6 Posted: 26 Aug 2007 21:20 Edited by: AmiKit 
The AFOnlinePath is generated by AmiKit launcher on its each start. The launcher searches the Windows registry for AmigaForever path, converts it to Amiga path format and puts the info to this file. If such a file doesn't exist (corrupted installation of AmigaForever maybe?), you could start the Launcher, create one with your AmigaForever path inside, and hit the "Run AmiKit" button.

EDIT: gigio, I noticed you're from Italy. Come to Empoli to see AmiKit in action.

Author BuddhaPhi
#7 Posted: 19 Jan 2008 18:44 
I've throughly been looking for an answer to my problem in the forums. I didn't want to start a new thread for the same issue so I'm adding to this one. I also cannot get AmiKit to see my Amiga Forever 6.0 Online edition installation, regardless of what I try.

AmiKit\AmiKit\Prefs\Env-Archive\AFOnlinePath was not created by AmiKit, even after multiple re-installation attempts. So I created it with Notepad.

My Amiga Forever "System" volume (from a working default install) is located at:
C:\Program Files\Cloanto\Amiga Forever\Emulation\shared\dir\System

My C: drive is labeled "OS", so should the contents of AFOnlinePath be
OS:Program Files/Cloanto/Amiga Forever/Emulation/shared/dir/System ?

With this config, AmiKit still states that it's not a valid source of AmigaOS. I checked and the file AmiKit\AmiKit\Prefs\Env-Archive\WinPath correctly has the text OS: inside of it. I've tried removing my C: volume label also, updating the files above and still no success. What files are the AmiKit installer unable to find? I haven't added or removed anything from the Amiga Forever installation and I can boot it up separately without any problems.

After a couple of hours of frustration, I'm ready to give up, much like the previous poster.

Any suggestions?

Author AmiKit
#8 Posted: 19 Jan 2008 19:24 Edited by: AmiKit 
Hello and welcome.

It is important to differentiate between Amiga Forever version 6 and version 2006. While the AmiKit supports the 2006 version by default, it does NOT support version 6 (in this case you have to download some extra files, read bellow).

Please tell me what version you have exactly.

If you have version 6, please follow this post.

Author BuddhaPhi
#9 Posted: 19 Jan 2008 20:06 
Very good point about the versions. I was confusing them. I purchased AF 6.0 a couple years ago and haven't upgraded to AF 2006 yet. I will do this soon.

Good news, though: Shortly after I posted, I was able to figure out the problem anyway by looking at the Startup-Sequence and Startup-Sequence2 files.

Assuming a default AF 6.0 install to C: (labeled "OS" in this example), the AmiKit\AmiKit\Prefs\Env-Archive\AFOnlinePath file needs to be created with the the contents below in it:

OS:Program Files/Cloanto/Amiga Forever/Emulation/shared

Once I made this update, it worked fine.

This really is an excellent bundle of software. Thanks for sharing it.

Installation questions AmiKit Support Forum / Installation questions /
 Amiga Forever 2006 online - This is NOT a valid source of AmigaOS

Your Reply Click this icon to move up to the quoted message

Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


AmiKit Support Forum Powered by Forum Script miniBB ®