AmiKit - Your Modern Retro Amiga Experience
 Begin Register Reply Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 324 [28 Nov 2019 07:12]
Guests - 324 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  

It works! Sort of.

Author Ron Legro
#1 Posted: 31 Jul 2007 19:48 
I'm fiddling with Amikit on my Vista-equpped Intel Dual Core laptop, using Amiga Forever 2006 for source code. Amiga Forever works fine. At first Amikit wouldn't boot. Eventually, messing around with WinUAE settings, I did get it to load and it looked swell, Opus loaded and everything pretty much worked. Couldn't change screenmode, though, whether inside Amikit or from WinUAE. Odd!

Anyway, I auto-updated to 1.3.7 (yes, I do have web connectivity and CD-ROM avail as well) but now things are worse. Many assigns seem trashed (e.g., Amkit volume is not seen as SYS: ) and now I've got many unassigned default icons for many Workbench programs.

Also, I still can't switch resolution. I think it's at 800x600 but I can't even check that, because while I can use Amikit Screenmode, the standard Screemode program refuses to load. It did load before I updated to 1.37 but I still couldn't get the screen prefs to change. Under Amiga Forever, screenmodes are not a problem.

Also, while I saw it originally, I no longer see the Amikit title bar and the task bar at bottom is now missing (again, perhaps because assigns are missing). I was getting error messages on bootup to the effect that the system couldn't open Trashcan icons, that "sys:system/rexxmast" was an unknown command and that "Opus is sick of waiting for AppAssign to return." Those stopped appearing after upgrade, but I still am missing all my icons and assigns.

One other quirk: Despite assiging much RAM to the RTG function, it looks like the system graphically struggles. I've got a 1.6 Ghz CPU and 1.5 gigs of RAM, and I give 16 or 32 megs to RTG on top of 2, 4 or 8 megs of chip RAM in WinUA. I did take note that I need to choose a 68020 CPU in WinUAE for Picasso to kick in, but no joy.

One glitch: The Opus screen will sometimes blank out and then I must reboot or "unerase" the blackness, if you will, by painting the entire screen with my mouse. So I suspect I may, among other things, be stuck in AGA mode.

I've taken note of the many tips here, especially relating to laptops and dual core CPUs and I'm aware that WinUAE 1.42a may be problematic. If need be, I'll start all over.

Will fiddle more as I have time, because AmiKit looks great and I've always liked Opus Magellan. And I'll do a more formal problem report with full system specs if I can't resolve this. But while I enjoy this on a hobby level and would be happy to contribute a donation, I won't until I can see Amikit working without obvious quirks on my system. I do have a WinXP box I can eventually try it on, but for now I need to make it work on this Vista laptop. And let's face it: Vista is not yet mature. So, I hasten to add, I don't entirely blame Amikit.

I should also add that many apps like AWeb, the sound editors and so forth do work fine, if I open them from their drawers. Also, the "Ken" icons are visible in the Utility drawer but nowhere else. Go figure. Assigns, again?

Thanks for an amazing effort. It makes a long-time Amiga user proud to see what can still be done!

Author AmiKit
#2 Posted: 1 Aug 2007 00:26 Edited by: AmiKit 
Hello Ron!

Your problems with AmiKit are unusual and really weird.

First of all, please re-install AmiKit. Before you start the emulation, download the latest WinUAE zip archive and extract WinUAE.exe into your installed AmiKit/WinUAE/ folder so the old executable gets overwritten.

Also Windows Vista may give you some problems due to its strict policy about altering files inside the Program Files directory. To avoid this it might help to use the file explorer and select the Program Files/AmiKit folder and change the permissions (both from the main properties page and under the Advanced section) so that all processes have full permissions to the AmiKit folder and sub-folders.

Please let me know the result.

Author alanwall
#3 Posted: 3 Aug 2007 04:52 
the latest winuae is 143 and works fine
have you tried booting with startup sequence.safemode ?
if that works,open a cli/cd to Amikit and type:
protect #? rwed all
and see if that helps
also you can use the 060 IF you the rights libs installed
ask if you need more help, we all need it from time to

Installation questions AmiKit Support Forum / Installation questions /
 It works! Sort of.

Your Reply Click this icon to move up to the quoted message

Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


AmiKit Support Forum Powered by Forum Script miniBB ®