AmiKit - Your Modern Retro Amiga Experience
 Begin Register Reply Search Statistics Quick Guide  
Online now: Guests - 2
Members - 0
Most users ever online: 324 [28 Nov 2019 07:12]
Guests - 324 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  

A Note to All Laptop users who cant make AmiKit Run

Author solamnic
#1 Posted: 16 Mar 2007 10:10 
WinUAE 1.4.0 didnt work for me...
WinUAE 1.3.4 Freezes after a while....
WinUAE 1.3.3 Works fine...

So use WinUAE 1.3.3 and everything works fine... (lets hope WinUAE 1.4.1 fixes all that)...

Author Toni Wilen
#2 Posted: 16 Mar 2007 10:30 
Perhaps it does, perhaps not, I don't care.

"didn't work" isn't a bug report. At least post if public 1.4.1 betas already fix "didn't work for me"-bug. Bugs won't get fixed automagically.

I am sorry for very negative tone in this post but thats how I feel when I see these kinds of "bug reports" and then later (it always happens) someone complains why his/her so called "bug report" was ignored and the bug is still not fixed and of course it was 100% my fault..

Author solamnic
#3 Posted: 16 Mar 2007 12:57 
Its an advice that worked for me...

if other newer versions of WinUAE work for u thats great...
i wrote this because i wanted to share my experience with AmiKit... and how i solved a problem that occured to me...
I dont have the knowledge to say what exactly is wrong with WinUAE (or with my configuration to point out where is the fault...).. and as long as i ve found out a working version.. its fine...

U dont care if it works ...........



Author AmiKit
#4 Posted: 16 Mar 2007 13:11 
Well, if there are problems with WinUAE, please always:

1) report what is the problem exactly and how can it be reproduced
2) include your hardware specification, Windows version, gfx drivers and WinUAE version.
3) include log files (both winuaebootlog.txt and winuaelog.txt, don't forget to enable logging in misc-panel) for possible error or warning messages.
4) include screenshot if it's a graphic problem
5) report AmiKit version and what have you changed in your startup-sequence and/or WBStartup or report any other changes (running from hardfile, etc.)

...anything more Toni? We can make a sticky thread with the rules of posting the WinUAE bugreports, what'd you say?

Author solamnic
#5 Posted: 16 Mar 2007 13:45 
Here we go...

1) The Amikit stucks in the start screen (the one with the planet)
2) Toshiba Laptop, Centrino 2.0 ghz, 1gb ram, ati x700, Win XP sp2, Ati Latest, Winuae 1.4.1.b3
3)Where to send the my log file?
4) Amikit Latest version... 1.2.0 then updated to 1.3.1 via Live update installed with AF 2005.
5) No changes..
Anything else?

Author AmiKit
#6 Posted: 16 Mar 2007 14:00 
Oki, thanks. Now we are getting somewhere.

1) if the boot picture does not disappear, it indicates the boot process has not reached its end where the ShowAmiga96_Close program is executed from WBStartup. This program is supposed to close the boot picture.

Therefore close the picture manually by pressing the 'ESC' button to see what is happening in the background. Usually, the boot is halted by some requester or some kind of error message which you should be able to see as soon as you close the picture. (You might want to disable the boot picture in startup-sequence as well).

Similar problem happened to me with WinUAE 1.4.0 too. When I closed the boot picture manually it turned out the desktop was loaded in native AGA mode that triggers lots of error requesters, even a crash sometimes. This is because WinUAE 1.4.0 changed some screenmode identifiers and screenmode.prefs saved by previous versions of WinUAE might not be compatible with the current version (as was already described here).

The only possibility is to try to boot with WinUAE 1.4.0 and start the SYS:Prefs/Screenmode program, select the screenmode as you was using before and SAVE the settings. Then reboot. Next start of AmiKit should boot into correct screenmode again, even under WInUAE 1.4.0.

Author solamnic
#7 Posted: 16 Mar 2007 14:22 Edited by: solamnic 
While the first screen loads i press the ESC button as mentioned above
the i see a grey Workbench screen.. i wait but nothing happens..

If i wait till bar in the first (planet) screen is loaded and i press ESC nothing happens... (and no warning)....

how can i start Screen prefs ?

Author Toni Wilen
#8 Posted: 16 Mar 2007 14:27 Edited by: Toni Wilen 
All modes (except 640x480, 800x600, 1024x768, 1280x1024) have new Picasso96 mode ID since 1.4.0 (some changed already in 1.3.x series)

Previously all modes were not global but PC-specific, transferring P96 config file to another PC or different platform could for example change 800x600 magically to 1280x720 or 1600x1200 or 320x240 etc.. (not a good thing)

New modes are listed in picasso96_win.c and I think it would be nice to have automatic modeid test/update program included with future AmiKit update


winuaebootlog.txt is good to have (it also includes Windows version, some hardware info etc.., no need to repeat it), winuaelog.txt may be quite big in some cases, probably not needed except if requested.

Also it is good idea to test if it already works in latest public beta (if available)

Author AmiKit
#9 Posted: 16 Mar 2007 14:39 Edited by: AmiKit 
solamnic wrote:
While the first screen loads i press the ESC button as mentioned above
the i see a grey Workbench screen.. i wait but nothing happens..

Is the grey Workbench screen in the same screenmode as the boot picture was?

If the grey Workbench screen is in the same screenmode as the boot picture, then the problem is not related to the screenmode issue at all. But you can test it to be sure anyway.

Like Toni pointed out, eg. 1024x768 screenmode has not been changed. Therefore you start AmiKit with WinUAE 1.3.3, start "Screenmode AmiKit" and select 1024x768 mode. Also, before you reboot, start the system's AmiKit:Prefs/Screenmode program and select the same screenmode there.

Now use the latest WinUAE again and start your AmiKit. Does it work?

Author solamnic
#10 Posted: 16 Mar 2007 14:56 

it worked...

i followed ur instructions.... (booted with WinUAE 1.3.3 changed resolution and
everything worked fine in the newest WinUAE 1.4.1b3)..

it seems it was a resolution problem and it occured to laptops due to changes to WinUAE mentioned above...

Thank u for ur help..

Author AmiKit
#11 Posted: 16 Mar 2007 16:43 
Great! Nice to hear it works for you now.

Remember, whenever you use "Screenmode AmiKit" tool to change your screenmode in WinUAE 1.4.0, please always use the "SYS:Prefs/Screenmode" program as well before you reboot!

This is because "Screenmode AmiKit" contains set of old screenmode preferences that might not be compatible with WinUAE 1.4.0+. By setting the same screenmode with "SYS:Prefs/Screenmode" as well you always ensure the correct mode will be used.

Installation questions AmiKit Support Forum / Installation questions /
 A Note to All Laptop users who cant make AmiKit Run

Your Reply Click this icon to move up to the quoted message

Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


AmiKit Support Forum Powered by Forum Script miniBB ®