AmiKit Support ForumAmiKit Discord Chat
 Start Register Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 41 [17 Jun 2024 01:12]
Guests - 41 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  
 

Installation fails on either Windows 11 or Ubuntu 22.04 with POL

 
Author Juppstein
Partaker
#1 Posted: 6 Dec 2022 21:29 
Hi there, I bought AmiKit XE today. My roms and key come from an old Amiga Forever version from back in 2015, though I dont have the ISO file from back then, only the copied folders from an age old Windows install. If you need proof of purchase, I should have that somehwere in my email archive.

Whatever. I tried to get AmiKit running for several hours now on either Windows 11 or on Ubuntu. I first copied/renamed the rom file to the rabbithole/rom directory but that gave an error that the AmigaOS files were not found. I then used the romfinder tool in that folder and that one recognized the 3.1 ROM file for A1200 and copied it into the folder. But that still gave me the same error that the AmigaOS files are not found. I then tried the whole thing over on Ubuntu because I wasn't sure if Win11 was the bad guy. But I had exactly the same behaviour there as well.

Not really sure what I am doing wrong here. I have the same roms/key in use in retroarch as well as in WinUAE and FS-UAE, so they have to be the correct ones. This is turning into a bit of a low key experience

Author AmiKit
Admin
#2 Posted: 6 Dec 2022 23:47 
Hi Thorsten and welcome to Forum. I am sorry to hear about your experience. Let's solve it together. I have 2 or 3 possible solutions for you.

Even though the requirements specifically mention Amiga Forever 7, 8 or 9 only, it should work with the 2015 version too. The problem is that AmiKit is looking for a mounted ISO, a drive called AmigaForever:

1) The easiest one should be to install Amiga Forever on your Windows and then AmiKit will pick it up automatically.

2) Or you can contact Cloanto so they deliver the AmigaForever installer to you again, and then you can make an ISO out of it thanks to its «Build Image» feature https://www.amigaforever.com/screenshots/build-image/ (providing it was part of Amiga Forever 2015 already).

3) Or, providing you have the content of such ISO stored on your harddrive, you can mount such a directory as a drive in AmiKit and call it AmigaForever. To do so, run AmiKit launcher and click Configure. In WinUAE go to «CD&Hard drives» section and click the «Add Directory button». Then enter the following details:

Device name: CD0
Volume label: AmigaForever
Path: <path to your folder with Amiga Forever files> You can do so by clicking the «Select Directory» button.

Just make sure that the directory you choose really contains the complete Amiga Forever folders like:
Amiga Files
boot
Private
(etc.)

If there is a correct ROM in AmiKit/RabbitHole/ROMs folder named kick.rom (including rom.key file too), it should work.

Hope it helps?
Jan

Author robsten
Partaker
#3 Posted: 7 Dec 2022 00:15 
Juppstein
If the roms aren't found the error message should sound like «could not load system ROM, trying system ROM replacement». The correct filename ought to be <kick.rom> in the Amikit XE ROMs folder.
So you went through the full installation procedure on Ubuntu? There is a PDF file provided with it or a online guide how to setup Amikit on Linux.
https://docs.google.com/document/d/1b7cVHq2NZW57jIqk0FBTrKofEhB5Ylj_xjMsvsIEeuk/edit
PlayonLinux preinstalled is mandatory (to have Wine available).
There is a short video on the HP «SEE TORQUE INSTALLING AMIKIT AND FLOWER POT», maybe it helps.
Your error message rather sounds like there's no prepared Amiga system volume available. This should be created while running the provided install script with PlayonLinux. The next step should require a compatible AmigaOS source to be installed onto this volume.

Author AmiKit
Admin
#4 Posted: 7 Dec 2022 08:32 
robsten
I believe once he provides a proper Amiga Forever ISO to AmiKit or he tries that «Directory» method described above, it should work on both Windows and Linux.

Author Juppstein
Partaker
#5 Posted: 7 Dec 2022 12:31 
Hi, the method to provide the directory structure worked in the end. Thanks for the quick replies y'all Really appreciated! Good thing I didn't touch the structure itself when I backed it up years ago.

Author AmiKit
Admin
#6 Posted: 7 Dec 2022 13:10 
Glad to hear you got it working in the end!

Have fun with AmiKit.
Jan

Author AmiKit
Admin
#7 Posted: 7 Dec 2022 13:13 
One more thing. Once you got it installed and fully updated, backup AmiKit.hdf file so if anything goes wrong in the future, you just restore that single file without re-installing anything.

Author Juppstein
Partaker
#8 Posted: 7 Dec 2022 14:31 
Yeah, already did that. It was the first thing on my to-do after everything got upgraded :D

Author jwolf
Partaker
#9 Posted: 9 Sep 2023 22:27 
I do not understand how this Ubuntu 22 installation fix works. The above solution was for Windows but «should» work on Ubuntu? I don't even know where to start with that solution in an Ubuntu environment.

My installation fails using Play On Linux. After selecting the POL_install_AmiKitXE file, POL displays a popup that states: «Here is the source code of the script. Check it carefully. The window containing the source code is completely empty and the »Next« button is grayed out. The only button I can click is »Cancel« to cancel the execution of the script.

Any chance I can get clarification on the above solution if it is even a solution at all under Ubuntu 22? The above posts do not state conclusively that it is.

Installation questions AmiKit Support Forum / Installation questions /
 Installation fails on either Windows 11 or Ubuntu 22.04 with POL

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑