AmiKit Support ForumAmiKit Discord Chat
 Start Register Search Statistics Quick Guide  
Online now: Guests - 2
Members - 0
Most users ever online: 717 [7 Feb 2021 09:33]
Guests - 717 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  

Install of Amikit X fails

Author cewright12
#1 Posted: 7 Oct 2022 04:03 
Edit2: Never mind. Please ignore this. I thought it would be fun to get this working on Linux, but after trying this for a couple of hours I'm kind of over the novelty. I'm blowing away the system I'm using for this and just doing it under Windows instead. I figure that will be much easier. You can delete or ignore this post. Thank you.


Edit: Okay, I found the advice of someone else about pointing to the ISO as an archive, unchecking the four boxes and that got me past the error I had below. However, right after it says IMPORTING OPERATING SYSTEM FILES... SIT TIGHT it says INTERNAL ERROR.. please check Support Forum.

Progress is being made, but I'm not sure what I should do now.



I wanted to try the free X version first to see what I thought before buying. However, it immediately fails when I first try and run it. I am on the latest POP_OS and running PlayOnLinux. I complete the install by following the instructions on your site. However, when I first try and run it I get an error immediately. «Alias: argument line invalid or too long» This is showing up in the AROS window, so the error message looks like an error message would on an Amiga (i.e. not a Linux error).

I have the Amiga Forever ISO (ver 9). I was expecting it to ask for the ISO image to do the install. However, it fails with the above error message within a second or two of launching it. I tried going into «Configure» and down to WinUAE Properties/hardware/CD & Hard drives and select the ISO and it still gives the same error. I add a CD drive and mount the ISO and it still fails. I made a new ISO of Amiga Forever and it fails. I'm kind of frustrated. I see in images online that Amikit X normally says Welcome to AmiKit and you just select the button for Amiga Forever. It doesn't do that for me. For grins I installed Crossover and it installs Amiga Forever just fine. So, I'm obviously missing something, but I can't figure it out. Any ideas?

Author AmiKit
#2 Posted: 7 Oct 2022 13:09 
Hello, and sorry for the convenience you experienced. The reason for the initial error is most likely the wrong Kickstart ROM or missing rom.key. Or wrong path to both. AmiKit X should never run using the AROS ROM. Note that AmiKit requires A1200 ROM 3.1 (edition 40.68).

Yes, Windows edition is the AmiKit flagship and should install and work much more smoothly. Let me know your experience, please.

Jan, author of AmiKit

Installation questions AmiKit Support Forum / Installation questions /
 Install of Amikit X fails

Your Reply Click this icon to move up to the quoted message

Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


AmiKit Support Forum Powered by Forum Script miniBB ®