AmiKit - Your Modern Retro Amiga Experience
 Begin Register Reply Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 717 [7 Feb 2021 09:33]
Guests - 717 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  
 

Trouble setting up Amikit XE in Linux

 
Author bbusatti
Partaker
#1 Posted: 3 Oct 2020 23:22 Edited by: bbusatti 
EDIT: Never mind. I feel pretty dumb now since I just went ahead and executed the program (without completing the quick start guide) and it seems to be finding the files for me.

Hello everyone. I'm new to Linux and just finished installing the OS onto laptop that used to be a windows laptop. I'm currently running Linux Mint 20 Cinnamon 4.6.7. The quickstart instructions seem to be lacking in a few places, and my attempt to fill in the blanks has come up short. I've gone through the installation instructions and am using PlayOnLinux 4.3.4. I have also copie Picasso96.lha into the AmiKit/RabbitHole folder. I have yet to get the kickstart roms to work. I have purchased copy of AmigaForever DVD and have tried copying all of the kickstart roms over to the ROMS folder that is located in the folder that PlayOnLinux directs me to. I've tried to keep the filename unchanged "amiga-os-310-a1200.rom" as well as renamed it "kick.rom". The "rom.key" file has also been moved to that directory. I'm also not certain how to workbench onto emulator. The directions tell me to do either of the following:

○ If you have ISO image, select the "​ CD & Hard drives ​ " section under "Hardware".
Click the "​ Select image file ​ " button (near the bottom of the window) to browse for the
ISO image. Find and select the ISO image and click "Open".

○ If you have an AmigaOS 3.1.4 ZIP archive, click "​ Add Directory or Archive ​ "

The AmigaForever disk, as far as I can tell, has no ISO or zipped AmigaOS 3.1.4 ZIP. If I could get the emulator to use. This is as far as I've been able to get and seem hopelessly stuck. I did some searches on the board and online, but I couldn't find help for what I'm looking for. I'm also far from a Linux expert and am quite new to the OS. I apologize ahead of time if there is a conversation that I missed regarding this issue.

Any help would be greatly appreciated!

Thanks!

Brian

Author AmiKit
Admin
#2 Posted: 3 Oct 2020 23:50 
Hi Brian and welcome to forum!

I am not exactly a Linux guy, but I will do my best to help you out.

You did a good job with kick.rom and rom.key. They both belong to ROMs folder.

Just to clarify, AmigaForever does not include AmigaOS 3.1.4 ZIP. They are two different software packages. But no worries, you're all set with the Amiga Forever.

You can either make an ISO out of your Amiga Forever DVD and then use the ISO according to the manual.

Or you can try this. Insert your AmigaForever DVD, run AmiKit launcher and press Configure button.

Then go to "CD & Hard drives" section and click "Add Directory or Archive" button and enter
Device name: CD0
Volume label: AmigaForever
Untick the "Bootable" option.
And click "Select Directory" button and point the path to the root of your inserted DVD.

Then, still in the "CD & Hard drives" section untick all 4 options below: "Add PC drives at startup", "Include removable drives", "Include network drives", "CDFS automount CD/DVD drives"

And press the "Start" button.

When AmiKit asks you for the source of AmigaOS files, press "AmigaForever" button and your DVD should be recognized.

Author AmiKit
Admin
#3 Posted: 3 Oct 2020 23:52 
Ah, good to hear it works for you now! Once your AmiKit self updates to the latest version (currently 11.4.1), quit the emulation and backup your AmiKit/AmiKit.hdf file. And if anything goes wrong later, just restore that file. No need to re-install everything.

Have fun with AmiKit!
Jan

Author bbusatti
Partaker
#4 Posted: 4 Oct 2020 02:17 
Thanks for the explanation! I've been able to run it now and everything seems to be working smoothly. It's great to have a nice emulator setup. It's been years since I had an Amiga 2000, and I've never had the opportunity to see the newer OS features that came along later.

Author robsten
Partaker
#5 Posted: 3 Nov 2020 20:28 
Hi Brian and welcome to the forum.

It looks like there are not so many AmiKit users on the Linux side here than on other platforms.

I'm on Mint 19.3 Cinnamon with AmiKit 11.4.2. No troubles with Mint generally. But It feels like AmiKit since its last update has lost some of its performance and agility. Maybe UAE also needs a setup refresh. All I have checked by now is, that CPU was set to 68020. Iirc it was previously setup as a 68030 system and presumably with burst mode enabled.
Anyway it still feels a bit sluggish.

How about your experience with mouse control and boot delay? Have you tried and succeeded to enter the early-startup menu (hold both mouse buttons while startup/reset)?
How's your key assignment on the keyboard, everything properly assigned (also special characters such as | ? @ and things like LAmiga/RAmiga keys?)

Have fun with your new setup.

Regards

Author Morph Madness
Partaker
#6 Posted: 18 Aug 2021 16:38 
robsten
Hi robsten,

I'm butting in on this thread, as I'm looking for reports of how Amikit XE runs on top of Linux, opposed to how it runs on top of Windows10, on the same hardware. I have a desktop PC that is perhaps about 7 years old that I'd like to install some form of Linux on, as light weight as possible, then test how well it runs a couple of Windows only programs and one Windows only game that I'm fond of, by using the PlayOnLinux script. My hope is that since the bloated overhead of Windows will be gone, that the one game and couple of productivity programs I want to use will run just as fast, or faster/better on the light weight Linux under pinnings, than they actually do on Windows10 with the same hardware.

What do you think, and is Linux Mint the best choice for a light weight Linux distro that will work will with Amikit?

Author robsten
Partaker
#7 Posted: 12 Sep 2021 05:32 Edited by: robsten 
Hi Morph Madness,

Your last question first - one "light weight" Linux I know and just have booted a few times just to get a feeling of its own performance was Lubuntu. It felt quite responsive to me although I ran it from a quick SD card (rw rate ~90Mb/s USB3). I guess Amikit should also run well on it but I did not specifically install it on this test media.

I don't have a direct comparison between Amikit XE running on Windows but just running on Linux Mint 19.3. Generally Amikit is operating very responsive and quick also when doing things like de-/compressing archives.
I also have my own AmigaOS3.9 setup which I once transferred to WinUAE for booting it on a pendrive from any Windows. My original HW setup is made of a DCE 1260, so not having to tweak too much for getting it booting up I also set WinUAE up as a 060 system. It wasn't for performance reasons but for not having to backroll several library files and executables to just get my own system and software working.
Generally spoken I cannot clearly see much of a difference in performance between using WinUAE on M$ or Amikit on Linux. Simple AmigaOS benchmarking tools such as e.g. sysinfo could provide you some numbers, but simply be prepared to get hilarious calculated speeds. After all I simply thing using WinUAE on any "PC" setup will provide enough computing power compared to any real classic Amiga HW available. But sure, I would expect using Linux on the same HW might work a bit more smooth than using overloaded W10 which meanwhile seem to force users to pull a ticket if wanting to do some own action.
I'm up to moving Amikit to a VM using or VMWare or Virtualbox, not yet clear in my decision, but surely my Mint as base system.
My main system atm. is a Lenovo E595 AMD Ryzen 7 3700U notebook.

Installation questions AmiKit Support Forum / Installation questions /
 Trouble setting up Amikit XE in Linux

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑