AmiKit - Your Modern Retro Amiga Experience
 Begin Register Reply Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 324 [28 Nov 2019 07:12]
Guests - 324 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  
 

Install loop

 
Author wwinfrey
Partaker
#1 Posted: 2 May 2020 23:11 Edited by: wwinfrey 
I am a new AmiKit user. I've just purchased AmiKit XE v11 and am encountering an install loop trying to run it for the first time on Windows 10, and seem to be unable to ever get a point where I am presented with the ScreenMode Preferences dialogue. I get to the "Please sit back & relax while we work our magic"; then "Almost done. Let's select your screen mode...press enter when ready".

I press enter, and am briefly shown a message that says "SELECT & SAVE UAE:1366x768 32bit BGRA or similar mode for now. Really." My expectation is that at this point I should then be presented a ScreenMode preferences dialogue, but it just goes to "AmiKit XE installation complete! GET READY TO BE AMAZED. PRESS ENTER." at which point I press enter, and then it restarts, briefly displays the "SELECT & SAVE UAE:1366x768 32bit BGRA or similar mode for now. Really." message before returning to the "AmiKit XE installation complete! GET READY TO BE AMAZED. PRESS ENTER." screen. A loop.

I can post an animated gif or mp4 of the process somewhere if it would be helpful.

I have uninstalled and reinstalled AmiKit and am getting the same result. What am I doing wrong?

Author AmiKit
Admin
#2 Posted: 2 May 2020 23:40 
Hello and welcome to Support Forum!

The AmiKit is configured to show the screen mode requester IF screenmode.prefs is not found. That is the case on first run, of course. But as soon as you SAVE your preferred settings, the screen mode requester does not show up anymore. Are you sure you clicked the SAVE button? The only possible reason why the screen mode keeps showing up is if you clicked USE button instead - that one doesn't save screenmode.prefs file.

Please let me know.

Cheers,
Jan

Author wwinfrey
Partaker
#3 Posted: 2 May 2020 23:43 Edited by: wwinfrey 
That's the thing - I am never shown the ScreenMode prefs. I have not seen it since trying to start AmiKit, so there has never been an option for me to click USE or SAVE. I only know I am supposed to see this dialogue because I ran across an AmiKit installation walkthrough with screenshots showing it while trying to diagnose this issue.

Author AmiKit
Admin
#4 Posted: 2 May 2020 23:51 Edited by: AmiKit 
Oh, I got it now, my apologies. That is very unusual behaviour then. I am guessing this must have something to do with AmigaOS system files. Which AmigaOS version and ROM have you used to install AmiKit? Are you sure the source is not corrupted? Or maybe the CD or ISO was mounted in Windows in a way the Amiga file attributes got lost?

Author wwinfrey
Partaker
#5 Posted: 2 May 2020 23:59 Edited by: wwinfrey 
My source is an AmigaForever 8 Plus installation, also recently installed. I tried setting up AmiKit using both the installation directory as well creating an ISO image from the AmigaForever launcher and using that during the install.

Author AmiKit
Admin
#6 Posted: 3 May 2020 00:08 Edited by: AmiKit 
Would you mind uninstalling both Amiga Forever and AmiKit completely, and then reinstalling first AmigaForever (leaving path and everything else at its defaults) and then AmiKit (also with default options). Then run Romfind.exe to copy correct ROM and run AmiKit.exe and click Launch. When asked about AmigaOS source, select "AF Installed" button.

Author wwinfrey
Partaker
#7 Posted: 3 May 2020 01:28 Edited by: wwinfrey 
Thanks for your help. Unfortunately I am still getting the same results. I thought the presence of a 64-bit WinUAE might be the issue, so I uninstalled it, uninstalled AmigaForever and AmiKit again, removed the Program Files directories, the ProgramData directories and the C:\Users\Public directories.

Re-ran the installers, same result. It skips right past the ScreenMode preferences dialogue.

Author AmiKit
Admin
#8 Posted: 3 May 2020 09:31 
I am sorry foe the inconvenience (and delayed answer too - different timezone).

Anyway, please drop me an email at amikit@gmail.com or even better (and faster) contact me via Facebook messenger https://www.facebook.com/AmiKit as I might have an ace up my sleeve.

Thank you,
Jan (AmiKit author)

Author wwinfrey
Partaker
#9 Posted: 8 May 2020 03:40 
Just to follow up, it looks like the loop was incurred as a result of using the Amiga Forever installation. After switching to 3.1.4 as a source, it installed perfectly.

Author AmiKit
Admin
#10 Posted: 14 May 2020 13:24 
I found the reason why it did not work! Here are the details and a hotfix too: https://forum.amiga.sk/index.php?action=vthread&forum=1&topic=1960

I am sorry for the inconvenience.
Jan

Author wwinfrey
Partaker
#11 Posted: 19 May 2020 03:55 
Thanks, Jan for all your hard work in helping to get this fixed! Seriously the best technical support experience for any product I've ever owned.

Author agiceg
Partaker
#12 Posted: 2 Aug 2020 07:01 
Perdon, humildemente tengo que hacer mi aporte en este tema, llevo desde los primeros UAE, WINUAE, etc, etc, etc, so?ħando con que mi pc se vuelva un AMIGA para no utilizar mas ese sistema. Estoy frente al mejor logro en 25 a?ħos, pero use una palabra, humildad, chicos uds. deben superarla, hay que escribir ROMs para comunicarse con las bios y para cambiarlas por las de macintosh fisicamente, con el fin de apoderarce de esos sistemas obsoletos y abandonados por Microsoft y Apple, entendiendo que para seguir usando esas maquinas, los nuevos OS no las soportan y siempre seria una perdida de tiempo. Creo que su sistema puede, gracias a los peque?ħos programas de Amiga y Linux, Creando un OS como uds. dicen RETRO y MODERNO, pero para familias y personas comunes que NO quieren seguir con el consumismo de Microsoft, Apple y Android.
Los Admiro profundamente , por el conocimiento demostrado, creo que pueden vivir bien de esto, sin el deseo avaro de Microsoft, Apple y Android, que se creen genios y son herramientas de consumo y vicio, robando datos, simplemente ladrones sin escrupulos, que creo que no es lo que necesitamos las personas normales y de bien.
No pierdan el camino, que todos hemos recorrido, esta es la plataforma genial para aprender, divertirse y disfrutar sanamente, disfrutando sin tener que usar tecnologias de punta, tecnologia que se pierde en el consumismo de que en el momento que se compra ya esta superada y obsoleta por la carrera estupida que hacen correr los dioses del consumismo, creando constantes frustraciones en las personas, suerte y fuerza por que siempre estaremos los comunes con uds.

Author agiceg
Partaker
#13 Posted: 2 Aug 2020 07:04 
que lastima el traductor autom??tico hizo lo que se le dio la gana

Installation questions AmiKit Support Forum / Installation questions /
 Install loop

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑