AmiKit - Your Modern Retro Amiga Experience
 Begin Register Reply Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 324 [28 Nov 2019 07:12]
Guests - 324 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  

FlowerPot 1.1 Installation: Unable to find rom.key in Amiga Forever

Author Tolstoy
#1 Posted: 22 Sep 2019 18:18 
When I tried to install FlowerPot 1.1, I was unable to locate a rom.key file from Amiga Forever The error I got was "WinUAE Message: Could not find System ROM Key file. When I checked the Amiga Forever ROM location, C:\Users\Public\Documents\Amiga Files\Shared\rom, there was not a rom.key file there nor was a search of the C: able to locate it.

Flower Pot 1.1
Windows 10 1903 (OS Build 18362.356)
AmigaOS Final Edition 4.1 Classic CD converted to an ISO named ClassicInstallCD-53.71.iso
Amiga Forever
ROM Location: C:\Users\Public\Documents\Amiga Files\Shared\rom
amiga-os-310-a4000.rom (512KB)
ralphschmidt-cyberstorm-ppc-4471.rom (128KB)
rom.key (missing!)

Problem #1 was getting a non-zero byte ralphschmidt-cyberstorm-ppc-4471.rom (128KB), the solution to which was available elsewhere in the forums. That ended up creating a functional AmigaOS 4.1 install in Amiga Forever (without working networking, to be fixed later), so I know my ROM files are functional. To fix problem #2, I went back in my archives and ended up copying the amiga-os-310-a4000.rom and rom.key file from the Amiga Forever 2012 Plus ISO which resulted in a fully functional AmigaOS 4.1 install.

So the question is, does Cloanto not have a rom.key file in later releases of Amiga Forever, and if so why is FlowerPot and/or WinUAE looking for it?

Author AmiKit
#2 Posted: 24 Sep 2019 11:31 
Hi Tolstoy and welcome to Support Forum!

Thanks for your detailed message and please apologize my late reply. It took me a while till I get to Windows computer to check it (I was travelling with my Mac laptop).

Well, you're right! I cannot find rom.key in my updated Amiga Forever installation anymore. Strange.

The reason why FlowerPot is looking for the rom.key is that Flower Pot 1.1 was released before Amiga Forever update.

Anyway, it seems like that the "new" ROMs work even without the rom.key, fortunately. At least I was able to run both Flower Pot and AmiKit here and none of them complained about missing rom.key. Can you confirm?


Author Tolstoy
#3 Posted: 25 Sep 2019 04:20 Edited by: Tolstoy 

I did a clean install of FlowerPot. I was unable to duplicate the error. Maybe it was because I had the ralphschmidt-cyberstorm-ppc-4471.rom (128KB) prepared before I tried the first install. Or maybe I just had a better overall understanding of the installation process.

AmiKit XE install on the same machine went smoothly the first time.

I will point out that I knew the rom.key files was not there in earlier versions of Amiga Forever 8 because I had looked for it for AmiBerry and Amibian installations. I'm not sure when Cloanto dropped it. My installers after Amiga Forever 2012 were delivered as .msi files.

Installation questions AmiKit Support Forum / Installation questions /
 FlowerPot 1.1 Installation: Unable to find rom.key in Amiga Forever

Your Reply Click this icon to move up to the quoted message

Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


AmiKit Support Forum Powered by Forum Script miniBB ®