AmiKit - Your Modern Retro Amiga Experience
 Begin Register Reply Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 717 [7 Feb 2021 09:33]
Guests - 717 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  

AmiKit Android Problems - Amiga Forever

Author mroshaw
#1 Posted: 9 Jul 2014 10:28 
First up, thanks for AmiKit! Absolutely brilliant, and I've been running in via WinUAE / Amiga Forever 2012 on my i7 Ultrabook for a while now. Love it!

I'm trying AmiKit Android and am having trouble with the installation process.

I have:

1. Copied the amiga-os-310-A1200.rom and rom.key files to /data/data/sk.amiga.amikit
2. I've modified .uaerc to point to the ROM location
3. I've modified .uaerc as the default filename for AmiKit.hdf was Amikit.hdf (capital K was lower case, causing it to fail)
4. I've copied the 'Amiga Forever' files into 'AmigaForever'. That's basically all the files from the AF directory mount and includes, etc and the C, Classes, Devs etc folders

When I run AmiKit, I get the 'Click here if the AmigaOS is located in one of the folders." message. Clicking this and I immediately get:

INTERNAL ERROR.. please check Support Forum at

I'm guessing the problem is with my 'AmigaForever' files, but the instructions aren't clear about exactly how these need to be copied. If I comment out the AmiKit.hdf hardfile configuration line, it boots fine into my AmigaForever system - so it's mounting the folder correctly and finding all the relevant files to boot the Amiga.

Any thoughts?

Author Lubomyr
#2 Posted: 9 Jul 2014 21:12 
I checked and have same problem with Amiga Forever.
You can try to use Amiga OS 3.5, Amiga OS3.9 or Amiga OS XL installation files or wait for fix.

Author mroshaw
#3 Posted: 9 Jul 2014 22:10 
Going to wait for a fix, I think. I'm happy to help debug the issue and test any fixes - just shout!

Author AmiKit
#4 Posted: 10 Jul 2014 00:30 
I am a bit busy nowdays. I hope I can inspect this issue tomorrow evening. Thanks for your patience.

Author AmiKit
#5 Posted: 12 Jul 2014 07:02 
I am sorry. I haven't had time to look into this and now I am on vacation. Could you please use some other source of AmigaOS meanwhile?

Author Germandroide
#6 Posted: 24 Jul 2014 09:47 Edited by: Germandroide 
Amiga4Everer 2008+ release working fine in the installation process and successful in Android version

Author Severin
#7 Posted: 26 Jul 2014 19:32 Edited by: Severin 
I also have this problem with AmigaForever 2013, so I installed 3.9 in AmigaOS3.9 but it reports there are no system files and to press enter to start again.

I've also moved all the Amikit files to external_sd and edited the config so roms and filesystems point to:

rom: /mnt/external_sd/Amikit/files/ROMs
filesystem: /mnt/external_sd/Amikit/files/AmiKit.hdf
filesystem2: /mnt/external_sd/Amikit/files/AmigaOS3.9

Changed the location in the early settings etc.

I had the same problems while it was all still on the internal storage.

I tried downloading the AmmiKit.hdf on my real amiga and mounting it with diskimage so I could manually add the system files. It comes up as a bad disk (IDF0RDSK) with the only option being to format it. I also copied the file from the tablet, same problem but took much longer to mount. I suspect the hardfile is corrupt. I have no problems mounting other HDF's as a floppy image using diskimage.

I'm using an HP slate 7 2800, android 4.1.1, kernel version 3.0.8+

Author christopherpm
#8 Posted: 23 Oct 2014 22:18 
I too am having the same issues. Copied the Amiga 1200 Kickstart into the ROM directory and renamed to kick.rom.

Copied all files into the AmigaForever directory.

Start the program and get the same INTERNAL ERROR.

Using Android KitKat 4.4.3 on an HTC One M8. Could this be an issue with the version of Android rather than with AmiKit?

What SHOULD happen when AmiKit is first run - does it create or modify any files?

Author Guenter
#9 Posted: 29 Oct 2014 16:28 Edited by: Guenter 
Hallo habe Amikit 1.7 erfolgleich AmigaForever 2008 auf Tablet Medion Installiert.
Von der Amiga Forever 2008 CD den Ordner AmigaFiles in den Ordner AmigaForever kopieren
habe auch noch mit kopiert.
Die roms habe ich von GooglePlay "AmigaForever 0,79 €" ist geschenkt also kaufen
Die roms in den Ordner roms kopieren muss man nicht habe es aber mal so gemacht.
Hatte vorher auch viel getestet aber jetzt hat es geklappt.
Bin jetzt über 60 jahre und bin der Englischen sprache leider nicht mächtig.
LG Günter aus Bad Vilbel

Author AmiKit
#10 Posted: 29 Oct 2014 23:49 
I'll fix the internal error problem. Use other source of AmigaOS to install AmiKit meanwhile - if you have such possibility. (On first run it copies Amiga system files to AmiKit)

Author Guenter
#11 Posted: 30 Oct 2014 17:10 
Hallo Amikit läuft mit AmigaForever 2008 ohne Problem.
Bitte den Ordner AmigaFiles aus CD in den Ordner
Amiga Forever des Andoit Gerätes kopieren. Die roms von CD oder
über Google Play für 0.79 € kaufen und in den Ordner roms kopieren.
Ich habe meine SD Karte aus meinem Android Gerät ausgebaut und die Files "Daten" mit dem PC auf SD Karte kopiert, SD Karte wieder eingebaut und mit Ghost Commander die Dateien in die vorgegebnen Ordner kopiert fertig der rest erledigt Amikit selber.
LG Günter

Author Guenter
#12 Posted: 30 Oct 2014 17:10 Edited by: Guenter 
Hello Amikit runs with Amiga Forever 2008 with no problem.
I have a Medion Tablet "with Android 4.0.3 MD_Livetab_P9516.
Please Amiga Files folder from the CD in the folder
Copy of Amiga Forever Andoit device. The roms from CD or
Buy on Google Play for € 0.79 and copy it to the folder roms.
I removed my SD card from my Android device and the file "data" with the PC to SD card copied, installed SD card again and with Ghost Commander copied the files in the folder determined for specific finished the rest done Amikit itself.
LG Günter

Author AmiKit
#13 Posted: 5 Nov 2014 13:11 
If is located in AmigaForever folder, AmiKit assumes the whole content of the Amiga Forever CD is located there and thus searches for the following paths:

AmigaForever:Amiga Files/System/dir/System/
AmigaForever:Amiga Files/Shared/dir/System/

If none of the path is found, the Internal Error is reported

Installation questions AmiKit Support Forum / Installation questions /
 AmiKit Android Problems - Amiga Forever

Your Reply Click this icon to move up to the quoted message

Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


AmiKit Support Forum Powered by Forum Script miniBB ®