AmiKit - Your Modern Retro Amiga Experience
 Begin Register Reply Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 324 [28 Nov 2019 07:12]
Guests - 324 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  

Android 4.2.2 and AmiKit

Author Moviepro11
#1 Posted: 10 Jun 2014 17:15 
I have Amiga Forever 2013 installed on my Pc, Amiga Forever on my Android. When I run my amiKit for the first time it asks for the proper roms be located. I copied the rom files from my desktop computer and the roms files from my Cloanto directory. I also renamed amiga-os-310-a4000.rom to kick.rom and placed in both the roms folder and in the AmigaForever folder on my android. Still AmiKit cannot find the files. I cannot get back to the main page when starting the process, I have to reboot device to get to the configuration screen button.The default directory for "Data installation location" is /storage/sdcard0/Android/data/sk.amigia.amikit/files/ . I cannot get it to work. Help!

Author Lubomyr
#2 Posted: 10 Jun 2014 18:50 Edited by: Lubomyr 
As i remember if kickstart roms files will be not found then you will see only black screen.

Do you mean you have installed "amiga forever essentials" for android and autodetection kickstart not works ?

Try manually copy kickstart roms (amiga-os-310-a1200.rom as kick.rom and rom.key) to android/data/sk.amiga.amikit/files/ROMs folder then open and edit .uaerc file which located android/data/sk.amiga.amikit/files folder.

#kickstart_rom_file=../../com.cloanto.amigaforever.essentials/files/rom/amiga-os-310- a1200.rom

If kickstart roms will be found then after start amikit you will see amigados screen with detection request for amigaos files.

I think not necessary use reboot device for restart amikit. For stopping amikit you can close it via recent tasks or via android settings->Apps->AmiKit then press button "Force stop"

Author Moviepro11
#3 Posted: 24 Jun 2014 15:38 
I installed Amiga Forever Essential for Android. I download the AmiKit.hdf file during the Amitkit installation. The is no .uaerc file anywhere.
Next screen is "To complete the AmiKit installation..." I click on the "Click here if the AmigaOS is located in one of the folders" button and then "The Amiga Operating System Files not found." screen. I put the amiga-os-310.a1200.rom, the rom.key and the renamed kick.rom file in both the ROMs folder and the AmigaForever folder. Still stuck at this point, please help me. I am out of ideas.

Author Lubomyr
#4 Posted: 25 Jun 2014 13:29 
Probably file .uaerc is invisible for your file manager, you can try another.
If you see screen "To complete the AmiKit installation..." that mean your kickstart roms is already detected.
Next, Amikit required detection Amiga OS files (not a kickrom files)

Author Moviepro11
#5 Posted: 28 Jun 2014 23:34 
"The Amiga Operating System Files not found." Is what I see. I do not get to the point where the screen reads "To complete the AmiKit installation..." . Has anyone else got it to work on Android? Maybe some screen shots and step by step instruction for installation. Tell me what OS to put at what place, what to rename and any other files needed.

Author Moviepro11
#6 Posted: 29 Jun 2014 17:19 
I am glad I didn't purchase the USB with the software on it. I have given up trying to get it to work on my android device. I asked many times for help with the wrong answer or no help what so ever. I guess it just doesn't work. NO documentation on how to install it. Be assured I will post on Facebook and any other social media what has transpired here. Shame on you.

Author Lubomyr
#7 Posted: 29 Jun 2014 22:30 
What you mean with incorrect answer ?
With one of your request you wrote next screen is "To complete the AmiKit installation..." that mean kickrom will be detected and emulation started.
You pressed button "Click here if the AmigaOS is located in one of the folders" and received screen "The Amiga Operating System Files not found."
You not need any action with kickroms files (as amiga-os-310.a1200.rom)
I think you know difference between kickrom files and amiga os files.
amiga-os-310.a1200.rom - is kickrom file (not a amiga os file)

Please read User Manual
------------------------------------------------------------------------------------- -------------
3) You will need Amiga Operating system files, see requirements above. Copy the files
to the corresponding sub-directory („Amiga Forever“ or “AmigaOS XL“ or
“AmigaOS3.9“ or “AmigaOS3.5“ of android/data/sk.amiga.amikit/files folder. The
files will be detected and imported to AmiKit automatically.

Author Moviepro11
#8 Posted: 29 Jun 2014 23:31 
I am sorry for my comment. I admit it when I am wrong and I was wrong. I do not know the difference between the two. I was looking for all the required software from the android amiga forever install. I have now taken the reuired files from my PC and have installed the app. Once again, I apologize.

Author Moviepro11
#9 Posted: 30 Jun 2014 19:28 
My final thought. Amiga OS 3.5 and 3.9 do not come with the Amiga Forever 2013 disk or with the Amiga Forever Essentials for Android. One must acquire these elsewhere. My trouble consisted with the thought that the files came with A.F. One I got the ISO I extracted it and placed the extracted files in the OS 3.9 folder. Once the files were there, the installation was flawless. No need to move files cause the software finds what is needed. Now on to some fun....

Author AmiKit
#10 Posted: 1 Jul 2014 21:30 
I am glad it works for you now. Enjoy.


Author kiasanth
#11 Posted: 21 Apr 2015 19:31 
I am up to the stage where it is looking for the OS files.
I have Amiga forever, Amiga Forever Essentials and also areal OS 3.9 CD
I've tried copying various files to the folder to no avail.

is it all files from the CD root directory?
Just the files in AmigaOS3.9/ on the CD?
just the files is AmigaOS3.9/Workbench3.9/

or something else?

Author AmiKit
#12 Posted: 22 Apr 2015 00:09 
To import OS3.9 CD files, simply copy all files from CD to the OS3.9 folder in Android.

Installation questions AmiKit Support Forum / Installation questions /
 Android 4.2.2 and AmiKit

Your Reply Click this icon to move up to the quoted message

Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


AmiKit Support Forum Powered by Forum Script miniBB ®