AmiKit Support ForumAmiKit Discord Chat
 Start Register Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 16 [28 Mar 2024 06:51]
Guests - 16 / Members - 0
Basic questions, I am new here AmiKit Support Forum / Basic questions, I am new here /  
 

Installing software from a cdrom

 
Author steveis22
Partaker
#1 Posted: 6 Dec 2023 15:47 
Hi,
I have a cdrom of wordworth office 6 and am trying to install it as I try out the donation version of Amikit before paying more for the new version. When the installer gets to the point of actually installing it tells me there is not enough space for installation in any drawer I choose or create.
Is there any way around this to install the doftware, or is it impossible?

Regards Steve

Author AmiKit
Admin
#2 Posted: 6 Dec 2023 15:57 
Hi Steve, it seems like a bug on Wordworth side. Is it possible to ignore the message and proceed with the installation anyway? Or try to install it into RAM: just to see what happens. If it works, just copy the files from RAM: to your location, and alter the assigns if the program makes any (usuall in S:User-Startup file).

Hope it helps?
Ján

Author wiisoldier
Partaker
#3 Posted: 7 Dec 2023 17:32 
Hi Steve,
The issue with the Wordworth 6 installer is that it is looking for a hard-drive for installation. It won't install to a folder version of a drive or to Ram. My solution was to recreate the AmiKit drive as a .hdf file (at least 1GB) and the installation went ahead OK. If you need instructions on how to do this, please let me know.
By the way. This worked for Wordworth 6 Office and Wordworth 7.
wiisoldier
P.S. After checking, Wordworth 7 did install to the folder version of AmiKit.
P.P.S. This was completed on AmiKit 11.9.0 (standard installation) / Raspberry Pi 4 / Amiberry v5.5.1

Author steveis22
Partaker
#4 Posted: 10 Dec 2023 04:38 
AmiKit
Hi Thanks for your reply
I can't get past the error about there being no space and I tried to install to ram but once again I'm told there is no space.

Steve

Author steveis22
Partaker
#5 Posted: 10 Dec 2023 04:43 
wiisoldier:
The issue with the Wordworth 6 installer is that it is looking for a hard-drive for installation.
Hi Thanks for your reply.
I have created a HDF drive and can copy things to it but can't install wordworth as I'm still told there is not enough space. However in your reply you said you 'recreated the amikit drive'. How can that be done as my new HDF drive is just a blank one?

Steve

Author wiisoldier
Partaker
#6 Posted: 10 Dec 2023 15:45 
Hi Steve,
The simplest way I have found is to use a workbench 3.1 setup as follows:
1: Open your emulator (Amiberry or WinUAE)
2: Choose a standard A1200 set up and add your wb3.1 disk image (adf) to df0: and set Floppy speed to turbo
3: Get a copy of Directory Opus and put it in a folder (lets call the folder «DOpus4»)
4: Go to the harddrive/CD tab of your emulator and create a hardfile (.hdf) at least 1.2GB and name it «AmiKit.hdf»
5: On the same tab add the following drives:
DH0: and use the DOpus4 folder
DH1: use your existing AmiKit folder but in your emulator name the drive as «AK_Folder»
DH2: use the AmiKit.hdf hardfile
6: Start the emualtion and wait for the workbench screen to appear.
7: Wait a few seconds and DH2: will appear as Non-DOS
8: Click once on DH2: and go to ICONS/Format disk and do a quick format naming it «AmiKit»
9: Once complete, open the DOpus4 Icon and start Directory Opus
10: In Opus choose one side as DH1: and the other as DH2:
11: Copy all files and folders from DH1: to DH2: (this may take a while and you may get one error of a dupliacate file which can be ignored)
12: You now have all AmiKit files on the hardfile (.hdf)
13: Restart the emulator and load your original AmiKit config
14: In the harddrive/CD tab you need to replace AK0: Amikit (folder version) with AK0: AmiKit.hdf. (bootable)
15: Keep all other folders the same and save the configuration under a new name such as AmiKit_HDF
16: Start the emulation and check everything works.
17: You should now be able to install Wordworth to your .hdf hardfile
Regards
wiisoldier
P.S. after you install Wordworth, you could reverse the operation and transfer all the files/folders from the .hdf file back to a new AmiKit folder and Wordworth should still work. Note that this might be needed for future updates of AmiKit to work. AmiKit 12 for Raspberry Pi does not work correctly from a hardfile as the operating system (Manjaro) needs access to some files on the Amikit side of things and it cannot do that with a .hdf file.

Basic questions, I am new here AmiKit Support Forum / Basic questions, I am new here /
 Installing software from a cdrom

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑