AmiKit - Your Modern Retro Amiga Experience
 Start Register Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 717 [7 Feb 2021 09:33]
Guests - 717 / Members - 0
Basic questions, I am new here AmiKit Support Forum / Basic questions, I am new here /  
 

Cant open the Windows folders in Amiga Workbench

 
Author amikit_noob
Partaker
#1 Posted: 10 Mar 2022 09:47 
AmikitX 10.5.3., OS4.1FE Classic ISO for install, default amikit (no customization), using Amiga keys to control mouse, Windows 7.

Hi, when I try to open the Windows folders (C: or D on workbench in AmikitX, the folder wont open. The folder just
«blinks/shakes» when I click/double-click on the folder, and it wont open.

All amiga-only folders in Amikit, open without a problem, its just the Windows folders that dont.

It happens both when I use a normal mouse, or when I use Amiga keyboard keys in Amikit to control the mouse.

It happens on a clean new Amikit install.

This problem sometimes comes and goes, most days there is no problem, then all of a sudden the Windows folder refuse to open, and repeated reboots doesn´t help.

Is it a problem that can be fixed in AmikitX 10.5.3 or will I need to upgrade to a newere amikit for the problem to go away ?

Thanks
amikit_noob

Author AmiKit
Admin
#2 Posted: 10 Mar 2022 09:49 
Hey, I believe this is more about WinUAE and the Windows itself. What you can try is to update winuae.exe, just download 32-bit ZIP archive from here: https://www.winuae.net/download/ and replace the old winuae.exe in AmiKit

Author amikit_noob
Partaker
#3 Posted: 10 Mar 2022 10:21 
Hi, I replaced winuae.exe itself, with the latest 32-bit version, it did not solve the problem.

(Did you mean I should replace ALL of winuae files or just the winuae.exe file ?)

But I CAN access the Windows folders another way: by typing the full path to the folder and press enter, at the bottom of the the DOpus window with all the folders in it.

I can also access the Windows folders, when I save a text file to a Windows folder, when I use MicroGolded text editor.

So the problem is only when I try to open a Windows folder by clicking the folder icon or folder name in DOpus window.

Thanks
amikit_noob

Author AmiKit
Admin
#4 Posted: 10 Mar 2022 10:27 
Perhaps there is disk.info file in the root of your Windows drive? If so, delete it, so a default icon is associated with the Windows drive on AmiKit desktop.

Author amikit_noob
Partaker
#5 Posted: 10 Mar 2022 13:48 
I deleted the disk.info file from Windows 7 C: drive, and booted Amikit, but the problem is still there, sadly...

I hope some solution will be found, but I can work around the bug, by accessing the Win folders using the other ways I mentioned.

Thanks for the help so far

amikit_noob

Author AmiKit
Admin
#6 Posted: 10 Mar 2022 15:20 
In that case the generic def icon for drive is corrupted. Check AmiKit:Prefs/Env-Archive/Sys/def_disk.info file, or even better, rename it, and then rename def_disk1.info to def_disk.info
And then reboot. This way you use a different def icon for drive. It should work then.

Btw. is it default AmiKit? With Directory Opus Magellan used as Workbench replacement, with AfA_OS?

Author amikit_noob
Partaker
#7 Posted: 10 Mar 2022 16:42 
No, that didn't work either, renamed def_disk1.info to def_disk.info, rebooted, still same problem...

Yes it is default AmiKit with DOpus Magellan as WB replacement, and with AFA OS, yes!

I can only open files/folders if shown as «Icon» in DOpus, file/folders will NOT open if shown as «Name» in DOpus!

It is actually ALL files/folders that sometimes have this problem, amiga-only files/folders AND Windows files/folders.

They ALL refuse to open if doubleclicked in DOpus window, when shown in «Name» mode.

amikit_noob

Author AmiKit
Admin
#8 Posted: 10 Mar 2022 18:36 
Please send me an email. I need to see that. Thanks.

Basic questions, I am new here AmiKit Support Forum / Basic questions, I am new here /
 Cant open the Windows folders in Amiga Workbench

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑