AmiKit - Your Modern Retro Amiga Experience
 Begin Register Reply Search Statistics Quick Guide  
Online now: Guests - 2
Members - 0
Most users ever online: 717 [7 Feb 2021 09:33]
Guests - 717 / Members - 0
Basic questions, I am new here AmiKit Support Forum / Basic questions, I am new here /  
 

HDMI, LG TV, and Overscan

 
Author Fluffymonkey
Partaker
#1 Posted: 19 Aug 2021 14:44 
Hi, first things first ... I'm a complete AmiKit n00b!

I set up AmiKit on my PI400 with a monitor, using the AmigaForever ISO. I'm using the latest version of AmiKit, as I only bought it a couple of days ago.

My problem:
When I set up the PI400 with the monitor, there was no overscan issue and the edges of the screen aligned with the edges of the desktop. I switched the old 23" monitor for a 32" LG HD TV, and now the desktop is larger than the screen and I can't use the bottom bar.

My question:
How do I change overscan in settings? I tried setting the zoom to 0.9 but that just makes the desktop issue worse, as more of it is unusable!

Author Fluffymonkey
Partaker
#2 Posted: 19 Aug 2021 15:00 
I should have said I am using version 9 of Amiga Forever ISO

Author AmiKit
Admin
#3 Posted: 19 Aug 2021 15:06 Edited by: AmiKit 
Hello! Do you mean the resolution in Linux or AmiKit?

In Linux you can change the resolution in the Display settings (use start menu to find it and launch it). Alternatively I found this thread: https://forum.manjaro.org/t/how-to-change-screen-resolution-in-manjaro-xfce-on-raspberry-pi/60758

Hope it helps?

In AmiKit you can change the resolution by Screenmode Prefs program located in AmiKit:Prefs folder.

Author Fluffymonkey
Partaker
#4 Posted: 19 Aug 2021 16:25 
How do I upload a photo of the problem I am seeing? A picture says a thousand words!!

Author Fluffymonkey
Partaker
#5 Posted: 19 Aug 2021 16:27 
The resolution is correct, full hd (1920x1080) bit the desktop is larger than the boundaries of the screen. This is usually called overscan, and I did find an overscan setting in AmiKit, but it's not related to making the desktop fit the screen as far as I can tell.

Author Fluffymonkey
Partaker
#6 Posted: 19 Aug 2021 17:23 
[imgs=https://ibb.co/P5qcVGb]Pic of what I see on the screen[/imgs]

Author Fluffymonkey
Partaker
#7 Posted: 21 Aug 2021 22:21 

Author Fluffymonkey
Partaker
#8 Posted: 21 Aug 2021 22:22 
Fluffymonkey
https://ibb.co/P5qcVGb

The bottom is off the screen, so is the top, and both sides. I've no idea what to do now

Author AmiKit
Admin
#9 Posted: 23 Aug 2021 02:12 
I am sorry for the delay.
Can you tell me what is the native resolution of your monitor, please?
Was this behaviour since the very beginning or you changed something?
Btw. have you tried altering Display settings in Amiberry? For example there's Auto Height enabled. Try to turn it off before you start the emulation. Perhaps it makes a difference?

Author Fluffymonkey
Partaker
#10 Posted: 23 Aug 2021 12:11 
AmiKit
Native resolution is 1920x1080, and it's an LG HDTV.
I set up AmiKit with a 22" HP monitor and it was fine.
I am a total linux newbie - Is Amiberry the linux OS or emulator? Either way I've tried many settings!
The overscan issue doesn't happen in the emulator, it only happens in the Linux OS.

Author AmiKit
Admin
#11 Posted: 23 Aug 2021 15:13 Edited by: AmiKit 
Some time ago I was a total Linux newbie too, no worries

The Linux OS is called Manjaro XFCE.
Amiberry, the Amiga emulator, is a Linux appliaction running on the Manjaro XFCE.

When you doubleclick AmiKit icon located on upper left corner of Manjaro desktop, Amiberry settings window is launched. When it appears, click Display and check some settings there - eg. the Auto Height as I mentioned before.

Just be advised that some settings cannot be changed while the emulation is running. So if you want to change something on the fly, press F12 (fn+F12) to show the Amiberry settings window and quit the emulation. Then launch Amiberry again, change some settings and start the emulation again.

Meanwhile I'll ask the author of Amiberry about the issue you are experiencing. Thank you for the screenshot! Btw. is the Manjaro Linux desktop cut off too? Or just AmiKit desktop?

Author Fluffymonkey
Partaker
#12 Posted: 25 Aug 2021 12:09 
Both desktops are cut off.

I though that the emulation desktop was OK but I can move my mouse off the top, bottom, left, and right of the screen.

I'm going to try a clean install using the TV as the setup device to see if that changes anything - I still have the AmigaForever ISO on the USB stick so it should be quick and easy to do.

Author Fluffymonkey
Partaker
#13 Posted: 25 Aug 2021 13:07 
AmiKit
I've re-done the SD-CARD via BalenaEtcher, and I can confirm the the desktop in Linux is still cut off, and so is the Amiberry emulator.

Author Fluffymonkey
Partaker
#14 Posted: 25 Aug 2021 13:24 
AmiKit
https://pasteboard.co/KhvQsvi.jpg - Linux desktop
https://pasteboard.co/KhvRkq8.jpg - Amiberry desktop

If I double click the amiberry icon the setting pop up but there's no overscan/scaling option I can see?

Author AmiKit
Admin
#15 Posted: 6 Sep 2021 01:05 
Again, sorry for my late reply. My family needed my attention a lot.

If the Linux screen is cut off, then, at least, it's not AmiKit problem. It seems like Linux (Manjaro XFCE) doesn't fully support your TV? Since I cannot reproduce it here, could you try to google "Manjaro XFCE" and "Cut Off" ? Perhaps it's in TV settings? https://bbs.archlinux.org/viewtopic.php?id=142339

Basic questions, I am new here AmiKit Support Forum / Basic questions, I am new here /
 HDMI, LG TV, and Overscan

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑