AmiKit - Your Modern Retro Amiga Experience
 Begin Register Reply Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 324 [28 Nov 2019 07:12]
Guests - 324 / Members - 0
Vampire related questions AmiKit Support Forum / Vampire related questions /  
 

CD Rom support using Amikit XE on Vampire V2

 
Author OldB0y
Partaker
#1 Posted: 12 Sep 2020 10:27 
Hi,

re.: CD Rom support using Amikit XE on Vampire V2

I'm running Amikit XE on my A1200 with Vampire V2. I'm really impressed, but can't get my IDE CD Rom working.

I have two (possibly 3) options:-

1) Use Elbox/Powercomputing FastATA v2/Power Flyer Gold (as the uk version from Power computing was known)

https://bigbookofamigahardware.com/bboah/product.aspx?id=1446

2) IDEfix97 with ancient buffered 4 way adapter that specifically works with IDEfix97:

https://bigbookofamigahardware.com/bboah/product.aspx?id=561

I disconnected the FastATA board, as initially my Vampire had the GOLD2.11 which used the Vampire's onboard IDE. I'm now back with the Amiga's IDE, having upgraded to GOLD2.12.

I used Amiga OS3.9 as the base for the Amikit install.
The 'hard drive' is a 8GB CF card in a standard CF -> IDE adapter connected to the Amiga's internal IDE via the buffered 4way adapters 44 pin
The DVD Rom is connected to the second IDE port on the adapter.

I 've tried IDEfix97, but it doesn't appear to be compatible with the Vampire at all, and causes it to crash to the point where it needs a hard reset.

I haven't re-installed the FastATA board, as its a bit of a pain to do, and I can't see any definitive answer regarding if it will work or not - apparently a later version will though according to their wiki.

The third option I have is the Squirrel SCSI PCMCIA, but as the machine is in a tower setup this requires a right angle PCMCIA adapter, and frankly I don't want to go down this route unless I have to.

Does anyone have any suggestions, or can confirm if the fastATA controller may work etc?

weirdly, although the Idefix software won't work, one of the tools that comes with it that scans for connected devices, and can see my Toshiba DVD drive.

Many thanks in advance

Rob

Author AmiKit
Admin
#2 Posted: 12 Sep 2020 10:34 Edited by: AmiKit 
Hi Rob, I don't have any CD-ROM myself so I am afraid I won't be able to help. But, can you post your question on AmiKit Slack channel? I believe the Vampire users will help you in real time there.

One more thing you can try is the pre-installed CD0 driver in AmiKit:Storage/DosDrivers drawer. Just double-click the CD0 - maybe it works?

Author OldB0y
Partaker
#3 Posted: 12 Sep 2020 11:27 
Its okay - I have fixed it!

Used the already installed cacheCDFS, updated CD0 to use atapi.device unit 2 - bingo!

All working with the 4 way adapter.

Author AmiKit
Admin
#4 Posted: 12 Sep 2020 11:56 
Great!!

Author OldB0y
Partaker
#5 Posted: 12 Sep 2020 18:28 
Now after over 20 years, I can finally play 'Napalm' and a few others, as originally intended by their authors

Next task, to try setting up the ethernet module.......

Vampire related questions AmiKit Support Forum / Vampire related questions /
 CD Rom support using Amikit XE on Vampire V2

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑