AmiKit - Your Modern Retro Amiga Experience
 Begin Register Reply Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 324 [28 Nov 2019 07:12]
Guests - 324 / Members - 0
Mac related questions AmiKit Support Forum / Mac related questions /  

Can't run AmiKit Mac - Just hangs

Author JonnieCache
#1 Posted: 1 Apr 2019 03:44 
I am just trying to get AmiKit X up and running on my Mac. I have tried multiple things:

- Uninstalled and reinstalled XQuartz 2.7.9.
- Tried using A1200 rom from Amiga Forever 8
- Tried using A1200 rom from AmigaOS 4.1
- Tried updating Wine directory
- Tried updating WinUAE.exe

Even if I just install only the A1200 rom, it will not start. The icon bounces for a LONG time before XQuartz launches. Then, it bounces some more and then stops bouncing.

I'm running the newest AmiKit X on macOS Mojave 10.14.4.

Any assistance is appreciated!

Author AmiKit
#2 Posted: 1 Apr 2019 11:29 Edited by: AmiKit 
Hi Jonnie and welcome to support forum!

I've just re-activated your download link. Please download AmiKit installer again as the link might contain a slightly newer version than you had.

Meanwhile I will update my Mojave 10.14.3 to 10.14.4 and see whether AmiKit still works. I will keep you updated.


Author AmiKit
#3 Posted: 1 Apr 2019 13:39 
It works here with Mojave 10.14.4 too.

Did re-install of AmiKit help? Please restart your computer too. Try to launch AmiKit with internet disconnected. Does Flower Pot work on the same computer?

Author JonnieCache
#4 Posted: 2 Apr 2019 02:43 
Okay, I think I figured it out. I had AmiKit on the Accessibility list in the Security Settings, but it also had another AmiKit X listed there. I removed both of them, rebooted, reinstalled AmiKit X, and then it started working.

I figured it out when I went to run Flower Pot, which worked right away. It wanted me to add to the exception to the Accessibility list and that's when I noticed that AmiKit X was listed twice (once with the .app and I'm assuming the other was the actual executable within the .app).

So, it's working now!


Author AmiKit
#5 Posted: 2 Apr 2019 06:44 
Good to hear. Enjoy AmiKit again!

Mac related questions AmiKit Support Forum / Mac related questions /
 Can't run AmiKit Mac - Just hangs

Your Reply Click this icon to move up to the quoted message

Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


AmiKit Support Forum Powered by Forum Script miniBB ®