AmiKit - Your Modern Retro Amiga Experience
 Start Register Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 717 [7 Feb 2021 09:33]
Guests - 717 / Members - 0
Linux related questions AmiKit Support Forum / Linux related questions /  
 

Sound problem on Linux Mint

 
Author steveis2
Partaker
#1 Posted: 1 Nov 2022 09:14 
Hi,
I've just installed flowerpot but the sound does not work. Can anyone suggest why this is happening or perhaps a solution. I've tried tinkering with sound in the configuration but nothing seems to work so perhaps it's a flowerpot specific issue. I don't know.

Regards Steve

Author AmiKit
Admin
#2 Posted: 1 Nov 2022 10:36 
Hi Steve, in WinUAE/Sound section there is a pull-down menu on top of the section. Try different settings there if they are available - WASAPI, DSOUND, etc.
Note that those settings needs to be adjusted before the emulation is started. Switching them on the fly would not have an effect, I guess.
Please let me know.

Also let me know the Linux distro you use and the computer specs, please.

Thank you,
Jan

Author steveis2
Partaker
#3 Posted: 1 Nov 2022 14:54 
Hi,
The drop down list at the top of the page is blanked out and can't be accessed. I have however tried changing many of the settings available on the config page. None of them seem to make any difference. Looking at the hardware info link there does not seem to be any sound card I think.
I'm using Linux Mint 20.2

Regards Steve

Author steveis2
Partaker
#4 Posted: 1 Nov 2022 15:04 
steveis2
Computer specs as follows. I should have added them in the earlier post

AMD 3600X CPU
16Gb ram
480Gb ssd
B450M Pro4-f motherboard

Author AmiKit
Admin
#5 Posted: 8 Nov 2022 09:52 
Hmm, does the sound work in the Mint itself? The case might be that PlayOnLinux (used by AmiKit/FlowerPot) is not fully compatible with Mint. By any chance, can you try it on a different distro? I am sorry for the inconvenience.

Author steveis22
Partaker
#6 Posted: 8 Nov 2022 10:44 
Hi Thanks for your reply
Sound works fine in Mint. I can set up another version, maybe ubuntu, on another pc although it's a slower CPU. I'll try that out in the next few days.

Steve

Author steveis22
Partaker
#7 Posted: 14 Nov 2022 21:29 
AmiKit:
can you try it on a different distro? I am sorry for the inconvenience.
Hi
I have now tried os4.1 on the very latest version of mint (mint 21) but it does not produce any sound. I have also tried it on Ubuntu 20.04 but it's not producing any sound there either.
Is there a particularly suitable version of linux that I could try?

Steve

Author AmiKit
Admin
#8 Posted: 15 Nov 2022 16:24 
Hi Steve and thank you for your report. Meanwhile another user reported no sound on his Mint and he was not able to initialize even with other versions of Wine.

But Ubuntu should work, I am confused. When you check the WinUAE/Sound settings, it is the same as with Mint? No sound devices displayed in the upper drop-down menu?

Author AmiKit
Admin
#9 Posted: 15 Nov 2022 18:31 
Since I am not a Linux guy, I just have been instructed that Mint and Ubuntu are practically the same distros...

The guy who created the Linux install script for AmiKit/FlowerPot will look into the issue. Btw. he normally uses Manjaro with Gnome 3 if that helps.

I am very sorry for the inconvenience you're experiencing.

Author steveis22
Partaker
#10 Posted: 15 Nov 2022 18:34 
Hi,
Initially in Ubuntu the winuae sound settings were not displayed. However I have changed the file and folder names in the winuae folder. I think this means it's running 32 bit not 64 bit winuae. Sound now works in ubuntu albeit in a broken and not very clear way. The sound settings are available. Perhaps I can change some to get a clear sound.

Steve

Author AmiKit
Admin
#11 Posted: 15 Nov 2022 18:37 
Wow, what file/folders names?

Author steveis22
Partaker
#12 Posted: 16 Nov 2022 10:16 
Hi,
I just followed the instructions that are in the tips section of the pdf guide that refer to the 32bit version of winuae working slowly. The aim is to change from the 32 bit to the 64 bit version with the intention of speeding things up. However having done it it seems to make the sound 'sort of' work. In the sound section of winuae settings I've tried the various settings in the top drop down list and the DSOUND options appear to work the best although the sound quality is still not good.
The ubuntu installation is on a slowish computer so I'll try it on a faster PC next. Perhaps that will make a difference.

Here's the info from the pdf guide

64-bit WinUAE might be slow on Windows or Linux system, therefore the 32-bit
version is used by default. To switch to 64-bit, in WinUAE folder, rename current
"winuae.exe" to "winuae32.exe" and then rename "winuae64.exe" to "winuae.exe". Also
rename «Plugins» folder to «Plugins32» and then rename «Plugins64» to «Plugins»

Steve

Author steveis22
Partaker
#13 Posted: 16 Nov 2022 15:53 
Hi
I was trying out the name changes on an older cpu but I've now done it on a much more modern PC and sound works far better. The older cpu was a core2 duo but the faster one is a Ryzen 3600x. It makes a big difference.

Steve

Linux related questions AmiKit Support Forum / Linux related questions /
 Sound problem on Linux Mint

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑