AmiKit - Your Modern Retro Amiga Experience
 Start Register Search Statistics Quick Guide  
Online now: Guests - 1
Members - 0
Most users ever online: 717 [7 Feb 2021 09:33]
Guests - 717 / Members - 0
Linux related questions AmiKit Support Forum / Linux related questions /  
 

Amikit Linux no sound (MX Linux 21.1)

 
Author tvandorffy
Partaker
#1 Posted: 25 Jul 2022 17:19 
[Solved] The PlayOn Linux icons were starting the 32 bit version of WinUAE. With the 64 bit version WinUAE detects the sound devices!
[Solved] As a very crude solution I copied the 64 bit version exe as winuae.exe and now the problem is fixed.
[Solved] I recommend using hte directsound device because the WASAPI device's sound is distorted.

Hi there,

I have successfully installed Amikit Linux on MX Linux 21.1.

I had only three problems:
-The first is that windowed mode did not work for me at all for WinUaE. (Not even Full-window mode)
I had to modify the WinUAE configs to use Fullscreen. I had to do check and modify at each reboot.

-After installing the system, it is possible to update to the latest version) after supplying the subscription information.
After the update, the system just presented me with an empty CLI prompt. Turned out that the kickstart rom was not the right one in WinUAE.
(I am using the kickstart rom for the 3.1.4 OS (A1200) After manually setting it up, amikit booted.

-My biggest problem right now is that there is no sound in WinUAE. I was not able to solve this.
When I press F12 and go to Settings->Host->Sound there is no audio device listed there, the dropdown is just blank.
When I select «configure winue» when right clicking the PlayOnLinux start item «Amikit XE», my system's sound server (pulseaudio) is detected correctly and the audio test was just fine.
So I guess this should be okay, but still, there is no sound in WinUAE.
I know, this might be a Wine issue, but I wonder if anybody has an idea or faced this same problem before.

My motherboard is a «TUF GAMING X570-PRO (WI-FI)», my CPU: AMD Ryzen 9 5900X and my Audio is: AMD Starship/Matisse HD
There is two audio device in my system, one is my motherboard, the other is my NVIDIA GeForce GTX 1060 gpu (via hdmi)
My kernel version is: 5.17.0-3mx-amd64 (AHS), I am using the 515.57 version of the NVIDIA driver
My wine version is 6.10

I also examined the WinUAE's boot log. In this I have found that WinUAE was not able to detect any «WASAPI» or «directsound» devices:
(...)
Enumerating WASAPI devices...
Enumerating DirectSound devices..
Enumeration end
(...)

Thanks a lot,

Tamas

Author AmiKit
Admin
#2 Posted: 26 Jul 2022 00:51 
Hey Tamas, I am glad you solved it!
Btw. isn't the boot time slower with 64-bit version of WinUAE now? I experienced such issue on Windows at least. The boot time took twice as much time with 64-bit.

Author tvandorffy
Partaker
#3 Posted: 26 Jul 2022 14:19 
Thanks!

The boot time Amikit using the 64 bit WinUAE is around 10 seconds on my system which is fine with me.
I did not really measure the boot time for the 32 bit version.
I have a fast computer, so I am not sure if my boot time is average or not.
Maybe it would be a good thing to add an option to the Launch app for a future version so it would be possible to choose what WinUAE should be used at boot time.
(Or maybe there is already one but I did not notice it! )

BTW, very cool new background picture!

Author AmiKit
Admin
#4 Posted: 26 Jul 2022 14:41 
Thanks! Whenever you get a chance, measure the boot time with 32-bit WinUAE. I am curious.
On my Windows it's:
64-bit boot time: 8.85 seconds
32-bit boot time: 4,70 seconds

Author tvandorffy
Partaker
#5 Posted: 26 Jul 2022 15:42 
Here are all the boot times on my system.
I measured from boot start until the cool background first appeared. (Did not wait until the end of the Amikit splash screen)

Amikit Linux 32 bit boot time 8.36
Amikit Linux 64 bit boot time 11.28

AMikit Windows 32 bit boot time 5.03
AMikit Windows 64 bit boot time 8.26

One more remark: Using Amikit and then change to e.g. to a browser, then back to amiga made the mouse not being trapped again in amiga mode.
Changing the «Mouse untrap mode» in Settings->Host->Game port to «None (Alt-tab) helped.
Now I can change back from Amikit, check something on the net and change back to amikit again without problems.
Update: I was once able to reproduce this problem even with this setting. But works most of the time...

Author AmiKit
Admin
#6 Posted: 28 Jul 2022 11:13 
Interesting, thank you! It confirms that 32-bit WinUAE is really faster when it comes to read/write operations. I already reported that to the author of WinUAE but the reason of such behavior is still unknown. I recommend using the 32-bit version. The only advantage of using the 64-bit version is that you can assign more RAM for Amiga emulation, but even with 32-bit version you can assign way enough RAM anyway. More than AmigaOS ever needs.

Linux related questions AmiKit Support Forum / Linux related questions /
 Amikit Linux no sound (MX Linux 21.1)

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑