Your high-end Amiga!AmiKit turns your PC into high-end Classic Amiga environment! 
Welcome to AmiKit Support Forum!

(Click here for main AmiKit website)
none
 
  Forums Search Register Statistics FAQ  DONATE 
Miscellaneous topics AmiKit Support Forum / Miscellaneous topics /

Self-booting AmiKit X (RabbitHole problems!)

Author amikit_noob
Registered
#1 Posted: 3 Jun 2017 09:19 Edited by: amikit_noob 
I made AmiKit X boot up by itself, by making a shortcut to the WinUAE config file (full-window.uae), and placed shortcut inside Startup folder in Windows 7.

This boots AmiKit X after Windows is finished loading,

BUT then RabbitHole programs won't open (if I boot AmiKit X using the Startup shortcut)

(If I shutdown AmiKit X and then boot AmiKit X again then RabbitHole programs work again)

Do you have any idea why RabbitHole programs wont work in AmiKit X, if booted using Startup shortcut?

Thanks
Regards
amikit_noob

Author AmiKit
Admin
#2 Posted: 3 Jun 2017 20:41 
Probably it cannot find the winlaunch.alib file if launched like this. Try to copy it from WinUAE\winuae_dll to WinUAE folder.
Or check WinUAE 3.5 where the winlaunch is integrated.

Author amikit_noob
Registered
#3 Posted: 5 Jun 2017 02:27 Edited by: amikit_noob 
Thanks, it worked after copying winlaunch.alib file to WinUAE folder

I hope you can make this similar problem work also:

If AmiKit X boots using Startup shortcut, and I double-click on a .mp4 or .pdf file inside the Amiga filemanager, that file won't open in a Windows program, like it should when using "Full-window/RabbitHole compatible" configuration in WinUAE.

But if I boot AmiKit X normally, then .mp4/.pdf files inside Amiga filemanager will open just fine in a Windows program.

Is there a similar solution, where another file should be copied to WinUAE folder, like in the previous problem ?

Thanks
Regards
amikit_noob

Author AmiKit
Admin
#4 Posted: 6 Jun 2017 14:10 Edited by: AmiKit 
I have no idea what's happening there. Probably some absolute vs. relative path problem?
What you're trying is not a regular way to start AmiKit so I am afraid I cannot help you there much. I am sorry.

Author amikit_noob
Registered
#5 Posted: 10 Jun 2017 20:44 Edited by: amikit_noob 
Ok, I'm booting AmiKit X normally from now on...

Miscellaneous topics AmiKit Support Forum / Miscellaneous topics / Self-booting AmiKit X (RabbitHole problems!) Top
This topic is closed. New replies are not allowed.
 
Online now: Guests - 1
Members - 0
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0