Your high-end Amiga!AmiKit turns your PC into high-end Classic Amiga environment! 
Welcome to AmiKit Support Forum!

(Click here for main AmiKit website)
none
 
  Forums Search Register Reply Statistics FAQ  DONATE 
I want to leave a feedback AmiKit Support Forum / I want to leave a feedback /

Finally - Up and Running

Author Ray Richards
Registered
#1 Posted: 23 Aug 2009 12:49 
Downloaded AmiKit a couple of weeks ago and TRIED to install it...All I got was errors...most of them saying that Cloanto AmigaForever was not a valid installation etc...so last night I decided to do a fresh windows install...backed everything up,formatted the disk and re-installed Windows XP. Updated everything and re-installed AmigaForever and AmiKit...Installation was a breeze...Everything works and it looks FANTASTIC.

Have already bought the AmiKit CD from this website ( with a donation )

Cheers guys

Ray

Author AmiKit
Admin
#2 Posted: 23 Aug 2009 13:00 Edited by: AmiKit 
Thanks for your feedback, Ray. I am glad you managed to install AmiKit and you like it. Enjoy!

Your AmiKit CD has been sent yesterday. Sorry for the delay, I've been on holidays. And many thanks for your donation! I greatly appreciate your support. I've already added your name on "who donated" page.

I want to leave a feedback AmiKit Support Forum / I want to leave a feedback / Finally - Up and Running Top
Your Reply Click this icon to move up to the quoted message
 

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.
 
Online now: Guests - 1
Members - 0
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0