AmiKit - Your Modern Retro Experience
  Forums Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0
I have a specific problem with AmiKit AmiKit Support Forum / I have a specific problem with AmiKit /  
 

AWEB very s l o w after installation of update 1.1

 
Author TrevorDick
Partaker
#1 Posted: 2 Apr 2006 21:43 
Following the installation of Amikit 1.1 AWEB has slowed to "snail's pace".

Pages take forever to load 10 to 20 seconds or longer. Some pages hang up completely? IBrowse stll OK however. I have AmiKit installed on 2 PC's (desktop & Laptop) and have the same problem with AWeb on both. Any suggestions?

Thanks

TrevorDick

Author AmiKit
Admin
#2 Posted: 3 Apr 2006 15:17 Edited by: AmiKit 
Hi Trevor!

Well, someone already reported this behaviour:
http://www.amiga.org/modules/newbb/viewtopic.php?topic_id=30274&forum= 22#forumpost367080
but I am not able to reproduce it. AWeb runs just fine here. The only slowdown I noticed is during the first inicialization of AWeb itself. That's because AWeb loads all the truetype fonts at the beginning.

Anyway, it seems the slowdown might be caused by truetype fonts used in AWeb. There are few possibilities how to solve this situation:

1) You can always revert to your non-truetype config by MotpheuZ tool, but this will disable all truetype fonts, not only those used in AWeb.

2) You can use non-truetype config for AWeb only. Rename "browser_noTTF" file to "browser" located at "AmiKit:Prefs/Env-Archive/AWeb3/" drawer, but please keep also the original "browser_noTTF" file there, otherwise MorpheuZ will be confused and won't work anymore.

3) ...or you can edit truetype font preferences in AWeb's "Browser settings" section and delete all the fonts EXCEPT "Normal" and "Fixed width" fonts. Hope it helps.

I'd recommend to try the point 3) first so you can keep your AWeb in truetype suit (provided the solution will work of course ;)

Author TrevorDick
Partaker
#3 Posted: 3 Apr 2006 22:15 Edited by: TrevorDick 
No time to investigate at the moment. However as a quick check I turned off truetype fonts. AWeb worked fine! I have AmiKit installed on a desktop, a laptop and a small notebook pc. On the Desktop and laptop truetype fonts appears to affect the performance of AWeb. However on the notebook truetype & AWeb work OK together? Strange!

Author AmiKit
Admin
#4 Posted: 4 Apr 2006 13:19 
yep, strange, but maybe I have an idea what is wrong, I'll investigate it... However I will need your help because AWeb works fine here, you know.

I think there is a problem with windows truetype fonts. They are copied from Windows installation to AmiKit:Fonts/Truetype directory during the update procedure. AWeb is configured to use all of them. I was thinking about two theories:

A) some of the fonts are missing in Windows directory and thus they are missing in Amikit as well. And AWeb gets slowdowned if it misses some fonts...

B) there are different versions of truetype fonts across various Windows versions or even among the same version of Windows. Some of them cause the slowdown of AWeb and some of them not.

Trevor, please check your "AWeb slowdowned" configuration and tell me what is located in AmiKit:Fonts/TRUETYPE directory or better send me the content. THANK YOU!

You can also compare this directory with your "AWeb works fine" config.

Author AmiKit
Admin
#5 Posted: 4 Apr 2006 17:35 
I think I found out the problem, please refer here and let me know whether it works. Thanks.
http://amikit.amiga.sk/forum/index.php?action=vthread&forum=7&topic=83

Author TrevorDick
Partaker
#6 Posted: 8 Apr 2006 00:09 Edited by: TrevorDick 
Thanks,

I have not had a chance to check out the solution. However have just re-installed 1.1.1 on my main Desktop PC and that have solved the problem.

The reason I did a new installation is that my AmiKit start-up broke after installing 1.1? However is was OK on the laptop and notebook. Installing 1.1.1 cured the startup problem on the Desktop and AWeb slowdown. Many thanks!

TrevorDick

I have a specific problem with AmiKit AmiKit Support Forum / I have a specific problem with AmiKit /
 AWEB very s l o w after installation of update 1.1

Your Reply Click this icon to move up to the quoted message

 

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 
 
AmiKit Support Forum Powered by Forum Script miniBB ®
↑ Top