AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 605 [18 Apr 2019 18:52]
Guests - 605 / Members - 0
Specific questions AmiKit Support Forum / Specific questions /  
 

Amikit freezes -> logfile?

 
 
Page  Page 2 of 2:  « Previous  1  2

Author Clyde
Partaker
#16 Posted: 16 Mar 2009 23:12 
Ok, the author wrote me, that he don't believe that it does a matter whether this tooltype is active or not but he thinks it depends on the value. So, he said, that all programs use TOOLPRI=0 and he delievers LimpidClock with TOOLPRI=1. And indeed with 0 as well as 1 I don't get the freezes, but as soon as I set up a negative values (-1, ...) AmiKit immediately freezes ... He thinks it is a kind of deadlock when LimpidClock runs with too less priority ... He also thinks that this is not due to an error of LimpidClock, but the AmiKit distribution is over and dead patched so it is no wonder that nothing really works.
Well, I am not his opinion, I love AmiKit, everything works perfect, only this little thing is strange ...

Author AmiKit
Admin
#17 Posted: 16 Mar 2009 23:32 Edited by: AmiKit 
AmiKit distribution is over and dead patched
Heh, Thomas always says this.

The LimpidClock with priority +1 is not a good idea as it slows down certain other processes. This was the reason why the priority was decreased in Live Update 1.3.2 for the first time. Now in AmiKit 1.5.7 it was decreased even more (to -15).

I would say there must be some other program or patch or whatever that is co-responsible for the crash. I hate these multi-dependencies Would it be dare to ask you for another interpolation bug tracing? This time keep only LimpidClock in WBStartup.

Author Clyde
Partaker
#18 Posted: 16 Mar 2009 23:37 
Ok, I will do this test. But I can't promise to do this very quick. I hope you understand that, as this is very time consuming ... But be sure, I will do that soon!

Good night so long ...

Author AmiKit
Admin
#19 Posted: 16 Mar 2009 23:45 
Many thanks!

Author Clyde
Partaker
#20 Posted: 17 Mar 2009 00:25 
Ok, I just wanted to test quick, whether there are freezes with just Limpid in WBStartup and nothing other. And the freeze is still there!

So, I think maybe it could be a program that is started via startup-sequence? Are there other files in S: I have to edit?

Author AmiKit
Admin
#21 Posted: 17 Mar 2009 00:31 
As far as I remember there's also MUIWhell patch in user-startup.

Run >NIL: MUI:Goodies/MUIWheel/MuiWheelPatch

Page  Page 2 of 2:  « Previous  1  2 
Specific questions AmiKit Support Forum / Specific questions /
 Amikit freezes -> logfile?

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑