AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 3
Members - 0
Most users ever online: 605 [18 Apr 2019 18:52]
Guests - 605 / Members - 0
Specific questions AmiKit Support Forum / Specific questions /  
 

AK 1.5.0 fails to start on my system!

 
 
Page  Page 1 of 2:  1  2  Next »

Author Artha Parson
Partaker
#1 Posted: 20 Sep 2008 10:54 
Hi Jan, all,

I installed the new AK's version 1.5.0 recently and let it overwrite the former installation. The new installation is not working although it did load up once and i did see the Workbench screen.

Former installation worked great indeed especially after I bothered Jan himself for a couple of days or more via many emails and he helped me through things so AK started working finally on my system.

I can give a hint as to how things may have gone wrong:

1. the Amiga Format installation on my laptop is from a 2006 disk and according to Jan, it is not quite compatible with even the former versions of AK.

2. Jan helped me with a different Startup-Sequence than the one that was originally on the AK's installation and it was the main thing that helped me through with the AK's loading problems.

I do have a copy of that SS file and replaced the new AK's SS file with that one but it's not working.

Now, even I were able just to roll back to the older version of AK I'd be happy enough anyway. How can I do that: do I just have to use the older version of WinUAE, or do I need an older version of the AK installer file?

The version that did work was the one with WinUAE 1.4.4 if that can help here.

Thanks for any suggestions or info that may come from anyone.

Best regards,
SP

Author AmiKit
Admin
#2 Posted: 20 Sep 2008 11:15 
Hello,

first of all, have you used the UPDATE installer to update your AmiKit 1.4.4 to 1.5.0?

What exactly is not working on your system? How it behaves? Any error report or just a black screen or boot screen, anything?

What Windows version do you use? Note that since WinUAE 1.5 the Windows98 is not supported.

You can also download the older WinUAE 1.4.6 ZIP archive and copy the WinUAE.exe into your AmiKit\WinUAE\ folder. (But remember to backup the newer WinUAE.exe there)

Author Artha Parson
Partaker
#3 Posted: 20 Sep 2008 23:15 
Hi dear Admin,

No, I had not used that update yet, I'm going to do it now.

Many items do not quite work: no error reports of any kinds, not a black screen either but the boot screen does appear only it cannot work by either of the two options below:

1. boot via Installed AF
2. boot via AF CD (Amiga Forever 2006)

although I have both of the above available.

On my first installation of the AK I did also have similar problems and Jan (you?) kindly helped me with it back then about two years ago and finally a different Startup-Sequence worked for my setup. I am using that SS file now but still have issues.

For example, the Paths screen on WinUAE Properties window does not let save the changes I make to them; same with the ROM screen where only the Extended ROM field can be changed and preserved but not the Main ROM file. (It was not like that in the past and I could change both of them and save them too.)

I already have the WinUAE 1.4.6 archive, unzipped it, installed it too, it shows up, but does not work as expected. I have tried reboots and all that, none worked. The point of the matter is that the previous installation worked great even after a few updates to newer WinUAE.exe files.

Anyway, let's see what happens after the AK _update14x-150.exe is going to be installed. Will keep you informed.

Best thanks,
AP

Author Artha Parson
Partaker
#4 Posted: 20 Sep 2008 23:33 
Ok, the AK _update14x-150.exe was installed but still the same problems. What I get mostly is the 'Safe' boot screen that stops responding.

Btw, Windows XP Home is the one I'm using on the laptop. The point however is that upon the first installation, it booted up once and I did see the AmiKit's Workbench screen but only once and it did not happen again.

I'd really like to roll back to what I had previously since it was working fine indeed!

Any suggestions on how to do that?

Many thanks,
AP

Author Artha Parson
Partaker
#5 Posted: 20 Sep 2008 23:39 
Hi again,

Btw, what is a "rom.key" file that is needed to be placed in AK's ROM folder?

I can't find it anywhere!?

Thx again,
AP

Author AmiKit
Admin
#6 Posted: 21 Sep 2008 00:22 Edited by: AmiKit 
If you don't mind re-installing...

1. Uninstall AmiKit
2. Install the older AmiKit version that worked for you (use the modified startup-sequence you mentioned)
3. Run AmiKit and finish the installation on Amiga side
4. Quit the emulation
5. Install the appropriate updates

For further troubleshooting I will need more information than just "it doesn't work".

Author Artha Parson
Partaker
#7 Posted: 21 Sep 2008 02:52 
hi Admin,

I'd be really willing to uninstall the AmiKit and then reinstall it only I have to find the older installation version. (Although i must have a backup of it somewhere but is it on AK site too?)

by "it doesn't work" I mean it runs but not the way it should: can't get to the Workbench screen. Certain features on the configuration screens of WinUAE also have problem working right as I have mentioned in the previous emails.

What if I uninstall and reinstall this latest version anyway?

Best regards,
AP

Author Artha Parson
Partaker
#8 Posted: 21 Sep 2008 07:11 
hi Admin again,

I uninstalled the whole thing, reinstalled the 1.4.4 version I had kept somewhere but still the same problem.

I get the 'Safe' boot up Amiga Shell but nothing happens. I have left it running for more than half an hour now so that as you said the bootup after the first installation takes quite a while but nothing is happening yet. I'm going to wait more though and see what happens.

What if go to Windows System Restore and see if I can do something there to get the working installation back?

Regards,
AP

Author AmiKit
Admin
#9 Posted: 21 Sep 2008 08:52 
System restore doesn't help. Please un-install AmiKit and install it exactly the same as you did in the past, with the help of the modified startup-sequence.

"can't get to the Workbench screen" doesn't help me either. What do you see on the screen?

AmiKit should work with its default WinUAE configuration. No changes are necessary.

Author Artha Parson
Partaker
#10 Posted: 21 Sep 2008 09:31 
hi again:

Error messages i get if i click on the closing gadget of the 'Safe' CLI screen and when the AmigaDOS CLI screen pops up:

Loading L:Ram-Handler failed: object not found
C:LoadModule failed returncode 10

hope it helps.

i'm going to laod an older AmiKit installer.

for now,
AP

Author AmiKit
Admin
#11 Posted: 21 Sep 2008 09:53 Edited by: AmiKit 
There are two possibilities after un-installing everything:

1. Install the older AmiKit as I mentioned above and then use the update installer.

2. Install fresh new AmiKit 1.5.0

Do not change any config. If anything goes wrong I need exact information what you did, where it stopped and what appeared on the screen.

Thanks!

Author Artha Parson
Partaker
#12 Posted: 21 Sep 2008 11:16 
OK!

got it at last!

i did the two steps you said above, then upon installation Amiga system files off a CD, this time i tried my brand new never before opened Amiga OS3.9 CD and it worked!

(formerly, i used my AmigaForever CD and AK's installation script rejected it as original while it is an original one and already installed. AK's installation script also did not like the AF Instlled option rejecting that one too!)

only, i think i'll use the same old Wb background screen with a blue-black color scheme again. the new green one is ok too but i prefer the other one!

Thx alot for your great warm support Jan and i think i'm quite set now.

Kiss your kitten for me!

c u!

best wishes,
AP (Shahbaz Parsipour - AP is my newborn daughter's initials.)

Author AmiKit
Admin
#13 Posted: 21 Sep 2008 11:31 Edited by: AmiKit 
The possible reason why it did not accept your Amiga Forever CD (or installation) is that it's older AmigaForever version, for example v6 or even earlier.

AmiKit supports AmigaForever 2005 (do not confuse it with AF5), 2006 (do not confuse it with AF6) and 2008.

Btw. to switch to the old blue theme is very easy. Simply use the Theme Switcher Add-on.

Enjoy!

Author Artha Parson
Partaker
#14 Posted: 21 Sep 2008 11:44 
Yes, that's the problem with my AF CD. AK's installation script does recognize it as 2005/2006 version of AF but doesn't quite like it! ;)

I'm not sure about the difference between AF5 / 6 with AmgiaForever 2005/2006 in here though!?

I'll also make sure to use the Theme Switcher Add-on.

Thanks again and you enjoy too!

Regards,
AP / SP

Author AmiKit
Admin
#15 Posted: 21 Sep 2008 11:54 Edited by: AmiKit 
Amiga Forever v5 is older version and thus it's different from newer Amiga Forever 2005. The same with AF6 versus AF2006. The numbers might be similar but they are different versions.

Here's the chronology:

Amiga Forever 1
Amiga Forever 2
Amiga Forever 3
Amiga Forever 4
Amiga Forever 5
Amiga Forever 6
Amiga Forever 2005 (AmiKit supports this version)
Amiga Forever 2006 (AmiKit supports this version)
Amiga Forever 2008 (AmiKit supports this version)

Page  Page 1 of 2:  1  2  Next » 
Specific questions AmiKit Support Forum / Specific questions /
 AK 1.5.0 fails to start on my system!

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑