AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 3
Members - 0
Most users ever online: 605 [18 Apr 2019 18:52]
Guests - 605 / Members - 0
Specific questions AmiKit Support Forum / Specific questions /  
 

Problem with AmiKit (screenmode)

 
Author foody
Partaker
#1 Posted: 5 Aug 2007 18:37 
I keep getting error on AmiKit, horrible video graphics, crashing WinUAE and i get this error every time I run AmiKit:

----------

The installed LIBS:Picasso96/rtg.library (40.3993) should be updated.
A newer version is included in the "Amiga Programs" directory
of the WinUAE distribution archive.

Newer library version fixes graphics problems and increases performance.

----------

I have graphics problems, etc and AmiKit refuses to boot. Please can someone help me? Thanks in advance.

Author AmiKit
Admin
#2 Posted: 5 Aug 2007 18:53 Edited by: AmiKit 
Hi Foody,

it seems you have installed new WinUAE 1.4.3. This version requires new rtg.library which is included in the WinUAE archive. Copy the library from the WinUAE1430.zip archive to AmiKit/Libs/Picasso96 drawer.

With regards to the rest of your problem (horrible video graphics), it seems you are experiencing thr good old screen mode troubles. This happens if you update WinUAE. To fix it easily, even though the AmiKit starts in horrible graphics, try to start AmiKit:Prefs/ScreenMode program, select your desired mode, save and restart.

This screen mode thingy will be fixed in AmiKit 1.4.0

Author foody
Partaker
#3 Posted: 5 Aug 2007 22:46 
It is not working AmiKit, first the configuration of AmitKit doesn't exist so I am force it to load the configuration manually from the hard drive or otherwise I get the insert floppy disk screen. OK, now that I have done the configuration loading manually, I start with a window that says "Safe" on the header and I have to close the window before AmiKit start or otherwise it will stay this like forever. The second I close the window and the second it starts loading I am flooded with errors over errors no matter what I do. HELP?

Author AmiKit
Admin
#4 Posted: 6 Aug 2007 14:42 
How come the configuration file doesn't exist? What is your HW&SW config? Where did you install AmiKit? Was the installation successful? Is kick.rom located in your AmiKit\ROMs\ folder?

Author AmiKit
Admin
#5 Posted: 19 Aug 2007 13:14 
The problem was that AmiKit checks for newer version of WinUAE on your system, and if found, this newer version is used instead of the internal one. So for example if you have installed new WinUAE 1.4.3 (using its installer) into C:\Program Files\WinUAE, the AmiKit checks this location and uses this executable instead of the one located in C:\Program Files\AmiKit\WinUAE\ folder.

Unfortunatelly, the WinUAE 1.4.3 has a bug in path system it could not found the AmiKit location (ROM and HDD) even though it was specified. This resulted into the violet kickstart screen as you described.

It seems this issue is fixed in the latest beta version of WinUAE. Please download it (WinUAE 1.4.4 beta 1) and copy the executable into your installed WinUAE location, eg. C:\Program Files\WinUAE\

Author arnljot
Partaker
#6 Posted: 19 Aug 2007 15:41 
I'd also like to point out that it's really tough to set the screen size to anything but the hardcoded 4:3 screen sizes in amikit.

Issues I have now:
* Screen opens twice. 1st with boingglobe, then 2nd with opus. Both times with my hacked 1280x720 resolution
* right hand icons doesnt align correctly, and snahpshotting doesnt help
* Clock commodity rarely shows (1 of 20 boots perhaps)
* Some boots get stuck with "intuition: close all windows" because the screen is closed and reopened before dopus loads.

Author AmiKit
Admin
#7 Posted: 19 Aug 2007 16:32 Edited by: AmiKit 
* Screen opens twice. 1st with boingglobe, then 2nd with opus. Both times with my hacked 1280x720 resolution
See my post here.

* right hand icons doesnt align correctly, and snahpshotting doesnt help
Select all the desktop icons, press the right mouse to enter the pull down menu, select

* Clock commodity rarely shows (1 of 20 boots perhaps)
Try to start it manually: doubleclick AmiKit:WBStartup/LimpidClock.ttengine. When it shows up, move it to your desired position, press the right mouse button over it and select Project -> Save settings. This way you get it snapshoted.

* Some boots get stuck with "intuition: close all windows" because the screen is closed and reopened before dopus loads.
Disable the boot picture as mentioned in the previous link.

Specific questions AmiKit Support Forum / Specific questions /
 Problem with AmiKit (screenmode)

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑