Your high-end Amiga!AmiKit turns your PC into high-end Classic Amiga environment! 
Welcome to AmiKit Support Forum!

(Click here for main AmiKit website)
none
 
  Forums Search Register Reply Statistics FAQ  DONATE 
I have a specific problem with AmiKit AmiKit Support Forum / I have a specific problem with AmiKit /

System Lock-ups with GLMatrix screen saver

Author TrevorDick
Registered
#1 Posted: 24 Dec 2005 17:33 
I've just upgraded to v1.03 (thank you again) and have noticed problems with the glmatrix screen blanker since the installation of v1.02 (and BoingBags).

When the glmatrix screen saver activates (after a period of inactivity in AmiKit/WinUAE) a blank grey screen is displayed and WinUAE effectively locks up. Pressing any key has no effect. The only way to retrieve the situation is to perform a ctrl-alt-del and "END" the WinUAE task. I've tried different encoding and screen sizes in GLMatrix without success. This screen saver features worked OK in the original release of AmiKit. Any ideas?

Thanks,

TrevorDick

Author AmiKit
Admin
#2 Posted: 24 Dec 2005 21:19 Edited by: AmiKit 
Hi TrevorDick!

hmmm... none of the AmiKit update packages touches the GLMatrix. Moreover it works here without any problems (AmiKit 1.03 + both OS3.9 BoingBags). So it seems you must have installed something that is in conflict with GLMatrix or Warp3D itself (or QuarkTex that makes the Warp3D available for WinUAE).

Anyway, try this to see if it's the fault of GLMatrix only or whole Warp3D.
Open a shell and type:

stack 100000
cd AmiKit:Locale/Help/English/Warp3D/W3DDemo/
execute gears_68k

Screen switching may take some time, so please be patient.

If this Warp3D demo doesn't work, that would mean something is wrong with your Warp3D or QuarkTex.
Check Warp3D.library in LIBS:, it should have 42.196 bytes.
Check QuarkTex.alib (102.400 bytes), it should be located at AmiKit\WinUAE\alib\QuarkTex.alib

Author TrevorDick
Registered
#3 Posted: 25 Dec 2005 17:06 Edited by: TrevorDick 
Thanks for your quick reply. I tried the gears_68K utility as reccommended but all I got was a grey screen with some control and axis data but no graphics displayed. I checked the installation of the lib files and copied new files over the existing lib files. I have AmiKit currently installed on 4 PC's (2 desktop and two laptop/notebook). The install of AmiKIt on each PC was downloaded separately from the AmiKit website and updated as necessary. All of the installed versions of AmiKit now have problems running GLMatrix after installation of boingbags and v1.02. (Now v1.03) GLMatrix worked fine on the original installation.

TrevorDick

Author AmiKit
Admin
#4 Posted: 25 Dec 2005 17:51 
ok, it seems whole Warp3D is corrupted...
If I understand it correctly, the problem appeared after the installation of v1.02 update, right?

Let's make an elimination method again, please uninstall AmiKit completely and manualy delete rest of the files that remained in the AmiKit drawer and make a new installation of AmiKit 1.0. Test GLMatrix or gears_68k. If it works, install v1.02 update package and test it again. If it still works, install 1.03 update. Then, if the Warp3D still works, install first BoingBag, reset and test Warp3D again. Then install second BB and make a test again.

Please let me know the results. Like I said everything is OK here :-O

Author Anonymous
Guest
#5 Posted: 25 Dec 2005 19:24 
OK I will give it another try when I return home to London. I'm currently in NE England for Xmas and unfortnately my original copy of OS3.9 CD is in London

Merry Xmas & Happy New Year

TrevorDick

Author TrevorDick
Registered
#6 Posted: 25 Dec 2005 19:25 
Sorry Anonymous should read as TrevorDick (forgot to sign in!)

TrevorDick

Author AmiKit
Admin
#7 Posted: 26 Dec 2005 17:10 Edited by: AmiKit 
Something came into my mind... if this happens on all of your 4 computers, don't you remember that you've updated the graphic drivers of your PC or something similar at PC side? You know, Warp3D must cooperate with the Windows gfx-card (through QuarkTex) so the problems do not need to be related to AmiKit itself...

Author TrevorDick
Registered
#8 Posted: 26 Dec 2005 23:02 
I haven't upgraded or changed the graphics cards drivers in any of the PC's I installed AmiKit.

FYI the 4 PC's are:-

JVC Mini Note PC - MP-XV841 - XP Pro
Sony VAIO laptop - XP Home
Sony PCV V1/G Desktop - XP Home
Sony PCV V2/S Desktop - XP Pro

Author AmiKit
Admin
#9 Posted: 3 Jan 2006 14:02 
Any results with the elimination method I've described above?

I have a specific problem with AmiKit AmiKit Support Forum / I have a specific problem with AmiKit / System Lock-ups with GLMatrix screen saver Top
Your Reply Click this icon to move up to the quoted message
 

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.
 
Online now: Guests - 1
Members - 0
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0