AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 2
Members - 0
Most users ever online: 605 [18 Apr 2019 18:52]
Guests - 605 / Members - 0
Specific questions AmiKit Support Forum / Specific questions /  
 

WinUAE and ghost networks

 
Author AmyZamp
Partaker
#1 Posted: 29 Jan 2007 16:24 Edited by: AmyZamp 
Hi Jan, another strange question for you...

I have installed the Amikit distribution in a SFS Hardfile and I updated it up to 1.2.9. Everything works great.
My notebook is connected via 802.11b to an ASDL Router / Wireless Access Point, the operating system I have installed is Windows XP SP1. I use WinUAE 1.3.0 (last release).

Sometimes when I connect the notebook to Internet, WinUAE seems doesn't recognize the connection. If I open IBrowse, AWeb or the Liveupdate, all says me there is no connection. Other times, all works. My router connects itself to the Internet, all the computers in the LAN have a private IP, no one knows the public IP that the router uses.

I don't think is an Amikit problem, more probably is a WinUAE bug, have you never heard nothing about this?

Thank you!
Amizamp

Author AmiKit
Admin
#2 Posted: 29 Jan 2007 16:56 
Hello AmyZamp,

yes, the net connection is completely provided by WinUAE. There's no TCP/IP protocol installed in AmiKit.

When Amiga side reports there's no connection and you immediately switch to Windows, are you able to connect there?

I am using WinUAE 1.3.2 and I haven't experienced such a problem. However I don't use wi-fi with WinUAE very often.

Anyway, the latest version of WinUAE is 1.3.4. You might want to try it because the history log says: "Improved bsdsocket emulation stability" - that's the feature that provides the connectivity for the Amiga side.

Just read the following thread before installing WinUAE 1.3.4. It contains a path bug, which might prevent AmiKit from running.

Author klesterjr
Moderator
#3 Posted: 1 Feb 2007 14:00 
I use WinUAE every day with wireless and have never experienced that problem.

Could be a WinUAE issue I suppose, but it really sounds like a networking problem with Windows XP.

Author AmyZamp
Partaker
#4 Posted: 9 Feb 2007 13:50 
Hmm..

But.. if there is no TCP/IP stack installed in AmigaOS, who provides the network connection to AmigaOS and how can do it? WinUAE? How?

Is there some tools to see the IP, netmask, and the network configuration in general?

Thank you

Author AmiKit
Admin
#5 Posted: 9 Feb 2007 15:36 Edited by: AmiKit 
There's a "bsdsocket.library emulation" option in WinUAE/Misc configuration section. It's turned on in default AmiKit setup.

The following text is taken from WinUAE Help File located at http://winuaehelp.back2roots.org/

BSD socket library emulation allows your Amiga to use your PC's network connection, whether it be through Dial-Up Networking (DUN), or Ethernet connectivity. In other words, if your PC is connected to your Internet Service Provider (ISP) through a modem, or connected to a LAN through an Ethernet connection, your Amiga will be able to make use of that connection.


And I would add it is the same for wi-fi connection. Generally, if your PC is connected to internet, your emulated Amiga is connected as well. I am not familiar with the method how Amiga internet programs work, but I assume they always call the bsdsocket.library. And these calls are probably intercepted by WinUAE and passed to PC side.

Author Methanoid
Partaker
#6 Posted: 6 Aug 2007 09:48 
Amikit, (btw nice Avatar pic!!), this may be the reason why I install Amikit on my WinUAE system. I want to use a telnet.device and re-install my old Amiga BBS under WinUAE. Do I merely need to install said telnet-serial thingy and set my BBS software to use that instead of serial.device and Amikit passes the connection thru to my PC's TCP/IP stack?

Hope that makes some sense.. it has been a while since I ran the BBS (errr 14 years actually) but I do have a full backup on CD-R

Author AmiKit
Admin
#7 Posted: 6 Aug 2007 14:38 
Hi Methanoid!

I am afraid I cannot help you on this issue as I am not familiar with telnet.device or BBS. I tried to enter "telnet winuae" string into google and guess what? I found you again

Anyway, you can always try it with AmiKit, you have nothing to loose. Tell us the result then.

Specific questions AmiKit Support Forum / Specific questions /
 WinUAE and ghost networks

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑