AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 2
Members - 0
Most users ever online: 605 [18 Apr 2019 18:52]
Guests - 605 / Members - 0
Specific questions AmiKit Support Forum / Specific questions /  
 

AmiKit and dual hardware configs

 
Author UncleSpam
Partaker
#1 Posted: 17 Dec 2006 01:12 
I'm running AmiKit/WinUAE on a Dell Precision M60 laptop.

I also use a port replicator/docking station to dock my laptop to a 23" LCD when at my desk. Both the laptop resolution and the external monitor resolution is 1920x1200.

The problem is that if I set up the Amiga display (via Preferences) to the proper 1920x1200 resolution, when I go back to the other display, the Amiga resolution settings drops down to such a low resolution that I have to drop down to the ECS chipset emulation just to be able to use the Workbench and get to the Preferences/Screenmode settings and switch back to the proper resolution.

This only happens when I change from laptop to docked laptop and vice versa.

Nothing serious, but I'm just curious what causes this...

Regards,
Bogdan

Author Toni Wilen
Moderator
#2 Posted: 19 Dec 2006 08:54 
Only some common Picasso96 4:3 resolutions have unique ModeID. (640x480,800x600,1024x768,1280x1024,1600x1200), others get "random" ModeID that can and will map to different resolution in other PCs (or even between different display card driver versions)

(Amiga uses ModeIDs internally, 32-bit values, not resolutions directly.)

This will be improved in next WinUAE release. (yay, first post here..)

Author AmiKit
Admin
#3 Posted: 19 Dec 2006 12:39 Edited by: AmiKit 
Hi Toni and welcome to the AmiKit support forum!

" style="width:150px

Nice to see you here!

Author UncleSpam
Partaker
#4 Posted: 19 Dec 2006 23:02 
Thanks for the input everyone!

I was guessing that there must be some ModeID being reported to WinUAE by Windows, since the only difference is the Monitor setting when docked vs. undocked.

The aspect ratio for the resolution that I use is 16:10 rather than 4:3 since I'm running the wide aspect ratio monitors.

Regards,
Bogdan

Specific questions AmiKit Support Forum / Specific questions /
 AmiKit and dual hardware configs

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑