AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 2
Members - 0
Most users ever online: 605 [18 Apr 2019 18:52]
Guests - 605 / Members - 0
Specific questions AmiKit Support Forum / Specific questions /  
 

Amikit 1.20 hangs during startup or shortly there after.

 
Author Rabel1
Partaker
#1 Posted: 1 Nov 2006 03:16 
Greetings All!

I installed Amikit 1.20 to my new system using the OS 3.9 cd.
Installation completes fine. When I launch Amikit it rarely ever boots up properly. Sometimes it hangs on the windowed GUI. Sometimes it hangs after the full screen opens up. Usually it hangs while the top right status bar is showing the loading progress. I usually get past the Opus registration screen (clicking on "run").

It has booted up fully a few times and I've managed to get the 1.21 and 1.22 updates downloaded along with Boing Bags #1 and #2 and the other patches.

Every time it hangs I still have access to the F12 setup menu from where I can shut it down or reset the emulator.

I'm running at 1280 x 1024 on a new nVidia 7950GT card with the current nVidia driver. Motherboard is an ASUS P5W DH Deluxe with an Intel core dual E6600 cpu and 1GB of DDR2-6400 RAM. OS is XP Home with SP2 and all critical patches. I've tried lots of other resolutions from 640 x 480 up to 1280 x 1024.

I don't have any problems with any other applications.

I tried using the safe mode startup config and also preventing the WBStartup files from loading but it doesn't make any difference. I've tried running the emulator in Windowed mode only but it still hangs.
I'm using the default "Amikit" configuration.

I'm running out of things to try.

Any ideas?

Thanks,
Rabel1

Author AmiKit
Admin
#2 Posted: 1 Nov 2006 07:21 Edited by: AmiKit 
Thanks to your detailed report we can exclude it's AmiKit issue. I mean if the emulation hangs even with safe mode startup (which doesn't contain any patches) and sometimes even on the windowed GUI, the problem will be most likely in your HW.

Similar problems (with the same CPU and motherboard!) were already reported here.

Possible solution is to disable "JIT" but the emulation will be VERY slow.

Or leave the JIT enabled and try different positions of "CPU Idle" slider. When it's at the left side (default position), all of the CPU power goes to emulation. Therefore try to lower the CPU usage to change the timing inside the emulation, maybe it helps.

Make these changes even before the emulation starts. Run AmiKit GUI, press the "Configure WinUAE" button, change the "JIT" or "CPU Idle" settings and start the emulation.

Author Rabel1
Partaker
#3 Posted: 2 Nov 2006 05:19 
Thanks for your reply.
I tried disabling the JIT and the emulator does seem to be stable but very slow. I've been trying all the different parameters for JIT along with adjusting the cache size to see if I can find a stable configuration. I'll reply here if I have any luck.

Rabel1

Specific questions AmiKit Support Forum / Specific questions /
 Amikit 1.20 hangs during startup or shortly there after.

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑