Your high-end Amiga!AmiKit turns your PC into high-end Classic Amiga environment! 
Welcome to AmiKit Support Forum!

(Click here for main AmiKit website)
none
 
  Forums Search Register Reply Statistics FAQ  DONATE 
I have a specific problem with AmiKit AmiKit Support Forum / I have a specific problem with AmiKit /

Amikit X & WHDLoad

Author GeekPeter
Registered
#1 Posted: 29 Jul 2017 02:56 
Does anyone have any solutions here for WHDLoad, the stuff bundled with AMiKit X works but ALL of my own whdload stuff crashes instantly.

Author AmiKit
Admin
#2 Posted: 29 Jul 2017 02:59 
Try to download new WHDLoad slaves from www.whdload.de and/or play with WHDLoad config (I remember some NoCache and other switches that might help).

Alternatively you can try MorpheuZ > Retro Switch and run your games there.

Author GeekPeter
Registered
#3 Posted: 29 Jul 2017 04:19 
i already had the nocache/etc options setup with required games when i used an 040 emulation previously on 1 of my own older setups, i downloaded the up to date files for whdload including the main program yesterday but everything still crashes instantly, not a single one works except for the ones provided with amikit, its very confusing

Author AmiKit
Admin
#4 Posted: 29 Jul 2017 10:53 
Which games did you try? Do they work in Retro Switch? If so, there might be some patch responsible which can be disabled in MorpheuZ > Startup

Author GeekPeter
Registered
#5 Posted: 30 Jul 2017 01:13 
I tried every single game i own, some of which did have old .slaves which i updated, i even tried the whole thing in FS-UAE incase it was WinUae related but got the same results. Retro Switch just results in instant Software Failure on everything.

Author GeekPeter
Registered
#6 Posted: 30 Jul 2017 01:39 
EDIT: I tried using an older version of WHDLoad from 2012 instead of the usual advice of using the latest ones (which i had done near instantly) i had on an old install and that runs both my stuff and the amikit stuff so it looks like the newer version(s) of whdload are my issue.

To fault find I tried originally to move my kickstart images away incase they were the reason, on the newer whdload this resulted in an instant crash, on the older version(s) i am given the warning message about missing kickstart images, also the newer version(s) of whdload would crash even from boot without startup when just doing the basics, assigning T: setting stack above 30k and launching the slave manually, this would always result in an instant crash but perfectly fine on older ones.

Author AmiKit
Admin
#7 Posted: 30 Jul 2017 08:27 Edited by: AmiKit 
Interesting. Thanks Peter! I will forward your feedback to WHDLoad author. Could you please specify which version works for you? And which game (and Slave version) works with the old one while it does not with the new one? This is important for replicating the issue and debugging.

Thanks!
Jan

Author Wepl
Registered
#8 Posted: 8 Aug 2017 23:05 
Is it possible that you have a cracked keyfile on the disk? It's the only idea I have why an older WHDLoad version should work and newer ones not.
Search for a file called whdload.key ...

I have a specific problem with AmiKit AmiKit Support Forum / I have a specific problem with AmiKit / Amikit X & WHDLoad Top
Your Reply Click this icon to move up to the quoted message
 

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.
 
Online now: Guests - 1
Members - 0
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0