AmiKit - Your Modern Retro Experience
  Forums Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0
Specific questions AmiKit Support Forum / Specific questions /  
 

Amikit X & WHDLoad

 
 
Page  Page 1 of 2:  1  2  Next »

Author GeekPeter
Partaker
#1 Posted: 29 Jul 2017 02:56 
Does anyone have any solutions here for WHDLoad, the stuff bundled with AMiKit X works but ALL of my own whdload stuff crashes instantly.

Author AmiKit
Admin
#2 Posted: 29 Jul 2017 02:59 
Try to download new WHDLoad slaves from www.whdload.de and/or play with WHDLoad config (I remember some NoCache and other switches that might help).

Alternatively you can try MorpheuZ > Retro Switch and run your games there.

Author GeekPeter
Partaker
#3 Posted: 29 Jul 2017 04:19 
i already had the nocache/etc options setup with required games when i used an 040 emulation previously on 1 of my own older setups, i downloaded the up to date files for whdload including the main program yesterday but everything still crashes instantly, not a single one works except for the ones provided with amikit, its very confusing

Author AmiKit
Admin
#4 Posted: 29 Jul 2017 10:53 
Which games did you try? Do they work in Retro Switch? If so, there might be some patch responsible which can be disabled in MorpheuZ > Startup

Author GeekPeter
Partaker
#5 Posted: 30 Jul 2017 01:13 
I tried every single game i own, some of which did have old .slaves which i updated, i even tried the whole thing in FS-UAE incase it was WinUae related but got the same results. Retro Switch just results in instant Software Failure on everything.

Author GeekPeter
Partaker
#6 Posted: 30 Jul 2017 01:39 
EDIT: I tried using an older version of WHDLoad from 2012 instead of the usual advice of using the latest ones (which i had done near instantly) i had on an old install and that runs both my stuff and the amikit stuff so it looks like the newer version(s) of whdload are my issue.

To fault find I tried originally to move my kickstart images away incase they were the reason, on the newer whdload this resulted in an instant crash, on the older version(s) i am given the warning message about missing kickstart images, also the newer version(s) of whdload would crash even from boot without startup when just doing the basics, assigning T: setting stack above 30k and launching the slave manually, this would always result in an instant crash but perfectly fine on older ones.

Author AmiKit
Admin
#7 Posted: 30 Jul 2017 08:27 Edited by: AmiKit 
Interesting. Thanks Peter! I will forward your feedback to WHDLoad author. Could you please specify which version works for you? And which game (and Slave version) works with the old one while it does not with the new one? This is important for replicating the issue and debugging.

Thanks!
Jan

Author Wepl
Partaker
#8 Posted: 8 Aug 2017 23:05 
Is it possible that you have a cracked keyfile on the disk? It's the only idea I have why an older WHDLoad version should work and newer ones not.
Search for a file called whdload.key ...

Author GeekPeter
Partaker
#9 Posted: 10 Sep 2017 11:51 Edited by: GeekPeter 
nope i didnt overwrite the basic AmiKit X files apart from the bog standard WHDLoad executable after i had issues, i left everything else the same. Every time i use an older whdload all is well, when amikit does an autoupdate and updates whdload, all installs crash on launch.

I still have my original proper keyfile and also tried the dodgey version when you mentioned a potential clash, no difference occurs, still crashes when using an up to date WHDload, my old executable works perfectly.

My working version of WHDLoad is 17.1, its pretty old from my ancient eyetech 040/603e system but still seems to work, i havent tried a more up to date version yet apart from what the amikit updater provided.

Author AmiKit
Admin
#10 Posted: 10 Sep 2017 11:53 
Can you send us the WHDLoad installer as well as the game itself so we can replicate the problem? amikit@gmail.com
Thanks.

Author GeekPeter
Partaker
#11 Posted: 10 Sep 2017 12:00 Edited by: GeekPeter 
well, there is no 1 particular game that has issues ive got 287 games that all crash on the newer whdload.

http://oi66.tinypic.com/2jba6c5.jpg

pic shows my 2 version(s) of whdload, whdload is the older one that works for me, whdload-original is the one amikit came with or updated too, i have an even older version, my whdload.old is erm, version 7, that deffo doesnt work with the majority of my slave files now, only a handful work.

Author GeekPeter
Partaker
#12 Posted: 10 Sep 2017 12:34 
also to note, from a fresh amikit x install, the whdload games already bundled with amikit such as deluxe galage etc, all work flawlessly, right up until the updater kicks in, once whdload updates even the amikit bundled games crash.

Author AmiKit
Admin
#13 Posted: 10 Sep 2017 13:27 Edited by: AmiKit 
Interesting. I've just launched Deluxe Galaga and Deluxe Pacman on AmiKit X 10.3.0 with no problem.

Which game crashes exactly? Does it crash even if launched outside of iGame?

What ROMs do you use? If from Amiga Forever, please check you copied the correct ROMs according to this article (including rom.key file).

Author GeekPeter
Partaker
#14 Posted: 10 Sep 2017 14:42 
yeah its weird, the roms work fine on the old whdload so i assume there should be no difference on the newer one, in fact absolutely everything works fine from the standard amikit 10.0.0.0 i originally used, it all just went pear shaped after the first amikit live update i did, after that i aquired a new version of whdload and thats when literally all my whdload titles just bomb including the ones that came with amikit, so at present ive just changed the startup to copy the version thats working for me over the top of any new ones im getting via the update.

the crashes happen on every single title i have IF i launch via igame or via newshell only under the new whdload, once i slap back on my older whdload everything works perfectly, i also tried making a snoopdos log as well but couldnt see anything wrong before it hangs.

my roms are from amiga forever, the very first version in fact and i have only 2 roms copied in there, the a500 and a1200 ones, all named correctly, i did have a few obscure titles that asked for other roms but i removed all but the basic 2 for now just to make things less complicated.

its certainly puzzling but not a major issue for me atm, my older out of date whdload IS running everything, it was just the live updates breaking it by giving me the up to date whdload that doesnt like me for some reason.

Author GeekPeter
Partaker
#15 Posted: 10 Sep 2017 15:06 
okey, heres a quick bandicam video showing me deleting whdload, and replacing it with the version17 that works for me, i launch 1 random game (all of them work with V17 btw), i see the game launch np, i then quit the game, delete the old whdload and copy in the new one that amikit live update provides, V18beta, and launch the same game with an instant crash, all games do the same under V18.

https://youtu.be/ukiORKl6vHI

Page  Page 1 of 2:  1  2  Next » 
Specific questions AmiKit Support Forum / Specific questions /
 Amikit X & WHDLoad

Your Reply Click this icon to move up to the quoted message

 

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 
 
 
AmiKit Support Forum Powered by Forum Script miniBB ®
↑ Top