Your high-end Amiga!AmiKit turns your PC into high-end Classic Amiga environment! 
Welcome to AmiKit Support Forum!

(Click here for main AmiKit website)
none
 
  Forums Search Register Reply Statistics FAQ  DONATE 
I have a specific problem with AmiKit AmiKit Support Forum / I have a specific problem with AmiKit /

Problem with Sound

Author TrevorDick
Registered
#1 Posted: 1 Dec 2005 01:41 Edited by: TrevorDick 
I seem to have a problem playing cd's with AmiKit set up.

I can play a test sound through AHI Prefs configure and wav files with AMPlifyer or AmigaAmp, but I can't seem to play CD's using CDDA or PlayCD. I get a software failure window every time I select PlayCD. This happens on both my desktop and laptop installations both runing AmiKit with Windows XP.
I have set the correct tooltypes in the PlayCD NewIcon Tool.
Any ideas why this might be occuring?

TrevorDick

Author TrevorDick
Registered
#2 Posted: 1 Dec 2005 12:31 
Sound Problem update - I reinstalled AmiKit from scratch and found that PlayCD worked fine. However after installing the Boing Bag 3.9.1 and 3.9.2 updates double clicking on PlayCD crashes AmiKit/WinUAE and causes a guru meditation?

Is this a bug with AmiKit setup - the boing bag updates or something else. This happens on both the laptop and the desktop PC's.

TrevortDick

Author AmiKit
Admin
#3 Posted: 2 Dec 2005 09:57 
hmm... if default os3.9 PlayCD works fine, then the BoingBag version of this PlayCD must be bugged somehow... I'll investigate this.

Try to backup your default os3.9 PlayCD before you update to BoingBags and after then overwrite new PlayCD with your old one (together with .info file). Does it work?

Author TrevorDick
Registered
#4 Posted: 4 Dec 2005 18:57 
OK,

I had time to check my complete installation and I was able to re-install AmiKit correcting with all files using OS3.9 CDOM. I then installed the Boing Ball updates and copied back the original PlayCD files from the CDROM. CDDA & PlayCD do not crash but no sound is played when I put a music CD in the CD drive. I can use AmigaAmp & Song player to play .wav files and Song Player to play CD's? I seem to have AHi correctly set up as all sound/audio programs work OK apart from PlayCD? Any ideas?

TrevorDick

Author AmiKit
Admin
#5 Posted: 4 Dec 2005 20:47 Edited by: AmiKit 
I tried PlayCD yesterday with the same result, it worked but no sound is played. However I did not test it on my home "AmiKit" machine... But, you can play the CD with SongPlayer. It should load the content of audio CD if you press the CD button (second from the right side) of the SongPlayer GUI.
Or you can enable CDDA dosdriver by using taskbar -> Tools -> System -> DosDrivers -> CDDA. Then an Audio-CD icon appears on your desktop, open it, switch to Name mode, select all tracks and press the amplifier button from the window-toolbar. Selected tracks will be loaded into SongPlayer then.

For permanent use of CDDA dosdriver, simply move it from AmiKit:Storage/DosDrivers to AmiKit:Devs/Dosdrivers.

Author TrevorDick
Registered
#6 Posted: 6 Dec 2005 00:26 Edited by: TrevorDick 
Thanks for the confirmation. It seems to be a problem with PlayCD then? I just wanted to make sure that my AmiKit set-up was OK. I will use SongPlayer or the CDDA dosdriver as you suggest.

Thanks for your help.

TrevorDick

I have a specific problem with AmiKit AmiKit Support Forum / I have a specific problem with AmiKit / Problem with Sound Top
Your Reply Click this icon to move up to the quoted message
 

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.
 
Online now: Guests - 1
Members - 0
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0