Your high-end Amiga!AmiKit turns your PC into high-end Classic Amiga environment! 
Welcome to AmiKit Support Forum!

(Click here for main AmiKit website)
none
 
  Forums Search Register Reply Statistics FAQ  DONATE 
I have a specific problem with AmiKit AmiKit Support Forum / I have a specific problem with AmiKit /

Frequent crashes after live update to amikit 8.5

Author luke_70it
Registered
#1 Posted: 14 Jul 2015 14:13 Edited by: luke_70it 
Hello,
today I upgraded amikit to 8.5 version.
I'm experiencing frequent crashes, with this error:

Task: 0x0921C9A0 AmiStart
Errore: 0x81000005 "DEADEND" da: ExecLibrary
causa: Corrupt memory list detected in FreeMem
etc.

Before upgrading I never had this problem.

Am i doing something wrong?

Thank you in advance
Luca

Author AmiKit
Admin
#2 Posted: 14 Jul 2015 17:21 
Hi Luca,

I am sorry for the inconvenience. What system you use? Windows/Linux/Mac... And what desktop? DOpus/Scalos/Workbench.

AmiStart was not touched by the update. However, AmiStart uses MUI4 which was updated. Have you made some changes to AmiStart configuration? This is very easy as AmiStart is set to auto-save any changes.

What you can do is to go to AmiKit:Utilities/EXPANSION/AmiStart/ folfer. Back up file named sm.prefs (AmiStart config file) and then rename sm.prefs_bak to sm.prefs and reboot. This way you restore your AmiStart config to default version.

Author luke_70it
Registered
#3 Posted: 15 Jul 2015 17:46 
Thank you for your reply! I use Amikit on Windows 7 x64. I upgraded winuae to 3.1.0 (but I had this version even on 8.4, and all was working flawless).
I use Dopus.
I will try to restore sm.prefs, as you told me, and I'll let
you now if it solve.

Best regards
Luca

Author Overflow
Registered
#4 Posted: 23 Aug 2015 02:07 
Hah, I just had the same issue. Im under Windows 10.

Author AmiKit
Admin
#5 Posted: 23 Aug 2015 10:46 
Hi Overflow. I am sorry to hear that.

Looking at the change log of AmiKit 8.5, there is no reason for crashes as nothing system related was touched (except icon.library which is active only if Workbench is used instead of DOpus Magellan - see my previous post).

Could you be more specific, please? When the crashes occur exactly? Do you remember installing anything new meanwhile?

Thanks,
Jan

Author Overflow
Registered
#6 Posted: 28 Aug 2015 04:36 
Hey there!

I just reinstalled Amikit and have had no issues with it since.

Not sure what was the issue. It just would hang when loading Amikit, not completing the load.
But as I said, have had no issues since the reinstall. Got it now installed both on my win 7 and 10 PCs.

Works like a charm!

I have a specific problem with AmiKit AmiKit Support Forum / I have a specific problem with AmiKit / Frequent crashes after live update to amikit 8.5 Top
Your Reply Click this icon to move up to the quoted message
 

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.
 
Online now: Guests - 1
Members - 0
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0