AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 191 [17 Oct 2019 17:54]
Guests - 191 / Members - 0
Specific questions AmiKit Support Forum / Specific questions /  
 

Compression user menu options not working

 
Author andyhants
Partaker
#1 Posted: 24 Mar 2014 23:47 
Hi

I can't get the Zip - Extract Files option to work from the Compression menu in the top desktop menu bar. When I highlight a Zip file in a Lister The Zip - List Files and Zip - Check Files options work ok showing output in a Shell Window but when I highlight the same Zip file in a Lister & select the Zip - Extract Files option I just get a Click Close Window message in the Shell Window and no files extracted.

I am running the latest AmiKit 1.6.7 running WINUAE 2.7.1 beta 10.

Interestingly when I try the same thing with the same Zip file in the default AmiKit system generated by Cloanto Amiga Forever I get exactly the same result. It's as though the Zip Extract Files option has never worked under AmiKit.

I've spent the best part of 6 months getting to grips with creating a stable environment under AmiKit but really need to be able to crack this problem so would really appreciate your help.

Many thanks

Author AmiKit
Admin
#2 Posted: 25 Mar 2014 15:00 
Hi,

it seems it really doesn't work from the Compression menu. I will investigate this. Thanks for the report.

Meanwhile you can use alternative methods:

1) right mouse click the file and select "Extract to RAM" or "Extract here".
2) or drag the file from the lister (in name mode) and drop it to another lister (also in name mode). The archive gets unpacked there.

Author andyhants
Partaker
#3 Posted: 25 Mar 2014 20:39 
Ok thanks. Just to confirm with the drag to another Lister option do I then have to invoke the Zip - Extract option again or are you saying the zip file will automagically get unzipped by dragging to another Lister?

Can I also please raise another Compression-related issue? I'm also unable to Extract GZ files. When I select a GZ file again in a Lister and try TGZ - Extract I get a report in the Shell Window but its all in a weird font like Cyrillic or something and there is no decompressed file in the Destination Drawer.

Sorry to add more woes - overall I really like AmiKit and if I can get these two issues sorted I'm most of the way to the environment I'm looking for.

Thanks again for your help

Author AmiKit
Admin
#4 Posted: 25 Mar 2014 22:08 Edited by: AmiKit 
Hi, no problem, thanks for the report, again. Seems I need to remove some dust from AmiKit's compression menu as it is LONG time since it was updated.

Yes, it's enough to drag&drop the archive and it gets unzipped in the destination folder automatically.

I tried to compress some files using TGZ-Create and then decompressing the archive using TGZ-Extract and it worked for me. Maybe the Amiga program is not compatible with some special GZ files created with different compressor. Anyway, you can try the drag&drop feature too.

Did you know you can also double-click the archive to show its content? Then you can select the files and drag&drop them somewhere to get them unpacked.

Check out the tutorial videos explaining how to archive or unarchive files in AmiKit:
https://www.youtube.com/user/TheAmiKit

Author andyhants
Partaker
#5 Posted: 27 Mar 2014 21:17 
OK Thanks. Since posting the second note I have since found that XAD and XPK work with GZ archives so i have a solution now. & Didn't know about the double click thing thanks.

One other thing I seem to have noticed. If I use the latest WinUAE 2.7.1 beta it seems to prevent accessing Internet Explorer from the AmiStart - Win - Internet menu. When you select Explorer through that menu route, noting happens.

PS - Have you also noticed the Forum doesn't seem to display properly? I can only see the latest posts from the recent posts section. The individual sub-forums only show posts up to about 2009 / 2010!

Author AmiKit
Admin
#6 Posted: 1 Apr 2014 00:00 
Thank you, you're good in testing! If the only difference between working and non working Explorer launched from the AmiStart menu is the different WinUAE version, please report this issue to Toni Wilen - the author of WinUAE, please. It might happened that he has disabled the access to WinUAE\winuae_dll\winlaunch.alib file (which is required to run Windows programs from AmiKit environment) or changed the path or it's really a bug.

Regarding the forum, yes, I know it's not displayed properly. I have messed the database up and had no time to fix it.

Btw. if you're interested in betatesting new AmiKit version please drop me an email. Thanks!

Specific questions AmiKit Support Forum / Specific questions /
 Compression user menu options not working

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑