AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 191 [17 Oct 2019 17:54]
Guests - 191 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  
 

Mac OS X/AmiKit horror

 
Author amigaX
Partaker
#1 Posted: 6 Sep 2009 21:14 
I am a long time Amiga user (A4000/060,CVision,SCSI,etc), who used AmigaOS exclusivley till 2001. Then I used it via Amithlon in dual boot with WinXP, then I spent a few years without it and now I'd like to use it on my MacBook, which soon gets upgraded (see below, atm I got a white CoreDuo MacBook).

Imagine:
* Apple MacBook Pro
- Unibody aluminium
- illuminated keyboard
- approx. 7h battery run
* 4GB RAM
* Intel Core2 Duo
* 250 GB SSD (Amiga programs load faster than you double-clicked their icon ;-))
* running AmigaOS 3.9 full screen in 16:9 B-)

And then this:

Port command started with PID 47540
Fetching glib2
Attempting to fetch glib-2.20.4.tar.bz2 from http://ftp.belnet.be/mirror/ftp.gnome.org/sources/glib/2.20/
Verifying checksum(s) for glib2
Extracting glib2
Applying patches to glib2
Configuring glib2
Building glib2
Staging glib2 into destroot
Installing glib2 @2.20.4_0
Activating glib2 @2.20.4_0
Cleaning glib2
[...]
Attempting to fetch docbook-xml-4.5.zip from http://arn.se.distfiles.macports.org/docbook-xml-4.5
Verifying checksum(s) for docbook-xml-4.5
Extracting docbook-xml-4.5
Configuring docbook-xml-4.5
Building docbook-xml-4.5
Staging docbook-xml-4.5 into destroot
Installing docbook-xml-4.5 @4.5_0
Activating docbook-xml-4.5 @4.5_0
[...]
Fetching docbook-xml
Verifying checksum(s) for docbook-xml
Extracting docbook-xml
Configuring docbook-xml
Building docbook-xml
Staging docbook-xml into destroot
Installing docbook-xml @5.0_0
Activating docbook-xml @5.0_0
Cleaning docbook-xml
Fetching docbook-xsl
Attempting to fetch docbook-xsl-1.75.1.tar.bz2 from http://mesh.dl.sourceforge.net/docbook
Verifying checksum(s) for docbook-xsl
Extracting docbook-xsl
Configuring docbook-xsl
Building docbook-xsl
Staging docbook-xsl into destroot
Installing docbook-xsl @1.75.1_0
Activating docbook-xsl @1.75.1_0
[...]
Activating iso-codes @3.10.1_0
Cleaning iso-codes
Fetching libxml2
Attempting to fetch libxml2-2.7.3.tar.gz from http://ftp.belnet.be/mirror/ftp.gnome.org/sources/libxml2/2.7/
Attempting to fetch libxml2-2.7.3.tar.gz from ftp://gd.tuwien.ac.at/pub/libxml/
Verifying checksum(s) for libxml2
Extracting libxml2
Configuring libxml2
Building libxml2
Staging libxml2 into destroot
Installing libxml2 @2.7.3_0
Activating libxml2 @2.7.3_0
Cleaning libxml2
Fetching libxslt
Attempting to fetch libxslt-1.1.24.tar.gz from ftp://gd.tuwien.ac.at/pub/libxml/
Verifying checksum(s) for libxslt
Extracting libxslt
Configuring libxslt
Building libxslt
Staging libxslt into destroot
Installing libxslt @1.1.24_2
Activating libxslt @1.1.24_2
Cleaning libxslt
Fetching p5-xml-parser
Attempting to fetch XML-Parser-2.36.tar.gz from http://arn.se.distfiles.macports.org/perl5
Verifying checksum(s) for p5-xml-parser
Extracting p5-xml-parser
Configuring p5-xml-parser
Building p5-xml-parser
Staging p5-xml-parser into destroot
Installing p5-xml-parser @2.36_0
Activating p5-xml-parser @2.36_0
Cleaning p5-xml-parser
Fetching python26
Attempting to fetch Python-2.6.2.tar.bz2 from http://arn.se.distfiles.macports.org/python26
Verifying checksum(s) for python26
Extracting python26
Applying patches to python26
Configuring python26
Building python26
Staging python26 into destroot
Installing python26 @2.6.2_3
Activating python26 @2.6.2_3
To fully complete your installation and make python 2.6 the default, please run
sudo port install python_select
sudo python_select python26
Cleaning python26
Fetching py26-libxml2
Attempting to fetch libxml2-python-2.6.21.tar.gz from http://arn.se.distfiles.macports.org/python
Verifying checksum(s) for py26-libxml2
Extracting py26-libxml2
Applying patches to py26-libxml2
Configuring py26-libxml2
Building py26-libxml2
Staging py26-libxml2 into destroot
Installing py26-libxml2 @2.6.21_0
Activating py26-libxml2 @2.6.21_0
Cleaning py26-libxml2
Fetching getopt
Attempting to fetch getopt-1.1.4.tar.gz from http://arn.se.distfiles.macports.org/getopt
Verifying checksum(s) for getopt
Extracting getopt
Applying patches to getopt
Configuring getopt
Building getopt
Staging getopt into destroot
Installing getopt @1.1.4_1
Activating getopt @1.1.4_1
Cleaning getopt
Fetching gnome-common
Attempting to fetch gnome-common-2.26.0.tar.bz2 from http://ftp.belnet.be/mirror/ftp.gnome.org/sources/gnome-common/2.26/
Verifying checksum(s) for gnome-common
Extracting gnome-common
[...]
Fetching gnome-doc-utils
Attempting to fetch gnome-doc-utils-0.16.1.tar.bz2 from http://ftp.belnet.be/mirror/ftp.gnome.org/sources/gnome-doc-utils/0.16 /
Verifying checksum(s) for gnome-doc-utils
Extracting gnome-doc-utils
Configuring gnome-doc-utils
Building gnome-doc-utils
Staging gnome-doc-utils into destroot
Installing gnome-doc-utils @0.16.1_0+python26
Activating gnome-doc-utils @0.16.1_0+python26
Cleaning gnome-doc-utils
Fetching gtk-doc
Attempting to fetch gtk-doc-1.11.tar.bz2 from http://ftp.belnet.be/mirror/ftp.gnome.org/sources/gtk-doc/1.11/
Verifying checksum(s) for gtk-doc
Extracting gtk-doc
Configuring gtk-doc
Building gtk-doc
Staging gtk-doc into destroot
Installing gtk-doc @1.11_0+python26
Activating gtk-doc @1.11_0+python26
Cleaning gtk-doc
Fetching atk
Attempting to fetch atk-1.26.0.tar.bz2 from http://ftp.belnet.be/mirror/ftp.gnome.org/sources/atk/1.26/
Verifying checksum(s) for atk
Extracting atk
[...]
Fetching cairo
Attempting to fetch cairo-1.8.8.tar.gz from http://arn.se.distfiles.macports.org/cairo
Verifying checksum(s) for cairo
Extracting cairo
Configuring cairo
Building cairo
Staging cairo into destroot
Installing cairo @1.8.8_0+macosx
[...]
Fetching pango
Attempting to fetch pango-1.24.5.tar.bz2 from http://ftp.belnet.be/mirror/ftp.gnome.org/sources/pango/1.24
[...]
Fetching shared-mime-info
Attempting to fetch shared-mime-info-0.60.tar.bz2 from http://arn.se.distfiles.macports.org/shared-mime-info
Verifying checksum(s) for shared-mime-info
Extracting shared-mime-info
Configuring shared-mime-info
Building shared-mime-info
Staging shared-mime-info into destroot
Installing shared-mime-info @0.60_0
Activating shared-mime-info @0.60_0
Cleaning shared-mime-info
Fetching tiff
Attempting to fetch tiff-3.8.2.tar.gz from ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/
Verifying checksum(s) for tiff
Extracting tiff
On Mac OS X 10.5, tiff 3.8.2 requires Xcode 3.1 or later but you have Xcode 3.0.
Error: Target org.macports.extract returned: incompatible Xcode version
Error: The following dependencies failed to build: gtk2 tiff xorg-libXcomposite xorg-compositeproto xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto
Error: Status 1 encountered during processing.
Executing: /opt/local/bin/port install xdialog


So, what happened? Well, Mac OS X, being based on UNIX, offers X11, but it is not as well supported as on other Xish systems. There is the UNIX part of OS X, but that is not so easy, as one might think, since Apple does not offer support for the broad application-base, that is available in the open-source world. They install, what they think is good for you (and them) and then you use it. If you need more (bash-completion, MidnightCommander, Wget, etc.) then you use one of the three Mac OS X OpenSource package systems available out there: MacPorts, Fink or Rudix. I would gladly live without any of them, since they tend to mess up the system, or at least did so for some folks in the past, but then and when I need some additional stuff, so I use MacPorts. Today was such an event, I needed xdialogs, so I could install AmiKit. I have no Windows machine available.

What you can see above is the torture-run to install xdialogs (shortened due to posting limits).

So, please, may I kindly ask you to offer a "dialogs" (ideally) or "ncurses" based installer? Or why not make it even more simple and use what's most easily available? Simple questions where one answers (Y/n) or answers question by entering text (ie: paths). This could be even implemented quickly. Or just a script one runs from the shell, that copies the right files from the OS3.9 CD into the right paths in the AmiKit directory.

Yours, Andreas

Author AmiKit
Admin
#2 Posted: 7 Sep 2009 00:36 
The Mac version of AmiKit will be available once I get a MacBook.. which will happen very soon

Author amigaX
Partaker
#3 Posted: 7 Sep 2009 02:02 
Yummy. I am glad for you!

I just checked the script in an editor. It seems, that, when removing the graphical arguments xdialog behaves like dialog. But I am new to this, so I am not 100% on this. But you know this already better than me, I guess.

As I see, it does not copy any AmigaOS files. That would mean, that all I need to do is to setup the e-uae and Amikit stuff and boot. Then AmiKit will launch a installer on the Amiga side?!

Also I wonder, why you set uo the RAM the way it is being set up in the .uaerc file. You use slow- and fast-ram while you leave 1MB for chip only, however, for Z3 you assign 128MB, despite mentioning in the Linux guide, that anything above 32MB Z3 RAM breaks JIT. Has this changed?

Shouldn't 64MB for OS3.9 suffice by large? And 16MB of VGA RAM should suffice, at least for displays, that us mortals own?! I had no problem with my old AmigaForever stuff using only 8MB of VGA RAM in fullscreen at uaegfx/1280x800/24bit.

Also it seems, that the JIT got used with 2MB chip, 0 slow, 0 fast, 64MB Z3 RAM. I have set "direct after P96" for all three memory access variants.

Author amigaX
Partaker
#4 Posted: 8 Sep 2009 01:14 
Okay, solved. The install script is definately not needed if one sets up E-UAE manually. One needs to dearchive the AmiKit directory, set it up as first boot-device in the emulator, boot from it and follow the steps on the AmigaOS side. Installation of AmigaOS files will happen there. Wasn't that a nice system? You could even run software without the OS being installed. All these low-level things came from the ROM.

Oh, a question: I had, in my previous config, added my Mac OS X home directory as HD3: ro. For Amikit I removed it from the e-uae config and also checked the config in an editor. It is not there. However, in AmiKit I still get my user's Mac OS X home-directory as HD3: Any idea as to what that could happen?

Great design, btw. What would be neat for the future (IMHO) would be a setup, that installs the foundation for a growing, more serious system with two partitions, Workbench: and Work:. Oh, wait, why would I want this?! It was important back then, so I could more easily create backups and handle emergency cases. Today I just copy the hardfile, lol. Nostalgia reasons, maybe, hehe.

Author AmiKit
Admin
#5 Posted: 8 Sep 2009 09:15 
I am not familiar with E-UAE but there is a guide how to configure it for Linux - written by Tom Newsom. The Mac's version has to be similar.

http://amikit.amiga.sk/linux.htm

Author amigaX
Partaker
#6 Posted: 14 Sep 2009 22:57 
Thanks, as already mentioned, I solved it.

Since I already had e-uae installed I only needed to let the AmiKit shell-script unarchive itself, copied AmiKit over and booted. Then the AmiKit install-routine started and I inserted my OS3.9 CD. All went fine.

Author Anonymous
Guest
#7 Posted: 19 Oct 2011 10:02 
AmiKit Admin, please, for the love of God, just provide the archive for download. I had to install Ubuntu in a virtual machine, install a bunch of seriously outdated debian packages so I could install Xdialog. Go through your nice, but certainly not needed, install script. Finally get the files, and archive them then copy them back to the host Mac system.

I understand you're trying to make this dead simple but we're Amiga users for God's sake. If you can't figure out how to setup the emulator, you probably don't deserve to use the Amiga emulation anyhow.

Author AmiKit
Admin
#8 Posted: 19 Oct 2011 17:12 
Sorry for the complications. AmiKit was created using Windows and Linux.

BUT AmiKit 1.6 will be available for OS X too - and easy to install.

Installation questions AmiKit Support Forum / Installation questions /
 Mac OS X/AmiKit horror

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑