AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 191 [17 Oct 2019 17:54]
Guests - 191 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  
 

New, trying to get AmiKit working with AF6 and having difficulties

 
Author vonshep
Partaker
#1 Posted: 8 Oct 2007 04:40 
I'm having some trouble with AmiKit installation and trying to use the trick to get it to recognize the AmigaForever 6.0 CD I have. My goal is to create a nice, emulated Amiga 4000 (T) with RTG and install all the nice bells and whistles. Later, I'll want to follow the same techniques on a real Amiga.

I extracted AmiKit to it's on folder, and when I start it I get an error message from WinUAE stating that it "Could not find system ROM key file". After I click OK, then I get "Could not load system ROM, trying system ROM replacement". And then after that, I get "You need to have a floppy disk (image file) in DF0: to use the system ROM replacement.

It would be nice to just click Run AmiKit and go, but I always go through these errors. Even after I've configured WinUAE with the proper ROM files I have from my installed AmigaForever 6.0.

OK, so after this the config utility comes up for WinUAE 1.4.4. I manually select the ROM files, and copy the 2 starup-sequence files from the downloadable "AmiKit-AF6CD-Startup" from this site, and then boot up the AGA Amiga 040.

I get "Please select the installation language", so I choose English. I get the welcome screen next. From here I've tried clicking the AmigaForever CD button or the AF installed button, but what I get after it tells me to input my AmigaForever CD is:

CD appears to be Amiga Forever 2005/2006
Checking version number ...

This is NOT a valid source of AmigaOS,
installation cannot continue, sorry ...

I've tried some of the tricks listed on another thread but that didn't work. I'm sure there's a way to get it to work with my AF6 CD, but maybe I've missed something?

Right now, I don't have money to plunk down for AF2006 or even OS3.9, although I'd like to. So I have a couple of questions:

1) Can someone help me get AmiKit working with what I have?
2) If it doesn't work, can I install WinUAE with OS3.1 and then upgrade to AmiKit later?
3) Is there anyway to get the Run AmiKit button to work correctly to start off with, rather than going to Configure WinUAE?

Author AmiKit
Admin
#2 Posted: 8 Oct 2007 07:36 
3) Try to move the "ROMs" folder located in AmiKit\ to AmiKit\WinUAE\

I'll answer the other issues later. Thanks for patience.

Author vonshep
Partaker
#3 Posted: 8 Oct 2007 07:46 
Ok, moving the ROMs folder got rid of the errors I received when clicking Run AmiKit. Thanks.

Next step is getting AmiKit installed. I'll check back. Thanks for the help.

Author AmiKit
Admin
#4 Posted: 8 Oct 2007 20:27 Edited by: AmiKit 
Ok, I updated the AF6CD script. Please download it again from here and let me know.

(Note: Clean your browser's cache to make sure the updated version will be downloaded, you know).

Author vonshep
Partaker
#5 Posted: 9 Oct 2007 01:45 
There we go! That worked. Thank you. It's asking me for a registration serial # when I start up. Is that my AF6 license key, or is that for Dopus, or something else? Also, I saw an icon for Install Patches. Should I do that? I read somewhere that it was for OS3.9, but I wasn't quite sure which OS version I'm running at the moment.

The Amiga looks sweet. I'm even typing this using IBrowse! I can't wait to get ImageFX working on this. Too bad the Toaster/Flyer won't work on it.

Author AmiKit
Admin
#6 Posted: 9 Oct 2007 08:00 Edited by: AmiKit 
I am glad to hear it works for you!

Your questions are answered in FAQ and Installation section.

The registration requester belongs to DOpus Magellan (which is still unavailable to purchase, eBay is the only solution at the moment).

"Install Patches" installs additional (and unofficial) patches on top of the AmigaOS3.9BB1&2. This is done automatically if AmigaForever is used as the source of system files for AmiKit. You do not need to take any action.

Installation questions AmiKit Support Forum / Installation questions /
 New, trying to get AmiKit working with AF6 and having difficulties

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑