AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 3
Members - 0
Most users ever online: 605 [18 Apr 2019 18:52]
Guests - 605 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  
 

AmiKit under EUAE OS X 10.4.8

 
Author Korruptor
Partaker
#1 Posted: 8 Nov 2006 10:47 
Hi,

I'm probably not the first person to have tried this, but I've successfully migrated an AmiKit Install over to EUAE/HiTorro under OS X 10.4.8 (Intel).

I had to revert to the safemode startup sequence, as it reports an error:

cannot open uaescsi.device unit 0

which the boot picture prevents me from cancelling, consequently halting boot. I've tried with scsi set to true and false in the UAE config, but nothing changes, so I'm still tracking this down.

Other than that, AmiKit is slightly unhappy with EUAE reporting an older version number than it would like, but it does run and so fars seems stable.

I've seen talk of a Linux version of AmiKit, so I wanted to mention that if this is done fairly cleanly, ie: bash shell for config, tarball for distro, you'd also get it running on OS X fairly easily...

If I figure out the problem with the scsi device on boot I'll let you know. So far, great compilation though. Thanks a lot

Author AmiKit
Admin
#2 Posted: 8 Nov 2006 11:08 Edited by: AmiKit 
Congratulations and thank you for your effort Korruptor!

The error you mentioned is due to CD0 file located in AmiKit: Devs/DosDrivers folder. It tries to activate an CD-ROM device, unit 0. It should be enough to move the CD0 file to AmiKit:Storage/DosDrivers folder to avoid the error report.

How fast is the emulation? Does it support JIT?

Once you completely manage to run AmiKit under OS X, I'd be happy if you could write a short manual on how did you do that so that other Mac users can try it too! I'll make it available on the website.

Author Korruptor
Partaker
#3 Posted: 8 Nov 2006 13:07 
Hi there,

I was just about to post that I'd sorted the problem It is indeed that file.

Emulation in a window is acceptable, although not what I'd call blindingly fast. It's configured to use JIT with an 8MB cache. I strongly suspect that the EUAE Universal Binary that I'm using is hamstrung by an SDL framework that's PPC. I've not yet found an Intel SDL build to confirm this, though. I've not fully tested it, but apparently EUAE is faster full screen, which is about right for SDL anyway...

My Installation on OS X is a cheat, though. I have access to a windows machine at work, which I had Amiga Forever Installed on. All I've done is run the AmiKit installer on the windows box and pointed it at the AF installation and ROM files then let it do it's thing.

From there, I've rar'd the resulting AmiKit file, ftp'd it to my MacBook and then using HiToro, set the correct paths for the rom files and edited the HD path to point to the new AmiKit folder. The only change that needs to be made to a base AmiKit install is the removal of this DosDriver file. The standard startups all work straight out of the box.

I'm 100% confident that if you provide a base AmiKit zip or rar package that the rom files and AF installation files you copy during the windows installer can be scripted to be copied in much the same way under Linux or OS X. There's probably more work involved in getting Amiga Forever setup on OS X in the first place, so I'd suggest the easiest way is to do similar to me; setup on windows then move the result lock stock over to OS X.

The only glitches I'm having are:

LiveUpdate is reporting it's unable to connect to the server. Not sure if this is fact, or peculiar to my setup right now.

The screenmode is stuck on 800x600. Despite saving my preference to 1024x768, it pops open at the lower res, then if I'm lucky on a later attempt via screen mode, Intuition will pop it up to the higher res. This is a bit hit and miss though, as the start bar, calendar etc will restart before intuition's able to resize. Not a big deal and something I'll fiddle with later.

All in all, my cheaty approach was pretty much painless, so cracking work and thanks

Author AmiKit
Admin
#4 Posted: 8 Nov 2006 13:28 Edited by: AmiKit 
With regards to Live Update, does the AWeb or IBrowse work for you? I mean the inetrnet connection in WinUAE is provided by emulated bsdsocket.library so the whole AmiKit uses the connectivity of your Windows. However I don't know how it works under Mac's EUAE. Btw. the Live Update server works, I checked it a minute ago.

What program have you used to save the screenmode preferences, "ScreenMode AmiKit" or classic "AmiKit:Prefs/Screenmode" ?

"ScreenMode AmiKit" adjusts the position of icons, windows and other elements according to your selected screenmode. It also contains pre-instaled screenmode prefs files and one of those is used. While it works perfectly for me and majority of the users, it was reported that eg. 1280x800 prefs file saved here on my laptop is interpreted as completely different screenmode on other laptops. Therefore if you change your screenmode using the "ScreenMode AmiKit" program, then always run classic "AmiKit:Prefs/Screenmode" and select the same screenmode there too before you reboot.

Oh, there's another thing - the safemode startup always uses 800x600 screenmode.

With regards to ZIP archive, yes, I already thought about it and I will make it available with next major AmiKit update. Does Mac EUAE support harfiles? I can provide the hardfile too, it would be even better than ZIP I think.

Author Korruptor
Partaker
#5 Posted: 8 Nov 2006 14:10 
Yup, both the browsers and ftp work and Live Update's still refusing to connect. Not got much time to check further today, although I'll keep playing with it.

Screenmodes: Doh. *slaps forehead* It would obviously help if I'd swapped that back to the right res. Hahaha, sorry

EUAE does apparently does support hardfiles, although I couldn't find any to test it with just now. Thinking about it, this would be the best option for people if it works as there's hardly anything to do. The AmiKit.uaerc file works fine in HiTorro once the paths are updated.

I've just installed the Universal binary of SDL and there's little or no performance improvement, unfortuantely. It is perfectly usable, just not as quick as WinUAE.

Paint me happy, though. It's a great little setup, especially full screen

Thanks for your help!

Installation questions AmiKit Support Forum / Installation questions /
 AmiKit under EUAE OS X 10.4.8

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑