AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 287 [27 Apr 2018 00:59]
Guests - 287 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  
 

Problem patching BB1 + 2 and 3.1.4

 
 
Page  Page 2 of 2:  « Previous  1  2

Author nilly
Partaker
#16 Posted: 12 Nov 2018 08:31 
No, no offscreen dragging, it doesnt seem to be loaded, so it works as it should on your end? how about you ClassiC, offscreen dragging?

Author AmiKit
Admin
#17 Posted: 12 Nov 2018 08:43 
Yes, it works here right out of the box. Make sure you shut down the whole emulation after you installed AmigaOS 3.1.4 and restart AmiKit (a simple reboot is not enough). Also check the new intuition.library is installed in AmiKit:Libs and make sure it has P attribute set (PURE).

Is it A1200 version of AmigaOS 3.1.4 you installed?

Thanks,
Jan

Author nilly
Partaker
#18 Posted: 12 Nov 2018 08:55 Edited by: nilly 
Got it working now, I do need to add loadmodule to startup-sequence to load the intuition lib, not working out of the box though so a bit weird.

yes its 1200 version

Author AmiKit
Admin
#19 Posted: 12 Nov 2018 09:01 Edited by: AmiKit 
LoadModule IS already in startup-sequence! Can you please confirm that the header of the startup-sequence after installing AmigaOS 3.1.4 says something like this: "Startup-Sequence 3.1.4 for AmiKit X"

If not, could you please uninstall AmiKit and follow the instructions above precisely and confirm the intuition.library is still not installed? If so, you found a bug Thanks for your testing!

Author nilly
Partaker
#20 Posted: 12 Nov 2018 09:18 
I did a fresh install as the instructions say, and the startup-sequence is the 3.1.4, there is nothing in the startup-sequence that points to intuition.library specifically,
I added "LoadeModule SYS:Libs/intuition.library" to get it working.

Author AmiKit
Admin
#21 Posted: 12 Nov 2018 09:24 
Do you use OS3.1.4 ROM as well?

Could you please confirm that the AmiKit:Libs/intuition.library has P attribute set?

LoadModule ROMUPDATE ensures intuition.library is loaded (it doesn't need to be specified manually).

Author nilly
Partaker
#22 Posted: 12 Nov 2018 09:29 
Yup, I use the 3.1.4 rom, intuition lib has P attribute set.

Author AmiKit
Admin
#23 Posted: 12 Nov 2018 09:33 Edited by: AmiKit 
Ah, we're getting somewhere. The instructions did not say to use new ROM 3.1.4

Does the new intuition.library work if you keep using the original ROM and non-modified startup-sequence, please?

Author nilly
Partaker
#24 Posted: 12 Nov 2018 09:39 Edited by: nilly 
That works actually intuition loads out of the box. But wouldn't we want to use the new rom aswell?

I didn't even think of booting amigaos 3.1.4 without the new rom.

EDIT: The 3.1.4 rom is still running, do you soft load it to ram?

Author AmiKit
Admin
#25 Posted: 12 Nov 2018 09:46 Edited by: AmiKit 
Thanks for the confirmation. Actually you don't need new ROM at all because LoadModule installs all new ROM modules (including new intuition.library) automatically - and that is the same as using the new ROM.

If new ROM is used then LoadModule is only used to load new icon.library. And you have just discovered that it should load new intuition.library as well. Thank you! I will modify startup-sequence accordingly.

I would like to thank you in next Live Update text - should I use "nilly" or do you prefer a full name?

Author nilly
Partaker
#26 Posted: 12 Nov 2018 09:50 
nilly is fine

Author AmiKit
Admin
#27 Posted: 12 Nov 2018 09:52 Edited by: AmiKit 
Thanks a lot nilly, ClassiC and JimmiG!

Author nilly
Partaker
#28 Posted: 12 Nov 2018 16:05 
Another small thing i noticed even though not about the 3.1.4 update, the DH3 volume button in your dopus4 config points to PC0, I usually use my own dopus4 config , but might be some guy that don't know his way around dopus4 to fix it, probably not, but still. just mentioning it.

Author JimmiG
Partaker
#29 Posted: 16 Nov 2018 11:24 
A bit late as I've been busy recently, but I just tried again with the latest update and the same procedure. This time it seems to work fine. No error messages during any of the update steps, and the AmiKit desktop looks as it should.

Author AmiKit
Admin
#30 Posted: 16 Nov 2018 11:36 
Thanks a lot for your confirmation, JimmiG! Much appreciated.
I am happy it works for all of you now!

Page  Page 2 of 2:  « Previous  1  2 
Installation questions AmiKit Support Forum / Installation questions /
 Problem patching BB1 + 2 and 3.1.4

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
 
AmiKit Support Forum Powered by Forum Script miniBB ®
↑ TOP