AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 287 [27 Apr 2018 00:59]
Guests - 287 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  
 

OS3.1 or OS3.9 for AmiKitX - any difference in daily use ?

 
Author amikit_noob
Partaker
#1 Posted: 4 Aug 2018 08:30 
Hi, just wondering, are there any visual differences in AmiKitX, when installed with OS3.1 or OS3.9 ?

I normally install with OS3.9, now I only have OS3.1, so just wondering

Thanks
Regards
amikit_noob

Author AmiKit
Admin
#2 Posted: 7 Aug 2018 23:11 
For AmiKit I definitely recommend AmigaOS3.9 as the source for Operating System, which is superior to OS3.1 in every aspect, including visual one.

Actually, AmiKit was developed using OS3.9, while OS3.1 support was added later for compatibility reasons.

Author amikit_noob
Partaker
#3 Posted: 12 Aug 2018 13:11 Edited by: amikit_noob 
Specs: AmiKitX 10.5 Dark Mode, 1280x800 32bit AmiKitX window Resoultion, iMac early 2009, 2.66GHz, 4 GB Ram, High Sierra 10.13.6
-----------------------------------------------------

I use OS3.1 (from OS4.1FE install dvd/iso) instead of OS3.9 as source, is that why some programs do not open in AmikitX 10.5 Mac version ?

Example: AmigaAMP gives these 2 errors:

"Error: Failed to open window.class (version 0 or newer required)

"Could not open ReAction classes! Exiting"

I mean, do some amiga programs not work/open, because I only use OS3.1 instead of OS.39 ?

Thanks
Regards
amikit_noob

Author AmiKit
Admin
#4 Posted: 12 Aug 2018 13:13 Edited by: AmiKit 
Right. AmigaAMP requires ReAction GUI which was introduced in AmigaOS 3.5

https://en.wikipedia.org/wiki/ReAction_GUI

Author amikit_noob
Partaker
#5 Posted: 12 Aug 2018 13:16 Edited by: amikit_noob 
ahh, okay, I understand now
I will get OS3.9 from AmigaForever and use that as source for AmiKitX, so all amiga programs will work

Thanks
Regards
amikit_noob

Author AmiKit
Admin
#6 Posted: 12 Aug 2018 13:23 
I would recommend OSXL (as it already includes OS3.9 with BoingBall1 update pre-installed) or plain AmigaOS3.9 and install BB1 and BB2 manually.

Amiga Forever includes AmigaOS3.9 too, but some (not viable) files are not included. Read more details here.

Author amikit_noob
Partaker
#7 Posted: 12 Aug 2018 19:35 
You are right

I re-installed AmiKitX on Mac with OSXL (instead of OS4.1FE) as source
and now AmigaAMP works perfectly

Now I'll try and see if AmiDock in included (I read it should be in OSXL)...

Author amikit_noob
Partaker
#8 Posted: 13 Aug 2018 18:50 Edited by: amikit_noob 
SCREENSHOT:

MAC - OSXL/OS3.9 - AMKITX 10.5: Perfect!

1680x1050 pixels:
https://ibb.co/dv9eT9

Thanks for suggesting OSXL as source for AmiKitX, now I have AmiDock (love it!) and AmigaAMP (with 86 skins!) streaming live internet radio

I'm happy with AmiKitX 10.5 on Mac, runs very smooth/full speed!

amikit_noob

Author AmiKit
Admin
#9 Posted: 14 Aug 2018 22:16 
Looks nice!

Installation questions AmiKit Support Forum / Installation questions /
 OS3.1 or OS3.9 for AmiKitX - any difference in daily use ?

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
↑ TOP