AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 605 [18 Apr 2019 18:52]
Guests - 605 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  
 

Not sure if this is a bug or not.

 
Author Cjnman
Partaker
#1 Posted: 3 Oct 2006 15:03 
I'm not sure if this is a bug or not, as I don't recall this happening with the 1.01 through 1.04 versions. Now I did all of this before I found the post explaining how to fix it without a re-install.

But I have a 21" Samsung LCD monitor whose default screen size is 1600x1200. And I installed Amikit 1.2.0 and when it asked the screen size, I chose 1600x1200 which worked fine on the 1.01 version during install.

But this time, when it does the re-boot I get the startup picture and the bar goes across the top and then it just stays there. I never get the part where I have to click Run, never get a desktop.

So I uninstall, and re-install and I pick 1280x1024, and this time everything works. I update to 1.2.2 and then I go into prefs and set both screenmode to 1600x1200 and the one marked for Amikit I changed to 1600x1200, and on re-boot get the picture but nothing else.

Finally I re-installed and this time picked 1280x1024, then after update to 1.2.2, I just change the screenmode to 1600x1200, but leave the one for Amikit at 1280x1024.

Now when I boot up, the opening screen is 1280x1024 and then I can click Run, and then it goes to the desktop and I'm at 1600x1200. I can live with the screenmode changes between the opening loading screen and the actual desktop, but just wondered why using 1600x1200 on the opening part don't seem to work anymore?

When I used to install the 1.01 version that mode worked for both loading screen and desktop.

Now I have found that one post, so if I ever have to re-install and forget and pick 1600x1200, I know how to fix it without a re-install.

Author AmiKit
Admin
#2 Posted: 3 Oct 2006 23:04 Edited by: AmiKit 
Hi Cjnman!

If I understood you correctly the lock up is caused by 1600x1200 boot picture while it worked fine in older releases (1.0). Even though the latest AmiKit uses the new boot picture (compared to previous AmiKit versions), I doubt this is the reason for lockups.

You can disable the boot picture to see what is happening in the background.

Please edit startup-sequence and disable following line by inserting ";" character at the begining (without quotes of course):

SYS:Utilities/Expansion/ShowAmiga96/Bin/ShowAmiga96_Rev239C18

(NOTE: microgolded will probably complain "Cannot delete file..." when you save the file but don't worry, the changes will be saved anyway.)

Then use the "Screenmode AmiKit" program and switch to 1600x1200 mode again and reboot.

I assume the problem you encountered was caused by a crash of IPrefs. In that case boot your AmiKit without the startup-sequence and edit it by entering:

ed startup-sequence

Then enable "Wait 1" command in front of IPrefs by removing ";" character in front of the line. You can also add the same "Wait 1" command in front of AfA_OS_Loader command as well. Save the changes, quit emulation completely and run it again.

Hope it helps.

Author Cjnman
Partaker
#3 Posted: 4 Oct 2006 01:40 
Ok, Well I tried commenting out the SYS: line and then I set screenmode Amikit to 1600x1200. I did the reboot and then I get the Dir Opus box in 800x600 screenmode then the Workbench comes up in 800x600 and some things fail to load. I can't remember everything that failed to load. I even ran into a error box or two.

Well the monitor says it's in 800x600, but everything on the display looks bigger then the one time I set it to 800x600 during install. So I think it was a screenmode that made my monitors menu think it was 800x600.

When I opened Screenmode Amikit, part of it was cut off the bottom and I picked 1280x1024 and then re-booted. Then both came up in 1280x1024.

Got the same when I uncommented the Wait 1 line. And added a Wait 1 to the AfA_OS_Loader.

Not sure what is causing it, but I'll think I'll leave the comment on the picture, as now I have screenmode amikit at 1280x1024 and my Workbench at 1600x1200 and now when the dir opus window pops up, it's in 1600x1200 and stays there when the desktop loads. So I don't get black screen flashes back and forth.

Author AmiKit
Admin
#4 Posted: 4 Oct 2006 07:36 
One more thing. Use "Screenmode AmiKit" again, set it to 1600x1200 but do NOT reboot. Run classic SYS:Prefs/Screenmode. What mode does it show? Set it to uaegfx:1600x1200 32bit, Save and reboot.

Author Cjnman
Partaker
#5 Posted: 4 Oct 2006 16:55 
Well, this is the third time trying this. I've tried typing this in IBrowse, and Aweb, but under both when I click on the Post message button, nothing happens, so I'm back in Firefox on Windows. Not sure why it would not accept the click on the Post message button on both IBrowse and AWeb, even though there was text in the box.

I tried this with the boot screen disabled. This time I still get a 1600x1200 screen size on the Dir Opus box, and on Workbench, but I get this box:

The following required GUI classes
could not be opened

radiobutton gadget

OK

I click OK, and notice I don't have the calender on the WB anymore. I tried quitting Amikit and re-starting, and the same thing pops up and no calender.

So I put the Screenmode Amikit back to 1280x1024 and Screenmode to 1600x1200, and the DirOpus box is in 1600x1200 and so is the WB, but no box pops up. I got the calender back, but all the saved settings were gone.

Same for IBrowse, all the settings I saved as default and regular save was gone. I had to go back through them again. Some of the changes I did in Aweb were there, and some were back to default.

I may try re-enabling the boot picture and try again to see what happens.

I'm also going to try to use IBrowse and AWeb on another forum and see if I can successfully post on them. Strange that I can't post here even though I logged in.

Author AmiKit
Admin
#6 Posted: 4 Oct 2006 18:24 Edited by: AmiKit 
With regards to forum, I have to confess I have never tried with AWeb nor IBrowse. You are correct, the "Post message" button doesn't work with these browser. Maybe this is because of recent upgrade of forum. Anyway, to avoid typing the text on PC side again, you can use RightShift+RightControl+c hotkey on Amiga side to put the Amiga text into PC clipboard. Then simply use Control+v on PC side to paste it. Similarly you can paste PC text into Amiga by pressing RightShift+RightControl+v on Amiga side.

The "radio button" error is not related to screenmode. This is a "bug" of LimpidClock calendar. I already discussed it with the author of this program some time ago but we were unable to find the bug. It happens only sometimes and in addition, if you manually run the LimpidClock (AmiKit:WBStartup/LimpidClock.ttengine), it will work even though it reported the error before. Strange. You can try to increase or decrease the value of DELAY tooltype of this program.

I apologize for overwriting your already customized IBrowse and AWeb settings. These and other settings are overwritten by "ScreenMode AmiKit" every time you change the screen mode with this program. It is necessary to adjust these browsers to selected screenmode and to set correct fonts according to your locale and truetype settings. There is a note in the program window informing you about overwriting, however it does not explicitly say what exactly will be overwritten. I should change it.

Anyway, please try to do what I wrote in my previous post, with the boot picture enabled in startup-sequence.

Author Cjnman
Partaker
#7 Posted: 4 Oct 2006 19:04 
Bingo, it now works. The pic comesup in 1600x1200 and then it switches to the Dir Opus, then back to the pic then the desktop shows up.

I still get the box no matter how long I set the delay to, I tried 10 through 320. So I moved it to the Disabled dir and moved the other one in to WBStartup. Now when it boots up, I get no box and the calender shows up.

I can live with the other version. WooHoo. Thanks.

I can understand the window size being affected, but I kinda wish the font sizes wouldn't be touched. It takes a while for me to go through each one and increase the size till I can read the text better.

Not knowing what site uses which font, I go through every one increasing the first 3 to 4 of each font.

If this was a CRT monitor instead of LCD, I would use a smaller screensize, but alot of times any size below 1600x1200 and text becomes a bit strange looking.

Author AmiKit
Admin
#8 Posted: 4 Oct 2006 19:24 
It would be possible to overwrite only those settings that are really needed. Unfortunatelly, this is not possible with IBrowse as its settings are stored in a single file, including bookmarks and everything, you know.

You said the 1600x1200 screenmode always worked fine with earlier AmiKit releases. Were you always using the same monitor as you are now?

When you switched to 1600x1200 using the "Screenmode AmiKit" program and then (before rebooting) you run classic "AmiKit:Prefs/Screenmode", what screen mode does it show?

Your screenmode problem was probably caused by my 1600x1200 screenmode.prefs file included in "Screenmode AmiKit". Everytime you switch to 1600x1200 using this program, the file is copied to ENVARC: and it should activate this screenmode next time you boot. However there might be some incompatibilities in interpreting this screenmode.prefs across various system. For example 1280x800 screenmode.prefs saved on LCD laptop is intepreted as completely different screenmode on my desktop CRC system. And it is the very same screenmode.prefs file. So I assume something similar happened to you with 1600x1200. I saved this preferences using my desktop CRC monitor, while your LCD system can interpret it as unknown mode. That's why you always encountered the lock up. I don't know why this screenmode misinterpretation happens, maybe it's because of different refresh rates of CRC and LCD monitors, even though the size is the same.

Anytime you use "ScreenMode AmiKit" program, please use also classic "AmiKit:Prefs/Screenmode" to confirm the screenmode before you reboot.

By the way, please send me your 1600x1200 screenmode prefs (ENVARC:Sys/screenmode.prefs). I'll check how is this file interpreted on my CRC monitor so I can 100% confirm the bug was caused by this misinterpretaion.

Author Cjnman
Partaker
#9 Posted: 5 Oct 2006 00:02 Edited by: Cjnman 
AmiKit
By the way, please send me your 1600x1200 screenmode prefs (ENVARC:Sys/screenmode.prefs). I'll check how is this file interpreted on my CRC monitor so I can 100% confirm the bug was caused by this misinterpretaion.


Ok, how do I do that here? I don't see an option to attach files here, and not sure what your email address is.

EDIT: Found it. I assume I can send it via Thunderbird on the Win side, as I haven't got Simplemail set up yet. Hopefully it won't do anything to the file. Well, maybe I'll set up simplemail first. Rather not take a chance that Windows screws up the file.

Author Cjnman
Partaker
#10 Posted: 5 Oct 2006 00:32 
Well, I think I got Simplemail set up. I attached the file and put my handle in the subject line, then hit send now before typing anything below.

Let me know if it made it.

Author AmiKit
Admin
#11 Posted: 5 Oct 2006 15:00 
Well, I confirm the problem was due to screen mode incompatibility. Your uaegfx:1600x1200 settings is interpreted as NTSC:640x200 here! Seems I have to rewrite the way of selecting the screenmode in AmiKit.

You mentioned the 1600x1200 worked fine with previous AmiKit releases. Did it work with your 21" Samsung LCD monitor?

Author Cjnman
Partaker
#12 Posted: 5 Oct 2006 20:00 
Yes. I used this 21" Samsung LCD on the early version. My previous Samsung was a 19" 1280x1024 default size, but I had this 21" when I was trying 1.01, 1.02, 1.03 and 1.04.

I remember it working on 1.01, .02, .03 and I think .04 but I may be wrong on 1.04, that may be when I first noticed it, but other things came up and I hadn't got back to using Amikit till here recently.

It might have been a higher version than 1.04 though, it has been a few months since I tried it.

Installation questions AmiKit Support Forum / Installation questions /
 Not sure if this is a bug or not.

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑