AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 191 [17 Oct 2019 17:54]
Guests - 191 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  
 

Recoverable Alert

 
Author XenonMB
Guest
#1 Posted: 11 Sep 2006 17:06 
Hey,

I installed amikit today and have some problems with an recoverable alert at boottime, and nothing after :D

Systemfiles are from os3.9cd, i even got dopus registered :D

i tried around a bit and booted from the "safe" startup-sequence,which works ok. i then installed boingbag1&2 and the patches in "safe-mode", but still get the same recoverable alert 0100 000C.

there are no weird directorynames or anything. J:\amikit (NTFS)

i tried a a1200 3.1 kickstart and a a4000 3.1 kickstart, both the same.

my pc is an athlon 64 3200+ with 1gb RAM, nvidia graphics card, windows xp sp2 and up to date.

Please give me some suggestions :D

Author XenonMB
Guest
#2 Posted: 11 Sep 2006 18:08 
i just found out that the problem does not occur if JIT is turned off, but it is painfully slow then, as you may probably imagine. i think the problem could be resolved by tweaking the JIT settings, but it is one of the settings i'm not familiar with, so any suggestions are welcome :D

Author AmiKit
Admin
#3 Posted: 11 Sep 2006 21:17 Edited by: AmiKit 
Thanks for report XenonMB.

I already got several bugreports describing differnet strange problems with AmiKit. What joins all the reports together is 64bit CPU. Once there is a huge slowdown, or ReAction programs crash or AmiKit keeps rebooting on startup.

If the problems are really caused by the 64bit CPU then there are two possibilities. It could be because of WinUAE itself OR something in AmiKit triggers rather rare bug in WinUAE that causes instability. Hope the second is the case.

Anyway, you can try something. First, try to change your screenmode using the "AmiKit:Prefs/Locale AmiKit" program to 800x600. Or better, reinstall AmiKit and select this screenmode during the AmiKit installation of system files.

Good news is that startup-sequence.SAFEMODE works for you. This indicates something inside regular startup-sequence is causing the troubles. Boot with "safe" startup and then edit regular Startup-Sequence using the microgolded. Try to disable several patches and additional programs by inserting a semi-colon in front of the following lines:

C:TagLiFE
SYS:Utilities/Expansion/ShowAmiga96/Bin/ShowAmiga96_Rev239C18
Run >NIL: SYS:Utilities/Expansion/TitleShadow/TitleShadow
Run >NIL: SYS:Utilities/Expansion/VisualPrefs/VisualPrefs
Run >NIL: SYS:Utilities/Expansion/VisualPrefs/TRAP ALL COMPLETE
SYS:Utilities/Expansion/ShowAmiga96/Bin/ShowAmiga96_Login >NIL:
SYS:Utilities/Expansion/FullPalette/FPPrefs
C:MakeLink >NIL: RAM:Disk.info ENVARC:SYS/def_RAM.info SOFT
Run >NIL: C:PatchAsl
C:MemTrailer SIZE=96

If you manage to boot with such a startup-sequence, then try enabling some lines and until it crashes again - this is the way how to find the trouble-maker program ;-) Note: microgolded will probably report the startup-sequence is locked when you save the changes. Just ignore this message, the changes will be saved anyway.

Please report the result, thanks!

Author XenonMB
Guest
#4 Posted: 13 Sep 2006 03:44 
okay i will try that today, and report the results....

by the way i found out that when setting HIT to indirect mode, the system boots ok and works as it should, i only get rather random crashes occasionally (software failure)

Author XenonMB
Guest
#5 Posted: 13 Sep 2006 03:58 
Of course i meant JIT instead of HIT in the last post. :D

after altering the startup-sequence as you described, it still doesnt work with JIT in direct mode. i get the same recoverable alert -.-

Author AmiKit
Admin
#6 Posted: 13 Sep 2006 10:02 Edited by: AmiKit 
Are you sure you disabled all the lines I mentioned? Ok, time to disable even more. It really has to be something inside the startup-sequence because, like you said, startup-sequence.safemode works. And there are all the patches disabled, you know.

Also disable:
C:AfA_OS_Loader

If you do so, you MUST also ENABLE following line in front of C:Iprefs
;C:Wait 1
and enable the same command in front of "Run >NIL:" "SYS:Utilities/Expansion/Birdie/Birdie ? <Env:Birdie.prefs"

Test it. If it works, enable all the patches you disabled before (as described in my previous post) and leave only "C:AfA_OS_Loader" disabled. Test it again, please.

Author XenonMB
Guest
#7 Posted: 13 Sep 2006 14:03 
it works with the AfA_OS_loader disabled and all others that i disabled earlier enabled again... so the AfA_OS_Loader seems to be the problem. (with direct JIT at least :) )

what does that program do? only thing i noticed, is my font spacing in file requesters was off :D

Author AmiKit
Admin
#8 Posted: 13 Sep 2006 14:31 Edited by: AmiKit 
well, AfA_OS provides TrueType font support for AmiKit. It also speeds up the icon loading.

AmiKit is set to use TrueType fonts by default. When AfA_OS is disabled, those fonts do not look nice, therefore run MorpheuZ and press "Disable TrueType" button to use classic font settings in AmiKit.

Thanks for your report, I'll discuss it with the authors of AfA_OS and WinUAE.

Btw. you can try to enabled AfA_OS_Loader again, just insert "Wait 1" command in front of it, or better "Wait 2". It will ensure everything gets loaded before AfA is run. This should help to avoid recoverable alert (or lock up) during the boot process of AmiKit.

Installation questions AmiKit Support Forum / Installation questions /
 Recoverable Alert

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑