AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 191 [17 Oct 2019 17:54]
Guests - 191 / Members - 0
Installation questions AmiKit Support Forum / Installation questions /  
 

Install problem

 
Author Anonymous
Guest
#1 Posted: 1 Dec 2005 20:13 
I install amikit all ok, it copies the file from my OS 3.9 CD just fine, i select the screen res.

then it reboot for the first time and i get a recoverable alert

Author Anonymous
Guest
#2 Posted: 1 Dec 2005 20:19 
sorry

Error: 0100 000F Task 001712E8

It then i get a Software failure Error: 8100 0005 Task: 001712E8

I am running Windows XP x64, Athlon 64 3500+ 939. 2 gb ram. Nvidia 6600GT Nforce 4 chipset.

If you need any more info then please ask

Thanks i am so looking forward to using AmiKt

Dave =)

Author AmiKit
Admin
#3 Posted: 2 Dec 2005 09:53 
I am not sure but I think some betatester with 64bit CPU had a problem with AmiKit long time ago. But not the problem of this kind.

Does the alert appear immediately after the reboot? No boot-picture is shown at all?

Please try to use "AmiKit/S/Startup-Sequence.SAFEMODE" as a regular Startup-Sequence. Most of the patches are disabled in this safemode startup-sequence.

However WBStartup remains enabled, so if safemode doesn't help, rename your WBStartup drawer as well so the programs inside are not executed during the startup...

Author Truck
Partaker
#4 Posted: 3 Dec 2005 03:26 
Hmm. Well, I had a similar problem, after boot 'patchMSB' failed, returncode 20. I disabled this in the startup-sequence, and everything loaded - and hung. (Left me with the kitty in the garden picture, and the loader bar completed... left it there for a while (2 hours actually, I did something else and came back and realized it hadn't loaded) ...

So I put in the safemode bit, and it wasn't able to load the arexx library, and closed the cli without a working workbench. ):

Think I have some tweaking to do with that first set of items...

It DID run twice, but I've had this error ever since the 2nd reboot.

Author AmiKit
Admin
#5 Posted: 3 Dec 2005 16:16 
hmmm... very strange behaviour. What CD has you used for installing system files? Does the reinstalling of whole AmiKit helps?

Author Truck
Partaker
#6 Posted: 3 Dec 2005 20:44 
I used my 3.5 CD.

I believe in my case that the problem may be due to some differences in the JIT compiler between E-UAE and WinUAE. With an 060 emulated, the PatchMSB program fails (error 20.) switching to an 020 or an 040, it loads fine (however I have to change some bits to the JIT settings or the program quits with JIT errors.

I've been fiddling with enabling/disabling things in the startup-sequence to see what the issue is, and I've pretty much come to the conclusion that I have to run it with 040 or 020 in order for the system to work. Running as 060 and disabling the PatchMSB error (either by not running it, or setting failat to 19 - because the program simply WILL NOT LOAD (snoopdos debugging shows nothing failing other than the program itself) results in Opus Magellan not loading, and most of MUI being b0rked - 68040 library emulation not working, etc.

I think this may also just be a bug in E-uae's 060 + JIT emulation; it's fairly new.

Author Anonymous
Guest
#7 Posted: 3 Jan 2006 20:37 
hello,

i installed 0S3.9 from CD, after first boot I got a

sys:utilities/expansion/visiualprefs/trap

software failure.

startup-sequence.failsafe renamed as startup-sequence only produces a empty workbench screen.

I use an old kick.rom 3.1 image from my A2000 or was it from my A1200? Maybe it was patched for shapeschifter?

Can anyone help?

Author Anonymous
Guest
#8 Posted: 3 Jan 2006 21:31 
uups,
seemed to be an 3.0 kick.rom

Author Amirex
Moderator
#9 Posted: 4 Jan 2006 20:58 
Did you copy this ROM manually or was it found by RomFind ?

Author kranichba
Partaker
#10 Posted: 5 Jan 2006 22:31 
Hey everybody,
i just sign up ;-) sorry for my weak english.
I'm from Germany
To answer your question:
Rom was manually copied and selected, installation worked fine until first boot.
Now i've seen, that findrom could not find this rom image and it was as mentioned a patched kick3.0 (bootscreen 39...).

My old 1200 seems to work well, but i have no working installation yet, i just must find my disks (scsi - hd an my floppydisks).

Author Anonymous
Guest
#11 Posted: 24 Sep 2006 19:06 
Hello,
I've installed 1.2.0 amikit (new istallation, no update)
I've selected 1024x768 screen mode and 3.1 1200 kikstart rom.
I start amikit and pc ask me for a internet connection (modem 56k).
I accept internet connection and amikit return a error message (visual c++ runtime error !), then amikit and winuae exit.
I've not istalled any patch (bb1,bb2 etc).

Ermanno B.

Author Amirex
Moderator
#12 Posted: 25 Sep 2006 09:39 
The crash appears when amikit is running ? That means the launcher application closes, winuae is starting and while the emulation is running the error message came up and winuae exit. So maybe the problem is related with the new update feature ? Did you use the AmiKit included WinUAE or have you installed an extras WinUAE and if so what version ?

Regards, ReX

Author Anonymous
Guest
#13 Posted: 25 Sep 2006 10:25 
I've disistalled winuae and cleaned registry ;)
then I install amikit 1.2.0 full package. I try to don't start internet connection. Problem is random. I get error while emulation is running.
On another pc is all ok (but I've istalled amikit 1.0 and update...)
I must investigate

Author PeterK
Guest
#14 Posted: 26 Sep 2006 10:11 
Hello Truck,

when PatchMSB quits with returncode 20, then the FPU emulation is missing !

You have to use WinUAE with 020+FPU or 040 (which has also an FPU emu)
or you cannot start any program which was compiled for FPU usage at all.

Please install the latest PatchMSB r10, because that one won't quit any more
and just returns with no error, using the mathieesingbas.library of the ROM.
And also copy the original AmigaOS mathieeeXXXX.libraries to Libs:NoFPU,
when you're using AmiKit 1.20 with the MathLibsUAE r10. The update didn't.
This would make it possible to use the IEEE math without an FPU emulation,
but ONLY the IEEE math. All other FPU dependent apps will crash very soon.

Installation questions AmiKit Support Forum / Installation questions /
 Install problem

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑