Your high-end Amiga!AmiKit turns your PC into high-end Classic Amiga environment! 
Welcome to AmiKit Support Forum!

(Click here for main AmiKit website)
none
 
  Forums Search Register Reply Statistics FAQ  DONATE 
I have a problem with installation AmiKit Support Forum / I have a problem with installation /

alternate install for non-Windows?

Page  Page 1 of 2:  1  2  Next »  
Author Truck
Guest
#1 Posted: 30 Nov 2005 12:20 
As I don't have Windows, I'd like to know if there's a possibility for a non-windows based installer. In particular, I'd be interested in seeing this run on my Pegasos, or my osX machine, but in a pinch I could use Linux to unarchive and install somewhere.

I did test, and it does not appear the installer is either a rar, zip, cab, or installshield cab file in executable format.

Author Amirex
Moderator
#2 Posted: 30 Nov 2005 12:29 
You can not extract it without windows I think. It is a InnoSetup executable. Inside the installer are 7zip compressed amiga files .. so no chance I'm afraid. Maybe Jan (the author of AmiKit) will release the files additional as RAR archive ??

Greetings, ReX

Author Truck
Registered
#3 Posted: 30 Nov 2005 19:22 
7zip isn't a problem at all, as the source for that is available; heck I think I even have 68000 Amiga binaries for it (:

Author AmiKit
Admin
#4 Posted: 30 Nov 2005 19:27 
Someone already tried to run AmiKit under Pegasos, however the speed of emulation is very slow (just because E-UAE doesn't have a JIT feature).
Check this (german only):
http://www.amiga-news.de/de/news/comments/thread/AN-2005-11-00109-DE.h tml

Author Truck
Registered
#5 Posted: 30 Nov 2005 20:18 
E-UAE has JIT, just not a PPC JIT. I wasn't going to run it in E-uae tho, but instead, native. MorphOS will run amiga binaries native...

We'll see how it goes (: Again, gotta GET the files out of the install pack first (:

Author AmiKit
Admin
#6 Posted: 30 Nov 2005 20:21 
no PC around?

Author Truck
Registered
#7 Posted: 30 Nov 2005 20:39 Edited by: Truck 
Sure. No licenses of Windows, nor do I want any (:

However, good news: knoppix CD (3.9 in this case) is running the executable file just fine under wine. (Didn't even need to install wine, since it runs off CD.)

I also found a (windows only, very odd, but source available (pascal? oh well (: ) unpacker for the installer you used. So if it comes down to it and the wine bit fails (eventually, it's doing some odd waiting now, but it did install files...) I will unpack with that and see what can be done from there.

(no, I'm NOT letting Windows stop me from seeing this in action, no sir (: )

Ah, it just popped up a requester, off to that machine...

Author Truck
Registered
#8 Posted: 30 Nov 2005 20:46 
and it has installed all the files 100%. Romfind also ran successfully under wine, as did the menu. Winuae did not, however, but that's ok because now it's time to take the drawers and put them on the ACTUAL machines and see how they work.

Which I will do after I unpack the 7z files (just in case.)

Author Amirex
Moderator
#9 Posted: 30 Nov 2005 20:48 
Impressive :-)

Author Truck
Registered
#10 Posted: 30 Nov 2005 21:11 
Right, so the answer is that provided you have the ability to use a Knoppix CD for x86, you can unarchive this completely. You can either unpack the install bit into it's components and use a 7zip utility to unpack the various bits (nicely grouped into what they are, this is going to be quite cool to check on MorphOS)
OR
You can run the installer native either by:
1. downloading the file using firefox and choosing 'run' from the option (it will run wine-safe)
2. saving the file to disk, and running "wine-safe AmiKit_setup.exe" in a terminal.

I should point out IF you choose to download the files and unpack them, you are STILL not able to use these files if you don't agree to the terms. (not to be a pedant but seriously they're not tough rules and respecting the wishes of the author is cool.)

I was incorrect about Amiga 7zip binaries, but it does have unrar (http://amiga.sourceforge.net if you didn't know about that spot for good amiga native versions of unixy tools.) 7zip is available on osX and MorphOS and Linux, so it's not a big issue for me; just mentioning in case someone tries with a native 060 or whatnot.

So, I'm off to try this out in E-aue first under Linux, then try under osX E-uae, and finally play with MorphOS in a bit (:

Author Truck
Registered
#11 Posted: 30 Nov 2005 22:17 
One further note - I had put these files on external media and copied them to a drive to run them. I'm not sure if it's the external drive that lost the executable permissions, or the copy, but- you guessed it - no executable bit set on the C: files, and also the mount file needed to start the Amiga install. Not sure what else will need it, but I'll have to run

protect [file] +E

at least once more, prolly, during this install (:

(for a dir, remember, it's #? to wildcard on the Amiga.)

I hope these notes help someone else, that's why I'm typing them, not just to hear me type. I can do the latter on any other message board (:

Author Amirex
Moderator
#12 Posted: 1 Dec 2005 20:05 
One further note - I had put these files on external media and copied them to a drive to run them. I'm not sure if it's the external drive that lost the executable permissions

Yes that's the reason for the 7zip files in the installer. If I put all files unpacked in the installer then theses files also lost their executable flag. But 7zip and RAR for example keep these bits untouched while unpacking. So before copying on another media just pack it with a platform independent packer.

Other files with special language characters like the e' in espanol also made problems and keep an eye on the subdirectories of ZoneExplorer. There are some problematic file names (not supported by windows copy, but maybe no problems on your platform).

Greetings ReX

Author Truck
Registered
#13 Posted: 3 Dec 2005 20:36 
Yeah, Amiga translation of characters is different from UTF-8, UTF-16, UTF-32, Mac, and Windows encoding (and heck, ASCII, PETSCII and EBDIC (: ) So that tends to be problematic and files tend to get messy, especially French characters - sometimes umlauts and accents are fine, but those French dangly things on the C get nasty.

I did try to complile 7zip for 68000, but the source for 7za is a mess (with things like checking once to see if wide character support is there, then ignoring the result and calling everything with wide character support... ugh!) so it's prolly going to have to be put into an XPK -- by someone other than me (:

Author blokey
Registered
#14 Posted: 12 Feb 2006 23:11 
I've managed to install AmiKit under WINE (Linux x86) and I have an original OS 3.9 CD handy for OS installation. AmiKit recognises the CD as 3.9 but won't install it. Here's what I get:

CD appears to be AmigaOS 3.9
Checking version number...
AmigaOS3.9:OS-Version3.9/Workbench3.5/C/Wait: disk is write-protected
AmigaOS3.9:OS-Version3.9/Workbench3.5/C/Version: disk is write-protected
INCORRECT!!!
This is NOT a valid source of AmigaOS, installation cannot continue, sorry...

Of course, the CD is read-only. I've made sure it was mounted with exec enabled, and execute permissions are set.

Any suggestions?

Author AmiKit
Admin
#15 Posted: 13 Feb 2006 08:56 
uff.. I have no idea why executing "Wait" and "Version" require the write operation, I am sorry. Try to modify the script to skip this section.

Page  Page 1 of 2:  1  2  Next » 
I have a problem with installation AmiKit Support Forum / I have a problem with installation / alternate install for non-Windows? Top
Your Reply Click this icon to move up to the quoted message
 

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.
 
Online now: Guests - 5
Members - 0
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0