AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 605 [18 Apr 2019 18:52]
Guests - 605 / Members - 0
Basic questions, I am new here AmiKit Support Forum / Basic questions, I am new here /  
 

AmiKit to HDF + Intel Mac = ENV problem

 
Author szewski
Partaker
#1 Posted: 8 Feb 2009 15:11 
Hello,

First of all I would like to thanks all AmiKit project contributors

Ok, to the point

My goal is to create 2GB HDF with AmiKit in it. I want to do this because currently I have to launch Amikit from Windows XP witch is running under VirtualBox on my IntelMac Macbook Pro.

There is a nice HOWTO on ths site explaining step-by-step how to do this:
http://www.amikit.amiga.sk/knowledge-base.htm#hardfile

When I do this it is working just fine on Windows, but when I try to launch AmiKit HDF from E-UAE + HiToro - I get an "ENV" requester (C:SetPatch: file is not executable) - the same thing is when I try to copy whole AmiKit folder to Mac and add AmiKit folder in HiToro.

More info:
- My ROM and Amiga system source is Amiga Forever 2k8
- permissions to AmiKit or HDF Amikit file are RW to all (doublechecked that)
- partition is OFS/FFS/RDB (Volume textfield is not active in HiToro - can't type "AmiKit:" from GUI - don't know why)
- used software: HiToro 0.5.2, E-UAE 0.8.29-WIP4

EUAE settings (Folder):

----
kickstart_rom_file=/Users/sw/NEW/AmiKit/Roms/amiga-os-3x0.rom
kickstart_key_file=/Users/sw/NEW/AmiKit/Roms/rom.key
filesystem2=rw,AK0:AmiKit:/Users/sw/NEW/AmiKit/AmiKit,-10
-----

EUAE settings (HDF):

-----
kickstart_rom_file=/Users/sw/NEW/AmiKit/Roms/amiga-os-3x0.rom
kickstart_key_file=/Users/sw/NEW/AmiKit/Roms/rom.key
hardfile2=rw,AK0:/Users/sw/NEW/AmiKit/AmiKit.hdf,32,1,2,512,-10,
----

Any ideas ?

Author AmiKit
Admin
#2 Posted: 8 Feb 2009 16:10 Edited by: AmiKit 
Hello and welcome to the AmiKit Support Forum.

I think that the similar problem has already been solved in this thread. Try it and let us know, please. Thanks!

Author szewski
Partaker
#3 Posted: 8 Feb 2009 18:41 
Thanks for instant replay

Hmm, I tried to rar whole AmiKit windows folder and copy it to AmiKit folder on Leopard - still permission issues

then I've chmoded SetPatch manually on Leopard:

bash-3.2$ ls -la | grep SetPatch
-rwxrwxrwx 1 sw staff 36212 9 mar 2002 SetPatch

still SetPatch ins not executable..

The same thing is when I'm trying to run previously unpacked HDF from rar...

Can someone tell me how some files on HDF have permission issues on one host (Leopard) and working just fine on other host (Windows) ? AmiKit folder was mirrored (with all permissions) on different partition (HDF file) with DO4. They are the same.. from Leopard/Windows POV HDF file is only bunch of 010101.. how come files contained in it act defferently on different systems.. I don't get it.. at all..

Author AmiKit
Admin
#4 Posted: 12 Feb 2009 23:32 
Boot from HDF again, enter the Early Startup Menu (by holding down the both mouse buttons right after the reset), select "boot without startup-sequence" button and then enter the following command:

Protect C:Setpatch +RWED

Now reboot. Any change?

Author szewski
Partaker
#5 Posted: 21 Feb 2009 23:55 
OK, I've managed to install AmiKit on another laptop with _real_ Windows. Currently I've got a HDF SFS file with upgraded AmiKit 1.5.5 with CD0 and CD0.info files in AmiKit\Storage\DosDrivers folder (after 'uaescsi.device' problem). Now I have a simillar problem described in this topic: http://amikit.amiga.sk/forum/index.php?action=vthread&forum=3&topic=53 9

On Windows host Amik hangs on 100%, when i hit ESC the following requester appears:



'Can't load Tereza file'

When I click 'try next'

this requester appears (can't load):




This is on Windows host.. On Mac the output is different. Loading screen is not showing up, hitting ESC doesn't do anything. After a ~30sec I get:



and GURU right after:



It is something with screen mode ? messed E-UAE settings ? oh, one more thing - I've changed IPrefs wait time from 1 to 2.. an then to 3.. no luck..

my E-UAE settings below:

http://www.arven83.republika.pl/amikit.uaerc

Any ideas ?

Author szewski
Partaker
#6 Posted: 22 Feb 2009 17:59 
Ok, thats it...

Everything has a limit.. my patience too.. I've already wasted a one week of my to figure it out what is wrong..

TO ALL INTEL MAC USERS:

If you have a mac and you want to dive into AmiKit/AmigaSYS world - just use Windows XP on VirtualBox and WinUAE on it. Even if you win a EUAE/HDF/permissions/long name/SFS/FFS/AF2k8/Win<-->Mac copy/you_name_it problems you will end up with a laughable EUAE-SDL performance (windowed and fullscreen) in compare to WinUAE.. even on WinXP under VirtualBox.

Note: This is only my >personal< opinion.

Happy AmiKit user

Author ness62
Partaker
#7 Posted: 23 Feb 2009 19:50 Edited by: ness62 
config

JIT on Enable ,translation buffer (KB) 16383

Memory :
P96 8 or 16Mb
Chip 8Mo and fast 0 or 2 and fast 8Mo
Z3 128Mo
Cpu :
68040

------------------------------

if problem of screen

click on prefs/screenmode choose 1024x768 uaegfx and save . <== Jan ,it is ok?


Edit Uaerc

Ex: here on linux
scsi=true
scsi_device=/dev/scd0 (your mac ? by your CDROM drive letter)

Basic questions, I am new here AmiKit Support Forum / Basic questions, I am new here /
 AmiKit to HDF + Intel Mac = ENV problem

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑