AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 2
Members - 0
Most users ever online: 605 [18 Apr 2019 18:52]
Guests - 605 / Members - 0
Basic questions, I am new here AmiKit Support Forum / Basic questions, I am new here /  
 

Cant seem to disable PC hardrives being displayed.

 
Author Toblerone
Partaker
#1 Posted: 2 Apr 2008 12:51 
Hi,

Amikit saw amiga forever and installed perfectly, and is running perfectly now (except for crashing - guru meditation - all the time when i first started running it until i patched it)

But what i dont like personally is having the pc hardrives listed - its a recipe for disaster in my mind especially with all the amiga viruses that were created back in the day.

so i want to turn it off......... but i cant.

if i turn it off in winuae (pressing F12 when amikit is running) and also Save the configuration with the same name as the amikit configuration, it still displays all the drives when i restart amikit.

ive also tried the winuae config option from the amikit launcher menu that appears, this also does not save the results. even if i click Save.

is there some special config file that gets run?
or a file that overwrites my changes if it sees there have been changes?

Thanks for any info.

Author AmiKit
Admin
#2 Posted: 2 Apr 2008 16:22 
Run the AmiKit launcher, click the "Configure WinUAE", mark the "AmiKit_v1" configuration entry and press the "Load" button. Then disable the "Add PC drives at startup" option in "Hard drives" section. Click back to "Configurations" section, mark the "AmiKit_v1" configuration entry and press the "Save" button.

Author Toblerone
Partaker
#3 Posted: 2 Apr 2008 17:19 
Run the AmiKit launcher, click the "Configure WinUAE", mark the "AmiKit_v1" configuration entry and press the "Load" button. Then disable the "Add PC drives at startup" option in "Hard drives" section. Click back to "Configurations" section, mark the "AmiKit_v1" configuration entry and press the "Save" button.

Hi,

Thats what i did, and it doesnt work.

doesnt seem to save it at all, or something overrides it and the PC drives are still mounted and displayed.

there are two configuration files

amikit_v1.uae

default.uae

ive tried amikit_v1.uae so far.

is default.uae anything to do with it?

Author AmiKit
Admin
#4 Posted: 2 Apr 2008 17:26 Edited by: AmiKit 
AmiKit Launcher loads the "AmiKit_v1" config entry if the "Run AmiKit" button is clicked. Anyway, do the same procedure with the "DEFAULT" config entry, just to be sure.

Also, if you use Vista, make sure the write-permissions are enabled for the AmiKit folder. You should find such an option somewhere in Properties if you right-click the AmiKit folder I assume.

Btw. when you save the config in WinUAE check the AmiKit\WinUAE\Configurations\AmiKit_v1.uae file. Does the time-stamp indicate that the file was changed/updated?

Author Toblerone
Partaker
#5 Posted: 2 Apr 2008 20:03 
altering DEFAULT.uae has solved the problem.

amikit_v1.uae doesnt seem to do anything at all.


anyway ive got more questions about amikit and using it, but thats for another thread.

Author Toblerone
Partaker
#6 Posted: 2 Apr 2008 21:18 
actually there is a small follow up to this.

whilst trying to get the pc drives issue working correctly, i noticed that after using amikit i have several files in my windows trashcan.

mostly 'boot.info' and 'configuration.backup' files

what are they for, and most importantly, why are they there?

Author AmiKit
Admin
#7 Posted: 2 Apr 2008 21:49 
If you delete any file using the AmiKit environment they are moved to Windows trashcan. If you do not like this feature, enable the "Don't use Windows Recycle Bin" option in WinUAE Hard drives configuration section.

Author Toblerone
Partaker
#8 Posted: 3 Apr 2008 09:42 
Actually it appears that its WinUAE thats doing this.

Everytime i click 'Save' for the configuration, a 'configuration.backup' file is created in the windows trashcan.

even does it when i havent loaded amikit at all and i am just using the winuae config tool.

strange. not life threatening.... just strange.

dunno what boot.info is, that appears after loading amikit...... even with 'dont use windows recycle bin' turned off. :/

Basic questions, I am new here AmiKit Support Forum / Basic questions, I am new here /
 Cant seem to disable PC hardrives being displayed.

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑