AmiKit - Your Modern Retro Experience
  Forums Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 1
Members - 0
Most users ever online: 123 [22 Apr 2016 12:58]
Guests - 123 / Members - 0
I have a basic question, I am new here AmiKit Support Forum / I have a basic question, I am new here /  
 

Android Amikit MK2 on Galaxy S5 : installation feedback

 
Author ccapublic
Partaker
#1 Posted: 20 May 2016 23:42 Edited by: ccapublic 
Hi,

Just a quick feedback. Once correctly installed, the thing is hell fast ! Really a great experience ! You guys rule !

However I encountered strange behavior during install that I did not observe on Orange PI. I believe there is some weird stuff happening depending on apk being installed on internal storage or external sdcard...

- on S5 after successful download of amikit.hdf, GUI opened with default settings (68000, no jit, no hardfile...). on orange pi it silently loads amikit config file and runs emulation
- in the GUI path to config folder is wrong at first launch. Once fixed I can load the config but...
- ...hardfiles and directory hard drives have wrong path. Part of the path starting at Android folder points to correct files or directory names but looks for the Android folder in internal phone storage instead of external sdcard. Once paths get manually fixed in the GUI or config file, amikit installation process finally starts.

I used Amiga Forever 2012 as installation source and it went well and fast. Then changed the screen resolution and... done...

After installation I removed dh1...dh5 and created my own to point my music and video folders on android side.

A non hd avi file gets decoded roughly 80% normal speed which is technically impressive.
However no way to get sound whatsoever (video is mute, play test sound in ahi prefs does nothing even in Paula mode and AmiAmp freezes right after clicking play button after loading a MP3).

I'll keep checking for mistakes on my side, but this is no big deal for now. I simply enjoyed installing the thing and see it run so fast.

Keep up the good work !

EDIT : Updated issue list (conf filename was indeed fine)

Author AmiKit
Admin
#2 Posted: 21 May 2016 07:49 
Hi Cyril, many thanks for the report. I completely forgot to mention that sound in P96 modes doesn't work well yet.

Author ccapublic
Partaker
#3 Posted: 21 May 2016 11:02 
Thanks Jan. Useful information indeed ;)

BTW installed the same hdf on Orange pi. Horribly slow. I will try to understand why but I'm not sure this is part of my skills.

Have a good week end

Cyril

I have a basic question, I am new here AmiKit Support Forum / I have a basic question, I am new here /
 Android Amikit MK2 on Galaxy S5 : installation feedback

Your Reply Click this icon to move up to the quoted message

 

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 
 
AmiKit Support Forum Powered by Forum Script miniBB ®
↑ Top