AmiKit - Your Modern Retro Experience
  Begin Register Reply Search Statistics AmiKit X  QuickGuide  SATISFIED WITH OUR SUPPORT? 
Online now: Guests - 3
Members - 0
Most users ever online: 605 [18 Apr 2019 18:52]
Guests - 605 / Members - 0
Basic questions, I am new here AmiKit Support Forum / Basic questions, I am new here /  
 

Small questions

 
Author dax
Partaker
#1 Posted: 5 Jun 2014 12:49 
Hi

I use Amikit within pendrive and I'm happy with it. I'm talking about bootable AmiPUP on pendrive.

I've created first "save" on AmiPUP, after first save, next one is doing automatically every logoff. I've done power off before save finished and file system is damaged now (missed files, damaged icons). I think it's not a problem, because I have copy of pendrive for safety - so I can restore original files (means unconfigured system ) to pendrive. But my questions are:

- Is this possible to use save feature manually ONLY? I mean to not being saved automatically, but only if I want to.
- Is this possible to force automatically start UAE in full screen mode ? I mean after AmiPUP starts, with no clicks.

Author dax
Partaker
#2 Posted: 5 Jun 2014 16:56 
I've partially solved my first problem by simply delete "save" file from AmiKit pendrive . No missing files, no damaged icons. Will try to find how to enable/disable save manually.

Author klesterjr
Moderator
#3 Posted: 6 Jun 2014 12:48 
Obviously, you already figured out the answer to your first question.

As to your second question -- I don't think so (not without modifying the existing shutdown script). You can copy your save file to a sub-folder so that AmiPUP can't see it at boot if you want to run a session without auto-saving, but that's not really what you asked for (actually, it needs to be buried one sub-folder deeper for AmiPUP not to find it). My suggestion would be to ask here: http://murga-linux.com/puppy

Some of the options for E-UAE can't be set from the GUI. Additional settings are controlled by a file called .uaerc that is located in the root folder (the folder that opens when you double-click the "Home" icon on the desktop). Click the "eye" in the window toolbar to show all icons. Changing the setting called "use_gui" to "no" will make AmiKit start without displaying the gui first -- most the the other settings are self-explanatory. I have never had much luck with full screen, but I am not an expert in E-UAE. Perhaps someone else can help with that.

Hope this helps a little.

Author dax
Partaker
#4 Posted: 9 Jun 2014 11:51 Edited by: dax 
It helped more than little, now in theory, later I'll do this practically

I tried to make copy of AmiKit pendrive to faster USB 3.0 pendrive, used "Passmark Image USB", but it says "amipup-1.1.0.sfs not found", which is not true, because file is located in proper directory. Is this because of MBR (of pendrive) ?

Author AmiKit
Admin
#5 Posted: 9 Jun 2014 12:33 Edited by: AmiKit 
This might happen if system doesn't have the drivers for the particular pendrive and thus it cannot read from it. I would guess your pendrive is too new for this Linux distro the AmiPUP is built on.

Author klesterjr
Moderator
#6 Posted: 9 Jun 2014 12:36 
dax

It can be hit or miss when copying one flash drive to another with Puppy Linux (AmiPUP). I'm sure there is a technical reason for this, but it is over my head!

My suggestion would be to actually install AmiPUP to the other drive using the option in the menu at the top (first option -- "Install AmiPUP to Flash Drive"). It will ask for an iso image to install (other than the what you booted from) -- there is one located on the folder labeled "AmiKit LIVEBOOT AmiPUP".

I haven't come across a flash drive that I wasn't able to install to, but as I understand it, there are some that don't work with Puppy Linux (AmiPUP).

Good luck!

Author dax
Partaker
#7 Posted: 10 Jun 2014 10:25 Edited by: dax 
Still the same error, so Amikit was right and I have to use original pendrive. Tested 2 pendrives.

Tnx for replies klesterjr & Amikit.

Basic questions, I am new here AmiKit Support Forum / Basic questions, I am new here /
 Small questions

Your Reply Click this icon to move up to the quoted message


 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 

 
AmiKit Support Forum Powered by Forum Script miniBB ®
 ⇑